• Ca1032 Sound Blaster Recon 3D not working 64bit kernel 3.16 and up


    Heyyo,

    So for some reason, ever since they made changes to kernel 3.16 and up? I can’t get my ca1032 Sound Blaster Recon 3D to work in Antergos 64bit on boot using systemctl to create an rc.local file which worked in Ubuntu but is not working in Antergos.

    [url:277uzgq5]http://wiki.antergos.com/ca0132[/url:277uzgq5]

    If you keep losing sound on reboot? We’ll need to setup an automatic way of executing these commands again… My example does this and recreates rc.local used in many distros.

    Open up "Terminal"
    Use this command:

    sudo gedit /etc/systemd/system/rc-local.service
    

    Copy & Paste this command set into gedit, save and exit

      
    >Description=/etc/rc.local Compatibility  
    >ConditionPathExists=/etc/rc.local  
    >  
    >[Service]  
    >Type=forking  
    >ExecStart=/etc/rc.local start  
    >TimeoutSec=0  
    >StandardOutput=tty  
    >RemainAfterExit=yes  
    >SysVStartPriority=99  
    >  
    >[Install]  
    >WantedBy=multi-user.target
    

    Now use this command in terminal:

    sudo gedit /etc/rc.local
    

    Copy & Paste the following code into gedit, save and exit:

    \#!/bin/sh  
    >sudo kill \`ps uax |grep pulseaudio | grep -v grep | awk '{print $2}'\` ; sudo modprobe -r snd-hda-intel; sleep 3; sudo modprobe snd\_hda\_intel model=,auto
    

    Now use this command in Terminal:

    sudo chmod +x /etc/rc.local
    

    Now to activate the systemd service with this command in Terminal:

    sudo systemctl enable rc-local.service
    

    Reboot and test if sound works again after restarting Antergos.

    If I try using that rc.local in Antergos? It fails to load the sound module and then my boot to desktop environment fails as it constantly tries to load sound, network, modem and two other modules I couldn’t make out the names for.

    So? I tried using the modprobe.d method with my file of /etc/modprobe.d/modprobe.conf and also with /etc/modprobe.d/alsa-base.conf …

    options snd\_hda\_intel model=auto
    

    Didn’t work… so then I tried…

    \# rmmod snd\_hda\_intel  
    options snd\_hda\_intel model=auto  
    \# modprobe snd\_hda\_intel model=auto
    

    also didn’t work… this is driving me crazy! Please help! I do enjoy Antergos more than Ubuntu and I’d really love for this to work… it’s really darn annoying to have to always open up the terminal and manually kill snd_hda_hintel, then do rmmod and then

  • Heyyo,

    So for some reason, ever since they made changes to kernel 3.16 and up? I can’t get my ca1032 Sound Blaster Recon 3D to work in Antergos 64bit on boot using systemctl to create an rc.local file which worked in Ubuntu but is not working in Antergos.

    [url:277uzgq5]http://wiki.antergos.com/ca0132[/url:277uzgq5]

    If you keep losing sound on reboot? We’ll need to setup an automatic way of executing these commands again… My example does this and recreates rc.local used in many distros.

    Open up "Terminal"
    Use this command:

    sudo gedit /etc/systemd/system/rc-local.service
    

    Copy & Paste this command set into gedit, save and exit

      
    >Description=/etc/rc.local Compatibility  
    >ConditionPathExists=/etc/rc.local  
    >  
    >[Service]  
    >Type=forking  
    >ExecStart=/etc/rc.local start  
    >TimeoutSec=0  
    >StandardOutput=tty  
    >RemainAfterExit=yes  
    >SysVStartPriority=99  
    >  
    >[Install]  
    >WantedBy=multi-user.target
    

    Now use this command in terminal:

    sudo gedit /etc/rc.local
    

    Copy & Paste the following code into gedit, save and exit:

    \#!/bin/sh  
    >sudo kill \`ps uax |grep pulseaudio | grep -v grep | awk '{print $2}'\` ; sudo modprobe -r snd-hda-intel; sleep 3; sudo modprobe snd\_hda\_intel model=,auto
    

    Now use this command in Terminal:

    sudo chmod +x /etc/rc.local
    

    Now to activate the systemd service with this command in Terminal:

    sudo systemctl enable rc-local.service
    

    Reboot and test if sound works again after restarting Antergos.

    If I try using that rc.local in Antergos? It fails to load the sound module and then my boot to desktop environment fails as it constantly tries to load sound, network, modem and two other modules I couldn’t make out the names for.

    So? I tried using the modprobe.d method with my file of /etc/modprobe.d/modprobe.conf and also with /etc/modprobe.d/alsa-base.conf …

    options snd\_hda\_intel model=auto
    

    Didn’t work… so then I tried…

    \# rmmod snd\_hda\_intel  
    options snd\_hda\_intel model=auto  
    \# modprobe snd\_hda\_intel model=auto
    

    also didn’t work… this is driving me crazy! Please help! I do enjoy Antergos more than Ubuntu and I’d really love for this to work… it’s really darn annoying to have to always open up the terminal and manually kill snd_hda_hintel, then do rmmod and then

  • Heyyo,

    Nothing? No one? Sigh… oh well, I think I am going to just revert back to using Linux Mint or Ubuntu Mate since those work fine with the rc.local fix in 64bit that doesn’t work in Antergos. This headache ain’t worth it if I can’t even get a little help.

    /cancelled monthly donation tbh

Posts 3Views 1129
Log in to reply