• Hidden boot messages?


    Dear All,

    this is more of a technical question than a request for help. I see that in Antergos the boot messages have been hidden. Once you select the grub entry the screen goes black until lightdm comes up. How was this technically achieved? I like it and would like to reproduce it on an Arch box I have. Was the logging from Systemd directed somewhere else, or was a different framebuffer used?

    Also, is it technically possible to substitute the black screen with another framebuffer background image?

    Thank you for all your help

    Valerio

  • Dear All,

    this is more of a technical question than a request for help. I see that in Antergos the boot messages have been hidden. Once you select the grub entry the screen goes black until lightdm comes up. How was this technically achieved? I like it and would like to reproduce it on an Arch box I have. Was the logging from Systemd directed somewhere else, or was a different framebuffer used?

    Also, is it technically possible to substitute the black screen with another framebuffer background image?

    Thank you for all your help

    Valerio

  • Not sure if it was supposed to show up “black”…
    Anyways, you can use some boot splash screen with a “Black” theme if you like absolute minimilism even on boot splash screen xD
    Or you can replace your lovely “black” screen with plymouth and [this Antergos theme[/url:27cz0ifu] on your Antergos install.
    Obviously, there are shit load of arch plymouth themes available on the internet for you.

    But I don’t think there’s any “Black screen” theme that you like for plymouth(or any other boot splash screen). “Black” screen is usually considerd as problem/bug.]0

    Archlinux x64

    AMD A4-3305M Processor
    6GB RAM
    1GB+512MB Hybrid AMD GPU

  • Well, some of the developers wrote in the forum that Plymouth was not stable on Arch (and hence in Antergos), so they would not add it to Antergos, but only hide the boot messages. I think it is intentional then!

    See here (last post):

    [http://forum.antergos.com/viewtopic.php?f=6&t=2007&p=9232&hilit=plymouth#p9232][0]">viewtopic.php?f=6&t=2007&p=9232&hilit=plymouth#p9232

    I was just wondering how they did it

    Valerio

    [0]: <a href=

  • Oh, Lol, I thought Antergos comes by default with plymouth and that theme.
    I’ve never installed antergos and I guess then the lovely “Black” screen is legit xD

    So, you either wait for a reply from one of the developers or Try using plymouth alternatives.

    Cheers!

    Archlinux x64

    AMD A4-3305M Processor
    6GB RAM
    1GB+512MB Hybrid AMD GPU

  • If using Grub edit /etc/default/grub
    change

    GRUB\_CMDLINE\_LINUX\_DEFAULT="quiet splash"
    

    to

      
    and update Grub  
    sudo update-grub
    
  • Thanks Hoover, but that does the opposite of what I asked. This shows the boot messages on Antergos, which usually shows them

    What I am trying to do is the opposite: on Arch, where normally the messages are shown, I want to hide them like in Antergos.

    Thank you anyway!

    Valerio

  • If you’re using GRUB you can hide boot-messages in /etc/default/grub with

    GRUB\_CMDLINE\_LINUX\_DEFAULT="quiet splash"
    

    and

    sudo update-grub
    

    or using [grub-customizer[/url:hpd31iaw]

    For Syslinux you’ll need to change /boot/syslinux/syslinux.cfg and add

    root=" .... quiet loglevel=0"
    

    See also Silent Boot on Archwiki[/url:hpd31iaw]]0

  • But I checked and Antergos does not have the ‘splash’ option in the /etc/default/grub

    It must be something else…

    Valerio

  • HI,

    The “quiet” parameter is all that is required to hide most of the output shown during boot. That is the setting used by default in Antergos.

    Best Regards,

  • Uhmm… Something must then be different in my Arch installation.

    Thank you very much for the information, lots.O.logs

    Valerio

Posts 11Views 2368
Log in to reply