• Strange Problem with the ä on my keyboard


    Hi,
    I’m running Antergos Linux (3.17.2-1-ARCH) with GNOME Shell 3.14.1.5.

    Recently I’m running into a rather strange problem regarding the ä on my keyboard. I’m located in Switzerland and I’m using a swiss-german keyboard layout ([https://en.wikipedia.org/wiki/File:KB_Swiss.svg][0]">[https://en.wikipedia.org/wiki/File:KB_Swiss.svg][1]).

    Since a few days I’m unable to type it using the ‘ä’-character using it’s designated key but I’m able to type it using the combination of ‘Super Right’ + ‘ä’.
    Using xev I was able to determine that the key isn’t registered correctly.

    this is the ‘ö’ key:

    KeyPress event, serial 36, synthetic NO, window 0x1c00001,
    root 0x95, subw 0x0, time 6838051, (832,428), root:(883,536),
    state 0x10, keycode 47 (keysym 0xf6, odiaeresis), same_screen YES,
    XLookupString gives 2 bytes: (c3 b6) "ö"
    XmbLookupString gives 2 bytes: (c3 b6) "ö"
    XFilterEvent returns: False
    KeyRelease event, serial 36, synthetic NO, window 0x1c00001,
    root 0x95, subw 0x0, time 6838147, (832,428), root:(883,536),
    state 0x10, keycode 47 (keysym 0xf6, odiaeresis), same_screen YES,
    XLookupString gives 2 bytes: (c3 b6) "ö"
    XFilterEvent returns: False

    this is the output for the ‘ä’ key:

    FocusOut event, serial 36, synthetic NO, window 0x1c00001,
    mode NotifyGrab, detail NotifyAncestor
    FocusIn event, serial 36, synthetic NO, window 0x1c00001,
    mode NotifyUngrab, detail NotifyAncestor
    KeymapNotify event, serial 36, synthetic NO, window 0x0,
    keys: 93 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0
    0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0

    full log here: [http://pastie.org/private/xydfmv2geeqb64mb1dqq9a][0]">[http://pastie.org/private/xydfmv2geeqb64mb1dqq9a][2]
    Does anybody have an idea on how to fix this?

    [0]: <a href=
    [1]: https://en.wikipedia.org/wiki/File:KB_Swiss.svg
    [2]: http://pastie.org/private/xydfmv2geeqb64mb1dqq9a

  • Hi,
    I’m running Antergos Linux (3.17.2-1-ARCH) with GNOME Shell 3.14.1.5.

    Recently I’m running into a rather strange problem regarding the ä on my keyboard. I’m located in Switzerland and I’m using a swiss-german keyboard layout ([https://en.wikipedia.org/wiki/File:KB_Swiss.svg][0]">[https://en.wikipedia.org/wiki/File:KB_Swiss.svg][1]).

    Since a few days I’m unable to type it using the ‘ä’-character using it’s designated key but I’m able to type it using the combination of ‘Super Right’ + ‘ä’.
    Using xev I was able to determine that the key isn’t registered correctly.

    this is the ‘ö’ key:

    KeyPress event, serial 36, synthetic NO, window 0x1c00001,
    root 0x95, subw 0x0, time 6838051, (832,428), root:(883,536),
    state 0x10, keycode 47 (keysym 0xf6, odiaeresis), same_screen YES,
    XLookupString gives 2 bytes: (c3 b6) "ö"
    XmbLookupString gives 2 bytes: (c3 b6) "ö"
    XFilterEvent returns: False
    KeyRelease event, serial 36, synthetic NO, window 0x1c00001,
    root 0x95, subw 0x0, time 6838147, (832,428), root:(883,536),
    state 0x10, keycode 47 (keysym 0xf6, odiaeresis), same_screen YES,
    XLookupString gives 2 bytes: (c3 b6) "ö"
    XFilterEvent returns: False

    this is the output for the ‘ä’ key:

    FocusOut event, serial 36, synthetic NO, window 0x1c00001,
    mode NotifyGrab, detail NotifyAncestor
    FocusIn event, serial 36, synthetic NO, window 0x1c00001,
    mode NotifyUngrab, detail NotifyAncestor
    KeymapNotify event, serial 36, synthetic NO, window 0x0,
    keys: 93 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0
    0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0

    full log here: [http://pastie.org/private/xydfmv2geeqb64mb1dqq9a][0]">[http://pastie.org/private/xydfmv2geeqb64mb1dqq9a][2]
    Does anybody have an idea on how to fix this?

    [0]: <a href=
    [1]: https://en.wikipedia.org/wiki/File:KB_Swiss.svg
    [2]: http://pastie.org/private/xydfmv2geeqb64mb1dqq9a

Posts 2Views 749
Log in to reply