• \[SOLVED\] oblogout error


    Me again :D

    My oblogout suddenloy stopped working.
    This is what terminal tells me.

    Traceback (most recent call last):  
    File "/usr/bin/oblogout", line 97, in <module\>  
    sys.exit(main())  
    File "/usr/bin/oblogout", line 92, in main  
    app = OpenboxLogout(config, local\_mode)  
    File "/usr/lib/python2.7/site-packages/oblogout/\_\_init\_\_.py", line 82, in \_\_init\_\_  
    self.load\_config(config)  
    File "/usr/lib/python2.7/site-packages/oblogout/\_\_init\_\_.py", line 176, in load\_config  
    self.parser.read(config)  
    File "/usr/lib/python2.7/ConfigParser.py", line 305, in read  
    self.\_read(fp, filename)  
    File "/usr/lib/python2.7/ConfigParser.py", line 512, in \_read  
    raise MissingSectionHeaderError(fpname, lineno, line)  
    ConfigParser.MissingSectionHeaderError: File contains no section headers.  
    file: /etc/oblogout.conf, line: 1  
    '\\xef\\xbb\\xbf[settings]\\n'  
    
    

    I checked my /bin/oblogout and my /etc/oblogout.conf with a friends files - identical, but he has no issues.

  • Me again :D

    My oblogout suddenloy stopped working.
    This is what terminal tells me.

    Traceback (most recent call last):  
    File "/usr/bin/oblogout", line 97, in <module\>  
    sys.exit(main())  
    File "/usr/bin/oblogout", line 92, in main  
    app = OpenboxLogout(config, local\_mode)  
    File "/usr/lib/python2.7/site-packages/oblogout/\_\_init\_\_.py", line 82, in \_\_init\_\_  
    self.load\_config(config)  
    File "/usr/lib/python2.7/site-packages/oblogout/\_\_init\_\_.py", line 176, in load\_config  
    self.parser.read(config)  
    File "/usr/lib/python2.7/ConfigParser.py", line 305, in read  
    self.\_read(fp, filename)  
    File "/usr/lib/python2.7/ConfigParser.py", line 512, in \_read  
    raise MissingSectionHeaderError(fpname, lineno, line)  
    ConfigParser.MissingSectionHeaderError: File contains no section headers.  
    file: /etc/oblogout.conf, line: 1  
    '\\xef\\xbb\\xbf[settings]\\n'  
    
    

    I checked my /bin/oblogout and my /etc/oblogout.conf with a friends files - identical, but he has no issues.

  • I just --recofigured and reinstalled oblogout. Same problem.

  • You have a faulty config file /etc/oblogout.conf

    Check it, if you can’t find the mistake post it here

    Cheers!

  • My current /etc/oblogout.conf

      
    usehal = false  
      
    [looks]  
    opacity = 80  
    bgcolor = black  
    buttontheme = doom  
    buttons = logout, restart, shutdown, suspend, lock  
      
    [shortcuts]  
    cancel = Escape  
    shutdown = S  
    restart = R  
    suspend = U  
    logout = L  
    lock = K  
      
    [commands]  
    shutdown = systemctl poweroff  
    restart = systemctl reboot  
    suspend = systemctl suspend  
    logout = openbox --exit  
    lock = dm-tool lock &  
    
    
  • Interesting. I just deleted the config file and created a new one. Everything works fine now.
    *confused*

Posts 6Views 1442
Log in to reply