• \[SOLVED\] Login manager (lightdm) issue


    In the last few days I installed Antergos with a different desktop (Kde, Gnome, Cinnamon) each time to find out which one better suits my needs.

    Antergos seems to always install its lightdm + webkit based custom theme (which, by the way, I really love). However there seems to be a problem: sometimes when lightdm starts, all I can see is a black screen (no mouse pointer either) and I have to switch to another tty and “pkill lightdm” to make it appear.

    Logs in /var/log/lightdm don’t seem to show anything unusual. Has anyone experienced the same issue?

  • In the last few days I installed Antergos with a different desktop (Kde, Gnome, Cinnamon) each time to find out which one better suits my needs.

    Antergos seems to always install its lightdm + webkit based custom theme (which, by the way, I really love). However there seems to be a problem: sometimes when lightdm starts, all I can see is a black screen (no mouse pointer either) and I have to switch to another tty and “pkill lightdm” to make it appear.

    Logs in /var/log/lightdm don’t seem to show anything unusual. Has anyone experienced the same issue?

  • Hi,

    I experience the same issue. It seems to be almost random. It’s doesn’t happen often, so I havent looked into it. If I find anything I will let you know!

    Cheers!

  • It hangs quite often here: either it shows a blank screen, or it hangs after entering the password.
    As much as i like the custom theme, I’m forced to change it… how can I replace it with something else? I don’t want to use “heavy” ones like gdm, perhaps the bug won’t show if I only use lighdm without the webkit addon?

  • I’m using [lxdm[/url:1assa9mx]. There are [Antergos-[/url:1assa9mx] and Archlinux-Themes[/url:1assa9mx] available.]1]0

  • I have the same issue, but for now, not something to be consider as affecting my daily work with computer. Like Dustin said, it doesn’t happen all the time.

    Asus X201EP | Intel Celeron 2x 1.10 GHz | 4 GB DDR3 RAM | Antergos 64-Bit.

  • Nevermind, I’m keeping lightdm as I can’t do without Antergos’ theme 🙂 Also, I’m using light-locker as my current screenlocker, which requires lightdm anyway…

    I wish I could restart lightdm using an hotkey when it hangs instead of switching to another console, but I guess it would require quite a bit of work.

  • You can use [b:3as0bk0q]xbindkeys[/b:3as0bk0q] to create a keyboard shortcut that executes this command:[command:3as0bk0q]sudo systemctl restart lightdm[/command:3as0bk0q]
    Though for it to work you would have to have sudo configured to not ask for a password. Not a big deal for me as I am the only user of my system, but for you it may be different so obviously it’s your decision

    [https://wiki.archlinux.org/index.php/Xbindkeys][0]">[https://wiki.archlinux.org/index.php/Xbindkeys][1]

    [0]: <a href=
    [1]: https://wiki.archlinux.org/index.php/Xbindkeys

  • Great! Thanks so much Dustin

    @“lots.0.logs”:xjctqftk said:

    Though for it to work you would have to have sudo configured to not ask for a password. Not a big deal for me as I am the only user of my system[/quote:xjctqftk]
    No problem, I also have sudo configured like that

  • Adding xbindkeys to my user’s .xinitrc as the wiki suggests doesn’t seem to work, probably because lightdm is started as root and I’m not logged in yet. So I tried to run it from rc.local (after enabling its systemd service and putting the rc in /etc) and it worked the first time, but now all I get is a core dump.

    Can you please tell me what is the right way to load xbindkeys at startup so that the hotkey is already active when lightdm appears?

  • Try creating a service file and then enabling it with systemd:[config=/usr/lib/systemd/system/xbindkeys.service:1nod240y][Unit]
    Description=Xbindkeys

    [Service]
    ExecStart=/usr/bin/xbindkeys -f /home/your-user-name/.xbindkeysrc

    [Install]
    WantedBy=multi-user.target[/config:1nod240y]Let me know if it works!

    Cheers!

  • It didn’t work, so I tried a “systemctl status xbindkeys.service” and it gave me the following:

    xbindkeys.service - Xbindkeys  
    Loaded: loaded (/usr/lib/systemd/system/xbindkeys.service; enabled)  
    Active: failed (Result: core-dump) since Sun 2014-11-09 12:29:11 CET; 43s ago  
    Process: 229 ExecStart=/usr/bin/xbindkeys -f /etc/xbindkeysrc (code=dumped, signal=SEGV)  
    Main PID: 229 (code=dumped, signal=SEGV)
    

    However if I manually run “/usr/bin/xbindkeys -f /etc/xbindkeysrc” it works just fine. Weird…

  • Try adding " -n " to the service file command…

  • Same as before…

    Loaded: loaded (/usr/lib/systemd/system/xbindkeys.service; enabled)  
    Process: 223 ExecStart=/usr/bin/xbindkeys -f /etc/xbindkeysrc -n (code=dumped, signal=SEGV)  
    Main PID: 223 (code=dumped, signal=SEGV)
    
  • I managed to “solve” the problem by simply enabling the ctrl-alt-backspace hotkey (which kills X, thus restarting lightdm).

    Basically I created the file /etc/X11/xorg.conf with the following content:

    Section "ServerFlags"  
    Option "DontZap" "false"  
    EndSection  
      
    Section "InputClass"  
    Identifier "Keyboard Defaults"  
    MatchIsKeyboard "yes"  
    Option "XkbOptions" "terminate:ctrl\_alt\_bksp"  
    EndSection
    
  • I forgot all about that option. Thanks for posting it here 🙂

  • Great. There are several threads about this issue (one of them is mine). Maybe you can pin this?

Posts 17Views 6226
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.