• Antergos grub don't boot


    I use antergos and install antother linux distribution in the same grub from antergros. Someone is going wrong and there is create a new grub.
    When I am going back in my UEFI bios and choose antergos grub, antergos don’t boot.
    Other distributions and windows are boot

    What can I do?
    This is my disk setup

    [http://pastebin.com/azEJzps5][0]">[http://pastebin.com/azEJzps5][1]

    When I boot in antergos I see this error
    resume: no device specified for hibernation

    [0]: <a href=
    [1]: http://pastebin.com/azEJzps5

  • I use antergos and install antother linux distribution in the same grub from antergros. Someone is going wrong and there is create a new grub.
    When I am going back in my UEFI bios and choose antergos grub, antergos don’t boot.
    Other distributions and windows are boot

    What can I do?
    This is my disk setup

    [http://pastebin.com/azEJzps5][0]">[http://pastebin.com/azEJzps5][1]

    When I boot in antergos I see this error
    resume: no device specified for hibernation

    [0]: <a href=
    [1]: http://pastebin.com/azEJzps5

  • Looks like there is a syntax error in your menu entry for antergos. Edit your grub.cfg and remove the “resume” option from the boot command.

    Cheers!

  • How can I do that? With a live session? Where exact can I find grub.cfg?
    Edit:
    I have do a live session but I can’t find anything in the section boot of my antergos partition.

  • My antergos partion is a efi system. This is automatic setup by installing.
    Is this normal?

  • Hi,

    Please boot using the Live ISO, open “Files/Nautilus”, click “Antergos-EFI” (should be listed in the left sidebar), right click>>Open Terminal Here, and finally run these commands[command:1eflspow]sudo fdisk -l
    sudo ls -lR[/command:1eflspow]

    Post the output here. Cheers!

  • You mean under devices when I open “files” I don’t see there my antergos partition.
    With gparted I see there my antergos partition with the flag “boot” and ext4. I have also a fat32 system with the flag "boot"
    My antergos system must have only ext4 and not the flag “boot” I think.

    I hope I can help you with this because I don’t see “antergos-efi” on the left.

  • Hmm…did you boot the live ISO in UEFI mode or legacy/BIOS boot mode when you first installed Antergos? It sounds like you might have installed it using legacy/BIOS boot. Do you see anything listed under Devices when you open “Files/Nautilus”? (eg: Antergos-Root). If not, manually mount it using this command[command:e0olut5m]sudo mount /dev/sdaX /mnt ## Replace “X” with the correct partition number[/command:e0olut5m]After it is mounted you should see it listed under Devices in the file manager so you can follow my previous instructions :-)

    Best Regards,

  • First time I must do legacy otherwise the usb don’t start.
    What is the root pasword? I need this for the terminal.
    I have try live and root but this are not good.

  • There is no password, just press Enter.

  • If you installed Antergos from the Live ISO booted in legacy mode then you must boot Antergos in legacy mode. Have you tried that.?

  • I have tried legacy and UEFI both. I can’t use the terminal with only enter.

  • Hi,

    Are you able to boot into the live system successfully? Please explain more details, so I can advise you. Thanks.

  • Yes I can boot live system without any problems. I have internet and when I open the terminal, it ask for a pasword with only enter don’t work and “root” and “live” don’t also work.
    In a other linux system with krusader root I can log in the antergos partition and open the directories but in dolpin I don’t see the partition because I can’t mount it. I have open with gparted the partition and see that the partition is ext4 with the flag boot. I think that is the reason I can’t mount
    When I take a look with krusader I don’t see anything in the boot directory.
    Can I try another live linux distribution where the root is work if antergos don’t work with the root and do the terminal codes?

    I hope this can help you

  • How are you launching the terminal? Did you try to open a normal terminal first, and then use sudo or su for root access like this:

    1. Press Alt + F2
    2. type " gnome-terminal " and then press Enter
    3. Type " su " and press Enter
    4. do stuff as root…

    If you intended to have antergos running on UEFI boot mode then you will need to reinstall it because it’s currently configured for bios boot. It should boot successfully if you enabled legacy boot mode again. Is that not the case?

    Best Regards,

  • I have take a look in the bios and I see by CSM in my bios by boot device: UEFI only and by secure boot I see other OS.
    That mean I have set up the install with UEFI and not legacy bios.
    I go try your another suggestions right now.

    I have try with the terminal mount that don’t work. I go now try legacy boot.

    I have try enable legacy bios and nothing boot, after that back to UEFI only and I can’t also boot.

    I am thinking:
    Is it possible to reinstall the grub? Can I shroot into it?
    If possible how does this work?

Posts 16Views 4607
Log in to reply