• No default File Manager


    GNOME 3.14.1

    If I click Activities > Files - nothing happens. Returns to desktop.

    I’ve tried removing it from favorites and added it back to favorites, same thing. Just returns to desktop.

    If I search for “Files” and run it that way, same thing. Just returns to desktop.

    If I right-click Files and select “New Window”. Just returns to desktop.

    Suggstions?

  • GNOME 3.14.1

    If I click Activities > Files - nothing happens. Returns to desktop.

    I’ve tried removing it from favorites and added it back to favorites, same thing. Just returns to desktop.

    If I search for “Files” and run it that way, same thing. Just returns to desktop.

    If I right-click Files and select “New Window”. Just returns to desktop.

    Suggstions?

  • Hi,

    Please post your xsession log after a few attempts to open the Files app. Thanks.

  • I assume you mean ~/xsession-errors ?? That file is zero bytes. The xsession-errors.old is also zero bytes

  • You probably updated some dependency(for some other software maybe).
    So, post your pacman log as well.

    and try running this in terminal
    [code:qiemp1bz]nautilus[/code:qiemp1bz]

    If you see some ‘libxxx’ error in terminal, you either need to update your Antergos or downgrade that damn dependency/package.

    Archlinux x64

    AMD A4-3305M Processor
    6GB RAM
    1GB+512MB Hybrid AMD GPU

  • When I run “nautilus” from the commands prompt nothing happens. (No errors, just goes back to commands prompt.)

    [[email protected] ~]$nautilus  
    [[email protected] ~]$  
      
    [[email protected] ~]$ which nautilus  
    /usr/bin/nautilus  
      
    [[email protected] ~]$ ls -l /usr/bin/nautilus  
    -rwxr-xr-x 1 root root 1376776 Oct 16 07:15 /usr/bin/nautilus
    

    pacman logs:

    [2014-11-04 14:24] [PACMAN] Running 'pacman --color auto -Sy'  
    [2014-11-04 14:24] [PACMAN] synchronizing package lists  
    [2014-11-04 14:24] [PACMAN] Running 'pacman --color auto -S -u'  
    [2014-11-04 14:24] [PACMAN] starting full system upgrade  
    [2014-11-04 14:24] [PACMAN] upgraded dhcpcd (6.5.1-1 -\> 6.6.0-1)  
    [2014-11-04 14:24] [PACMAN] upgraded java-runtime-common (2-1 -\> 2-2)  
    [2014-11-04 14:24] [PACMAN] upgraded libwbclient (4.1.12-1 -\> 4.1.13-1)  
    [2014-11-04 14:24] [PACMAN] upgraded make (4.0-2 -\> 4.1-1)  
    [2014-11-04 14:24] [PACMAN] upgraded os-prober (1.58-3 -\> 1.64-1)  
    [2014-11-04 14:24] [PACMAN] upgraded tdb (1.3.0-2 -\> 1.3.1-1)  
    [2014-11-04 14:24] [PACMAN] upgraded tevent (0.9.21-3 -\> 0.9.22-1)  
    [2014-11-04 14:24] [PACMAN] upgraded smbclient (4.1.12-1 -\> 4.1.13-1)  
    [2014-11-05 18:00] [PACMAN] Running 'pacman --color auto -Sy'  
    [2014-11-05 18:00] [PACMAN] synchronizing package lists  
    [2014-11-05 18:00] [PACMAN] Running 'pacman --color auto -S -u'  
    [2014-11-05 18:00] [PACMAN] starting full system upgrade  
    [2014-11-05 18:00] [PACMAN] upgraded efivar (0.11-1 -\> 0.15-1)  
    [2014-11-05 18:00] [PACMAN] upgraded elfutils (0.159-1 -\> 0.160-1)
    
  • Hi,

    First try running this command:[command:2n96glox]sudo pacman -Syyu[/command:2n96glox] If that doesnt help, post your journal logs here. Be sure to try opening the Files app a few times before grabbing the log.

    Cheers!

  • I tired the pacman statement, didn’t help. Then tried a “journalctl -f” to watch activity. There is nothing generated when I Click “Files” icon. I tried it over and over and over. Not a new line scrolled from journalctl.

    If I click “Activities” nothing scrolls by. However, as soon as I start typing the letters f, i, l, e, s to search for “files” I get some scrolling from journalctl:

      
    Nov 15 20:26:13 dldsk01 org.gnome.Calculator.SearchProvider[582]: Error: ErrorCode.UNKNOWN\_VARIABLE  
    Nov 15 20:26:13 dldsk01 org.gnome.Caribou.Daemon[582]: \*\* (caribou:742): WARNING \*\*: AT-SPI: Error in GetItems, sender=org.freedesktop.DBus, error=The name :1.32 was not provided by any .service files  
    Nov 15 20:26:13 dldsk01 org.gnome.seahorse.Application[582]: (seahorse:5484): Gtk-WARNING \*\*: Theme directory 48x48/app of theme Numix-Square has no size field  
    Nov 15 20:26:13 dldsk01 org.gnome.Photos[582]: GEGL-geglmodule.c-Message: Module '/usr/lib/gegl-0.2/ff-load.so' load error: /usr/lib/gegl-0.2/ff-load.so: undefined symbol: av\_read\_packet  
    Nov 15 20:26:13 dldsk01 org.gnome.Bijiben.SearchProvider[582]: (bijiben-shell-search-provider:5487): GLib-GObject-CRITICAL \*\*: g\_object\_unref: assertion 'G\_IS\_OBJECT (object)' failed  
    Nov 15 20:26:13 dldsk01 org.gnome.OnlineMiners.MediaServer[582]: Gom-Message: Setting scheduler policy to SCHED\_IDLE  
    Nov 15 20:26:13 dldsk01 dleyna-server-service[5513]: dLeyna core version 0.4.0  
    Nov 15 20:26:13 dldsk01 dleyna-server-service[5513]: dleyna-server-service version 0.4.0  
    Nov 15 20:26:13 dldsk01 org.gnome.OnlineMiners.GData[582]: Gom-Message: Setting scheduler policy to SCHED\_IDLE  
    Nov 15 20:26:13 dldsk01 dleyna-server-service[5513]: Type[0] Level[0x13] Mask[0x4C] Flags[0x4F]  
    Nov 15 20:26:13 dldsk01 dleyna-server-service[5513]: Load file [/home/rich/.config/dleyna-server-service.conf]  
    Nov 15 20:26:13 dldsk01 dleyna-server-service[5513]: [General settings]  
    Nov 15 20:26:13 dldsk01 dleyna-server-service[5513]: Never Quit: F  
    Nov 15 20:26:13 dldsk01 dleyna-server-service[5513]: Connector Name: dbus  
    Nov 15 20:26:13 dldsk01 dleyna-server-service[5513]: [Logging settings]  
    Nov 15 20:26:13 dldsk01 dleyna-server-service[5513]: Log Type : 0  
    Nov 15 20:26:13 dldsk01 dleyna-server-service[5513]: Log Level: 0x13  
    Nov 15 20:26:13 dldsk01 dleyna-server-service[5513]: [Network filtering settings]  
    Nov 15 20:26:13 dldsk01 dleyna-server-service[5513]: Enabled : F  
    Nov 15 20:26:13 dldsk01 dleyna-server-service[5513]: Entries: (null)  
    Nov 15 20:26:13 dldsk01 org.gnome.OnlineMiners.Flickr[582]: Gom-Message: Setting scheduler policy to SCHED\_IDLE  
    Nov 15 20:26:13 dldsk01 org.gnome.OnlineMiners.Facebook[582]: Gom-Message: Setting scheduler policy to SCHED\_IDLE  
    Nov 15 20:26:13 dldsk01 dleyna-renderer-service[5547]: dLeyna core version 0.4.0  
    Nov 15 20:26:13 dldsk01 dleyna-renderer-service[5547]: dleyna-renderer-service version 0.4.0  
    Nov 15 20:26:13 dldsk01 dleyna-renderer-service[5547]: Type[0] Level[0x13] Mask[0x4C] Flags[0x4F]  
    Nov 15 20:26:13 dldsk01 dleyna-renderer-service[5547]: Load file [/home/rich/.config/dleyna-renderer-service.conf]  
    Nov 15 20:26:13 dldsk01 dleyna-renderer-service[5547]: [General settings]  
    Nov 15 20:26:13 dldsk01 dleyna-renderer-service[5547]: Never Quit: F  
    Nov 15 20:26:13 dldsk01 dleyna-renderer-service[5547]: Connector Name: dbus  
    Nov 15 20:26:13 dldsk01 dleyna-renderer-service[5547]: [Logging settings]  
    Nov 15 20:26:13 dldsk01 dleyna-renderer-service[5547]: Log Type : 0  
    Nov 15 20:26:13 dldsk01 dleyna-renderer-service[5547]: Log Level: 0x13  
    Nov 15 20:26:13 dldsk01 dleyna-renderer-service[5547]: [Network filtering settings]  
    Nov 15 20:26:13 dldsk01 dleyna-renderer-service[5547]: Enabled : F  
    Nov 15 20:26:13 dldsk01 dleyna-renderer-service[5547]: Entries: (null)  
    Nov 15 20:26:13 dldsk01 dleyna-renderer-service[5547]: Calling GetRenderers method  
    Nov 15 20:26:13 dldsk01 org.gnome.Photos[582]: \*\* (gnome-photos:5486): WARNING \*\*: Unable to read results of FetchIdsJob: Interrupted  
    Nov 15 20:26:13 dldsk01 org.gnome.Calculator.SearchProvider[582]: Error: ErrorCode.UNKNOWN\_VARIABLE  
    Nov 15 20:26:13 dldsk01 org.gnome.Caribou.Daemon[582]: \*\* (caribou:742): WARNING \*\*: AT-SPI: Error in GetItems, sender=org.freedesktop.DBus, error=The name :1.37 was not provided by any .service files  
    Nov 15 20:26:13 dldsk01 org.gnome.Bijiben.SearchProvider[582]: (bijiben-shell-search-provider:5487): GLib-GObject-CRITICAL \*\*: g\_object\_unref: assertion 'G\_IS\_OBJECT (object)' failed  
    Nov 15 20:26:14 dldsk01 org.gnome.Photos[582]: (gnome-photos:5486): GLib-GIO-CRITICAL \*\*: g\_dbus\_proxy\_call\_internal: assertion 'G\_IS\_DBUS\_PROXY (proxy)' failed  
    Nov 15 20:26:14 dldsk01 dleyna-renderer-service[5547]: Client :1.142 lost  
    Nov 15 20:26:14 dldsk01 org.gnome.Calculator.SearchProvider[582]: Error: ErrorCode.UNKNOWN\_VARIABLE  
    Nov 15 20:26:14 dldsk01 org.gnome.Bijiben.SearchProvider[582]: (bijiben-shell-search-provider:5487): GLib-GObject-CRITICAL \*\*: g\_object\_unref: assertion 'G\_IS\_OBJECT (object)' failed  
    Nov 15 20:26:14 dldsk01 org.gnome.Photos[582]: GEGL-geglmodule.c-Message: Module '/usr/lib/gegl-0.2/ff-load.so' load error: /usr/lib/gegl-0.2/ff-load.so: undefined symbol: av\_read\_packet  
    Nov 15 20:26:14 dldsk01 dleyna-renderer-service[5569]: dLeyna core version 0.4.0  
    Nov 15 20:26:14 dldsk01 dleyna-renderer-service[5569]: dleyna-renderer-service version 0.4.0  
    Nov 15 20:26:14 dldsk01 dleyna-renderer-service[5569]: Type[0] Level[0x13] Mask[0x4C] Flags[0x4F]  
    Nov 15 20:26:14 dldsk01 dleyna-renderer-service[5569]: Load file [/home/rich/.config/dleyna-renderer-service.conf]  
    Nov 15 20:26:14 dldsk01 dleyna-renderer-service[5569]: [General settings]  
    Nov 15 20:26:14 dldsk01 dleyna-renderer-service[5569]: Never Quit: F  
    Nov 15 20:26:14 dldsk01 dleyna-renderer-service[5569]: Connector Name: dbus  
    Nov 15 20:26:14 dldsk01 dleyna-renderer-service[5569]: [Logging settings]  
    Nov 15 20:26:14 dldsk01 dleyna-renderer-service[5569]: Log Type : 0  
    Nov 15 20:26:14 dldsk01 dleyna-renderer-service[5569]: Log Level: 0x13  
    Nov 15 20:26:14 dldsk01 dleyna-renderer-service[5569]: [Network filtering settings]  
    Nov 15 20:26:14 dldsk01 dleyna-renderer-service[5569]: Enabled : F  
    Nov 15 20:26:14 dldsk01 dleyna-renderer-service[5569]: Entries: (null)  
    Nov 15 20:26:14 dldsk01 dleyna-renderer-service[5569]: Calling GetRenderers method  
    Nov 15 20:26:14 dldsk01 org.gnome.Photos[582]: (gnome-photos:5563): GLib-GIO-CRITICAL \*\*: g\_dbus\_proxy\_call\_internal: assertion 'G\_IS\_DBUS\_PROXY (proxy)' failed  
    Nov 15 20:26:14 dldsk01 dleyna-renderer-service[5569]: Client :1.154 lost  
    Nov 15 20:26:14 dldsk01 dleyna-renderer-service[5547]: dLeyna: Exit
    

    If I select the “Files” in the search results, nothing else scrolls.

  • My issue, I don’t know if it was the same, while using Gnome Tweaks Tool.

    1. If Desktop Setting – Icon on Desktop = ON. Nautilus from app list won’t show up (even it tells me that it runs). But I can access it from desktop icon.
    2. If Desktop Setting – Icon on Desktop = OFF. Nautilus from app list or dash would run normally

    Asus X201EP | Intel Celeron 2x 1.10 GHz | 4 GB DDR3 RAM | Antergos 64-Bit.

  • I do have a “Home” icon on the desktop and it works fine. Which sounds a lot like #1.

    I used “Tweaks Tool” to turn off the desktop icon. Now when I try “Files” a windows does not open, but it does show “Files” in the task bar as running now. But I can’t switch to it or open it.

  • Post the contents of your xsession log, there should be some clues in there:[code:prw0v1d3]~/.xsession-errors[/code:prw0v1d3]

  • @“lots.0.logs”:1gaaacrz said:

    Post the contents of your xsession log, there should be some clues in there:

      
    >   
    > Any idea why its always zero bytes?  
    >   
    > [[email protected] ~]$ ls -la .xsession-errors\*  
    > -rw------- 1 rich users 0 Nov 15 21:42 .xsession-errors  
    > -rw------- 1 rich users 0 Nov 15 21:36 .xsession-errors.old
    

    Scroll up to my Nov 5th post, it was zero then too.

  • Which display manager are you using? GDM does not log to xsession-errors anymore. :-/ Have you tried this yet:[command:2oui3w2o]sudo pacman -Syy gnome gnome-extra --needed[/command:2oui3w2o]

  • Using Light-DM and the command you suggested added 22 packages. “Files” still doesn’t work, xsession-errors still zero bytes, and nothing scrolls by in journal when trying to open “Files”.

  • Weird…There has to be something in the journal…please post the journal for the last 3 boots and I’ll take a look.

  • Attached are last 2. Note that I had to do some editing on the file to remove references to specific documents and email addresses.

  • I don’t know how I didnt think to mention this before now BUT…have you tried switching to the default GTK theme (Adwaita)? If that doesnt help, disable all of your GNOME extensions, log out, log in again, and try to open FIles. If it works, then you will have to enable your extensions one-by-one to find the culprit. Let me know how it goes!

  • Using Tweak Tool I set the following to Adwaita: Theme, Window, GTK+, Icons, Cursor.

    Log Off & On - no difference, “Files” does not work.

    I only have 2 extensions enabled “User Themses” and “Window List”. Turned them both off.

    Log Off & On - no difference, “Files” does not work.

    While in the Extension - I noticed “Places a status indicator” - I can use this to open up the File Browser no problem.

  • Okay…it must be something wrong with your user profile somewhere. Try creating a new user then log in as that user and try to open Files.

  • As you suspected, “Files” works fine with a new account. Any thoughts were look now?

Posts 22Views 4947
Log in to reply