• Where are screen saver settings?


    Trying to do basic customisation, and can’t find Screen saver settings neither in Tweaks nor Settings.
    Is it available at all? I’m looking for changing time when screen blanking starts, now it seems too long.

    Thank you.

  • Trying to do basic customisation, and can’t find Screen saver settings neither in Tweaks nor Settings.
    Is it available at all? I’m looking for changing time when screen blanking starts, now it seems too long.

    Thank you.

  • In Gnome 3.14, go to Settings, click on ‘Power’ icon, under ‘Power Saving’ select number of minutes to blank screen.This is where you can also turn on or off automatic suspend and set up the time before this occurs. There is also a ‘Power’ tab in Gnome Tweak Tool where you can specify the Power Button Action e.g. to suspend, turn off, interactive, etc. These will cause your screen to blank and/or suspend.

    Advice on setting up and running XScreenSaver can be found in the Arch Wiki:

    [https://wiki.archlinux.org/index.php/XScreenSaver#Configuring_XScreenSaver][0]">[https://wiki.archlinux.org/index.php/XS][1] … creenSaver

    Please note that simply installing the xscreensaver package is not enough to have it run automatically. See the Wiki for more details. Most options are configured on a user-by-user basis simply by running xscreensaver-demo from your terminal.

    I’m happy with the screen to go blank so haven’t tried the above settings.

    [0]: <a href=
    [1]: https://wiki.archlinux.org/index.php/XS

  • Thank you, Xler8, now I’ll know where it is.

    Tried, the Power settings in Settings are set for screen going blank to 5 min, and screen doesn’t go blank at all, up to 25 min.

    I thought that it could be because the optical mouse reacts on vibrations of walking in the same room, I turned mouse off. All the same, so this is not the souce of problem. Is there anything else I can try?

  • @“HJD09”:s9h6pv60 said:

    Thank you, Xler8, now I’ll know where it is.

    Tried, the Power settings in Settings are set for screen going blank to 5 min, and screen doesn’t go blank at all, up to 25 min.

    I thought that it could be because the optical mouse reacts on vibrations of walking in the same room, I turned mouse off. All the same, so this is not the souce of problem. Is there anything else I can try?[/quote:s9h6pv60]

    I have the same issue, I set it for 5 minutes, but never goes blank. Was there any issue like this before, or has someone else experienced it?

    Asus X201EP | Intel Celeron 2x 1.10 GHz | 4 GB DDR3 RAM | Antergos 64-Bit.

  • Hi, I think this is caused by lightdm being used for logging in. To enable screen blanking install gdm (Gnome display manager) and use that instead of lightdm. This also enables login without having to use your mouse:

    sudo pacman -S gdm (or install using PacmanXG or Pamac)
    sudo systemctl disable lightdm
    sudo systemctl enable gdm

    Reboot and you should be OK.

    Any problems, you can change back to lightdm:

    sudo systemctl disable gdm
    sudo systemctl enable lightdm

  • Take a look at this (from the xscreensaver manual)…

    "USING GNOME
    For the better part of a decade, GNOME shipped xscreensaver as-is, and everything just worked out of the box. In 2005, however, they decided to re-invent the wheel and ship their own replacement for the xscreensaver daemon called “gnome-screensaver”, rather than improving xscreensaver and contributing their changes back. As a result, the “gnome-screensaver” program is insecure, bug-ridden, and missing many features of xscreensaver. You shouldn’t use it.

    To replace gnome-screensaver with xscreensaver:

    1: Fully uninstall the gnome-screensaver package.

    sudo apt-get remove gnome-screensaver

    2: Launch xscreensaver at login.
    Select “Startup Applications” from the menu (or manually launch “gnome-session-properties”) and add “xscreensaver”.
    3: Make “Lock Screen” use xscreensaver.

    sudo ln -sf /usr/bin/xscreensaver-command \
    /usr/bin/gnome-screensaver-command "

    [http://www.jwz.org/xscreensaver/man1.html][0]">[http://www.jwz.org/xscreensaver/man1.html][1]

    [0]: <a href=
    [1]: http://www.jwz.org/xscreensaver/man1.html

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.10 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • @“Xler8”:1nc8zdiq said:

    install gdm (Gnome display manager) and use that instead of lightdm. This also enables login without having to use your mouse:[/quote:1nc8zdiq]

    This issue was been fixed sometime ago…

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.10 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • @“Xler8”:10p92h9e said:

    Hi, I think this is caused by lightdm being used for logging in. To enable screen blanking install gdm (Gnome display manager) and use that instead of lightdm. This also enables login without having to use your mouse:

    sudo pacman -S gdm (or install using PacmanXG or Pamac)
    sudo systemctl disable lightdm
    sudo systemctl enable gdm

    Reboot and you should be OK.

    Any problems, you can change back to lightdm:

    sudo systemctl disable gdm
    sudo systemctl enable lightdm[/quote:10p92h9e]

    This worked beautifully, only moving mouse is not enough to activate screen again, had to use keyboard - just as you said. Not a problem, each variation of OS requires changing habits.

    Thank you, everybody!
    Can you aslo help with few my other questions in Gnome sub-forum, please?

  • Hi, HJD09, I had the same issue with the mouse pointer, try this:
    run dconf-editor and navigate to org.gnome.settings-daemon.plugins.cursor and set the schema active to false
    Works for me ;)

  • @Xler8 said in [SOLVED] Where are screen saver settings?:

    lightdm

    Is there a way to make screensaver work with lightdm?

    Thanks,

    Martin

  • @mchenier1

    Hi,

    for lightdm and lightlocker you’ll find two working solutions in the following thread:

    https://forum.antergos.com/topic/7136/lightdm-lightlocker-under-gnome-research-for-a-working-solution

    Cheers,

    Khedron

  • @khedron Thanks a lot, i will look at that.

  • @mchenier1 Xscreensaver not helps get your screen healthy ;) this is something we need in former times where we have to use CRT Screens…

    Under Gnome the best saving solution is what @khedron gives you…

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    http://kamprad.net/howto-installing-antergos/
    how to add system logs

  • Hello,
    Look at this post, it worked for me.
    [link text]https://forum.antergos.com/topic/7637/resolved-screen-saver-on-gnome(link url)

  • Thanks, I’ll take a look as soon as possible.

Posts 16Views 10567
Log in to reply