• failed to commit transaction (invalid or corrupted package


    Hi. I successfully updated my system yesterday evening and have been unsuccessful this evening.
    Here is my terminal output:

    [[email protected] ~]$ sudo pacman -Syu  
    :: Synchronizing package databases...  
    core is up to date  
    extra is up to date  
    community is up to date  
    antergos is up to date  
    :: Starting full system upgrade...  
    resolving dependencies...  
    looking for inter-conflicts...  
      
    Packages (4): adwaita-icon-theme-3.14.1-1 git-2.1.3-1  
    numix-icon-theme-0.r229.634c1c1-1 sqlite-3.8.7.1-1  
      
    Total Download Size: 2.15 MiB  
    Total Installed Size: 52.58 MiB  
    Net Upgrade Size: 0.19 MiB  
      
    :: Proceed with installation? [Y/n] y  
    :: Retrieving packages ...  
    numix-icon-theme-0.... 2.2 MiB 918K/s 00:02 [\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#] 100%  
    (4/4) checking keys in keyring [\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#] 100%  
    (4/4) checking package integrity [\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#] 100%  
    error: numix-icon-theme: signature from "Antergos Build Server (Automated Package Build System) <[email protected]\>" is marginal trust  
    :: File /var/cache/pacman/pkg/numix-icon-theme-0.r229.634c1c1-1-any.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).  
    Do you want to delete it? [Y/n] y  
    error: failed to commit transaction (invalid or corrupted package)  
    Errors occurred, no packages were upgraded.
    

    After googling, I came across this thread on the Arch forums:

    [url:thbfhy4w]https://bbs.archlinux.org/viewtopic.php?id=165367[/url:thbfhy4w]
    I had used, user ‘karol’s’ link.
    I had edited the gpg.conf file using one after the other reccommended ‘keyserver hkp’ listings and then immediately, post saving the gpg.conf file, went

    pacman-key --populate archlinux
    

    That command had the following terminal output:

    [[email protected] ~]$ sudo pacman-key --populate archlinux  
    [sudo] password for frankenstein:   
    ==\> Appending keys from archlinux.gpg...  
    gpg: 3 marginal(s) needed, 1 complete(s) needed, PGP trust model  
    gpg: depth: 0 valid: 1 signed: 6 trust: 0-, 0q, 0n, 0m, 0f, 1u  
    gpg: depth: 1 valid: 6 signed: 62 trust: 0-, 0q, 0n, 6m, 0f, 0u  
    gpg: depth: 2 valid: 60 signed: 4 trust: 60-, 0q, 0n, 0m, 0f, 0u  
    gpg: next trustdb check due at 2015-03-31  
    ==\> Locally signing trusted keys in keyring...  
    -\> Locally signing key 0E8B644079F599DFC1DDC3973348882F6AC6A4C2...  
    -\> Locally signing key 684148BB25B49E986A4944C55184252D824B18E8...  
    -\> Locally signing key 44D4A033AC140143927397D47EFD567D4C7EA887...  
    -\> Locally signing key 27FFC4769E19F096D41D9265A04F9397CDFD6BB0...  
    -\> Locally signing key AB19265E5D7D20687D303246BA1DFB64FFF979E7...  
    ==\> Importing owner trust values...  
    ==\> Disabling revoked keys in keyring...  
    -\> Disabling key F5A361A3A13554B85E57DDDAAF7EF7873CFD4BB6...  
    -\> Disabling key 7FA647CD89891DEDC060287BB9113D1ED21E1A55...  
    -\> Disabling key D4DE5ABDE2A7287644EAC7E36D1A9E70E19DAA50...  
    -\> Disabling key BC1FBE4D2826A0B51E47ED62E2539214C6C11350...  
    -\> Disabling key 4A8B17E20B88ACA61860009B5CED81B7C2E5C0D2...  
    -\> Disabling key 63F395DE2D6398BBE458F281F2DBB4931985A992...  
    -\> Disabling key 0B20CA1931F5DA3A70D0F8D2EA6836E1AB441196...  
    -\> Disabling key 8F76BEEA0289F9E1D3E229C05F946DED983D4366...  
    -\> Disabling key 66BD74A036D522F51DD70A3C7F2A16726521E06D...  
    -\> Disabling key 81D7F8241DB38BC759C80FCE3A726C6170E80477...  
    -\> Disabling key E7210A59715F6940CF9A4E36A001876699AD6E84...  
    ==\> Updating trust database...  
    gpg: next trustdb check due at 2015-03-31  
    [[email protected] ~]$ sudo pacman -Syu  
    :: Synchronizing package databases...  
    core is up to date  
    extra is up to date  
    community is up to date  
    antergos is up to date  
    :: Starting full system upgrade...  
    resolving dependencies...  
    looking for inter-conflicts...  
      
    Packages (4): adwaita-icon-theme-3.14.1-1 git-2.1.3-1  
    numix-icon-theme-0.r229.634c1c1-1 sqlite-3.8.7.1-1  
      
    Total Installed Size: 52.58 MiB  
    Net Upgrade Size: 0.19 MiB  
      
    :: Proceed with installation? [Y/n] y  
    (4/4) checking keys in keyring [\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#] 100%  
    (4/4) checking package integrity [\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#] 100%  
    error: numix-icon-theme: signature from "Antergos Build Server (Automated Package Build System) <[email protected]\>" is marginal trust  
    :: File /var/cache/pacman/pkg/numix-icon-theme-0.r229.634c1c1-1-any.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).  
    Do you want to delete it? [Y/n] y  
    error: failed to commit transaction (invalid or corrupted package)  
    Errors occurred, no packages were upgraded.  
    [[email protected] ~]$ sudo pacman-key --populate archlinux  
    ==\> Appending keys from archlinux.gpg...  
    gpg: could not parse keyserver URL  
    ==\> Locally signing trusted keys in keyring...  
    -\> Locally signing key 0E8B644079F599DFC1DDC3973348882F6AC6A4C2...  
    ==\> ERROR: 0E8B644079F599DFC1DDC3973348882F6AC6A4C2 could not be locally signed.  
    -\> Locally signing key 684148BB25B49E986A4944C55184252D824B18E8...  
    ==\> ERROR: 684148BB25B49E986A4944C55184252D824B18E8 could not be locally signed.  
    -\> Locally signing key 44D4A033AC140143927397D47EFD567D4C7EA887...  
    ==\> ERROR: 44D4A033AC140143927397D47EFD567D4C7EA887 could not be locally signed.  
    -\> Locally signing key 27FFC4769E19F096D41D9265A04F9397CDFD6BB0...  
    ==\> ERROR: 27FFC4769E19F096D41D9265A04F9397CDFD6BB0 could not be locally signed.  
    -\> Locally signing key AB19265E5D7D20687D303246BA1DFB64FFF979E7...  
    ==\> ERROR: AB19265E5D7D20687D303246BA1DFB64FFF979E7 could not be locally signed.
    

    Thereafter, due to these errors, I repopulated the altered gpg.conf file with the [u:thbfhy4w]original gpg.conf[/u:thbfhy4w] file with the [u:thbfhy4w]original file settings[/u:thbfhy4w] as having changed that file to what the arch wiki suggests were of no use nor to any avail to me. That original gpg.conf file remains as the following:

    no-greeting  
    no-permission-warning  
    lock-never  
    keyserver hkp://pool.sks-keyservers.net  
    keyserver-options timeout=10
    

    There must be something that I need to alter. Hoping I can get help here for said problem to be resolved. Thanks in advance for your help.

    Download " antergos-wallpapers-extra " and enjoy community sponsored wallpapers.

    Use the "Linux Beginner Search Engine"

    https://cse.google.com/cse/home?cx=017607476515012185699:b_owgx6xyi0

  • Hi. I successfully updated my system yesterday evening and have been unsuccessful this evening.
    Here is my terminal output:

    [[email protected] ~]$ sudo pacman -Syu  
    :: Synchronizing package databases...  
    core is up to date  
    extra is up to date  
    community is up to date  
    antergos is up to date  
    :: Starting full system upgrade...  
    resolving dependencies...  
    looking for inter-conflicts...  
      
    Packages (4): adwaita-icon-theme-3.14.1-1 git-2.1.3-1  
    numix-icon-theme-0.r229.634c1c1-1 sqlite-3.8.7.1-1  
      
    Total Download Size: 2.15 MiB  
    Total Installed Size: 52.58 MiB  
    Net Upgrade Size: 0.19 MiB  
      
    :: Proceed with installation? [Y/n] y  
    :: Retrieving packages ...  
    numix-icon-theme-0.... 2.2 MiB 918K/s 00:02 [\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#] 100%  
    (4/4) checking keys in keyring [\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#] 100%  
    (4/4) checking package integrity [\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#] 100%  
    error: numix-icon-theme: signature from "Antergos Build Server (Automated Package Build System) <[email protected]\>" is marginal trust  
    :: File /var/cache/pacman/pkg/numix-icon-theme-0.r229.634c1c1-1-any.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).  
    Do you want to delete it? [Y/n] y  
    error: failed to commit transaction (invalid or corrupted package)  
    Errors occurred, no packages were upgraded.
    

    After googling, I came across this thread on the Arch forums:

    [url:thbfhy4w]https://bbs.archlinux.org/viewtopic.php?id=165367[/url:thbfhy4w]
    I had used, user ‘karol’s’ link.
    I had edited the gpg.conf file using one after the other reccommended ‘keyserver hkp’ listings and then immediately, post saving the gpg.conf file, went

    pacman-key --populate archlinux
    

    That command had the following terminal output:

    [[email protected] ~]$ sudo pacman-key --populate archlinux  
    [sudo] password for frankenstein:   
    ==\> Appending keys from archlinux.gpg...  
    gpg: 3 marginal(s) needed, 1 complete(s) needed, PGP trust model  
    gpg: depth: 0 valid: 1 signed: 6 trust: 0-, 0q, 0n, 0m, 0f, 1u  
    gpg: depth: 1 valid: 6 signed: 62 trust: 0-, 0q, 0n, 6m, 0f, 0u  
    gpg: depth: 2 valid: 60 signed: 4 trust: 60-, 0q, 0n, 0m, 0f, 0u  
    gpg: next trustdb check due at 2015-03-31  
    ==\> Locally signing trusted keys in keyring...  
    -\> Locally signing key 0E8B644079F599DFC1DDC3973348882F6AC6A4C2...  
    -\> Locally signing key 684148BB25B49E986A4944C55184252D824B18E8...  
    -\> Locally signing key 44D4A033AC140143927397D47EFD567D4C7EA887...  
    -\> Locally signing key 27FFC4769E19F096D41D9265A04F9397CDFD6BB0...  
    -\> Locally signing key AB19265E5D7D20687D303246BA1DFB64FFF979E7...  
    ==\> Importing owner trust values...  
    ==\> Disabling revoked keys in keyring...  
    -\> Disabling key F5A361A3A13554B85E57DDDAAF7EF7873CFD4BB6...  
    -\> Disabling key 7FA647CD89891DEDC060287BB9113D1ED21E1A55...  
    -\> Disabling key D4DE5ABDE2A7287644EAC7E36D1A9E70E19DAA50...  
    -\> Disabling key BC1FBE4D2826A0B51E47ED62E2539214C6C11350...  
    -\> Disabling key 4A8B17E20B88ACA61860009B5CED81B7C2E5C0D2...  
    -\> Disabling key 63F395DE2D6398BBE458F281F2DBB4931985A992...  
    -\> Disabling key 0B20CA1931F5DA3A70D0F8D2EA6836E1AB441196...  
    -\> Disabling key 8F76BEEA0289F9E1D3E229C05F946DED983D4366...  
    -\> Disabling key 66BD74A036D522F51DD70A3C7F2A16726521E06D...  
    -\> Disabling key 81D7F8241DB38BC759C80FCE3A726C6170E80477...  
    -\> Disabling key E7210A59715F6940CF9A4E36A001876699AD6E84...  
    ==\> Updating trust database...  
    gpg: next trustdb check due at 2015-03-31  
    [[email protected] ~]$ sudo pacman -Syu  
    :: Synchronizing package databases...  
    core is up to date  
    extra is up to date  
    community is up to date  
    antergos is up to date  
    :: Starting full system upgrade...  
    resolving dependencies...  
    looking for inter-conflicts...  
      
    Packages (4): adwaita-icon-theme-3.14.1-1 git-2.1.3-1  
    numix-icon-theme-0.r229.634c1c1-1 sqlite-3.8.7.1-1  
      
    Total Installed Size: 52.58 MiB  
    Net Upgrade Size: 0.19 MiB  
      
    :: Proceed with installation? [Y/n] y  
    (4/4) checking keys in keyring [\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#] 100%  
    (4/4) checking package integrity [\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#] 100%  
    error: numix-icon-theme: signature from "Antergos Build Server (Automated Package Build System) <[email protected]\>" is marginal trust  
    :: File /var/cache/pacman/pkg/numix-icon-theme-0.r229.634c1c1-1-any.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).  
    Do you want to delete it? [Y/n] y  
    error: failed to commit transaction (invalid or corrupted package)  
    Errors occurred, no packages were upgraded.  
    [[email protected] ~]$ sudo pacman-key --populate archlinux  
    ==\> Appending keys from archlinux.gpg...  
    gpg: could not parse keyserver URL  
    ==\> Locally signing trusted keys in keyring...  
    -\> Locally signing key 0E8B644079F599DFC1DDC3973348882F6AC6A4C2...  
    ==\> ERROR: 0E8B644079F599DFC1DDC3973348882F6AC6A4C2 could not be locally signed.  
    -\> Locally signing key 684148BB25B49E986A4944C55184252D824B18E8...  
    ==\> ERROR: 684148BB25B49E986A4944C55184252D824B18E8 could not be locally signed.  
    -\> Locally signing key 44D4A033AC140143927397D47EFD567D4C7EA887...  
    ==\> ERROR: 44D4A033AC140143927397D47EFD567D4C7EA887 could not be locally signed.  
    -\> Locally signing key 27FFC4769E19F096D41D9265A04F9397CDFD6BB0...  
    ==\> ERROR: 27FFC4769E19F096D41D9265A04F9397CDFD6BB0 could not be locally signed.  
    -\> Locally signing key AB19265E5D7D20687D303246BA1DFB64FFF979E7...  
    ==\> ERROR: AB19265E5D7D20687D303246BA1DFB64FFF979E7 could not be locally signed.
    

    Thereafter, due to these errors, I repopulated the altered gpg.conf file with the [u:thbfhy4w]original gpg.conf[/u:thbfhy4w] file with the [u:thbfhy4w]original file settings[/u:thbfhy4w] as having changed that file to what the arch wiki suggests were of no use nor to any avail to me. That original gpg.conf file remains as the following:

    no-greeting  
    no-permission-warning  
    lock-never  
    keyserver hkp://pool.sks-keyservers.net  
    keyserver-options timeout=10
    

    There must be something that I need to alter. Hoping I can get help here for said problem to be resolved. Thanks in advance for your help.

    Download " antergos-wallpapers-extra " and enjoy community sponsored wallpapers.

    Use the "Linux Beginner Search Engine"

    https://cse.google.com/cse/home?cx=017607476515012185699:b_owgx6xyi0

  • Hi,

    Please run the following commands:[command:2kedzggy]sudo pacman-key --init
    sudo pacman-key --populate archlinux antergos[/command:2kedzggy]

    Let me know if you still have trouble with it.

    Cheers!

  • @“lots.0.logs”:hqb4w6ll said:

    Hi,

    Please run the following commands:[command:hqb4w6ll]sudo pacman-key --init
    sudo pacman-key --populate archlinux antergos[/command:hqb4w6ll]

    Let me know if you still have trouble with it.

    Cheers![/quote:hqb4w6ll]

    I have the same issue, and those commands help me fix it. Thanks.

    Asus X201EP | Intel Celeron 2x 1.10 GHz | 4 GB DDR3 RAM | Antergos 64-Bit.

  • Ok. This seemed to have resolved the issue as evidenced by the output below:

    [[email protected] ~]$ sudo pacman-key --init  
    [sudo] password for frankenstein:   
    [[email protected] ~]$ sudo pacman-key --populate archlinux antergos  
    ==\> Appending keys from archlinux.gpg...  
    ==\> Appending keys from antergos.gpg...  
    ==\> Locally signing trusted keys in keyring...  
    -\> Locally signing key 0E8B644079F599DFC1DDC3973348882F6AC6A4C2...  
    -\> Locally signing key 684148BB25B49E986A4944C55184252D824B18E8...  
    -\> Locally signing key 24B445614FAC071891EDCE49CDBD406AA1AA7A1D...  
    -\> Locally signing key D95436A2E18DA94A72B1A5E2AEA529BF122902E5...  
    -\> Locally signing key EC3B5CE8FE98DFDF51B705536D6DDA3D2A45C7B4...  
    -\> Locally signing key 44D4A033AC140143927397D47EFD567D4C7EA887...  
    -\> Locally signing key 27FFC4769E19F096D41D9265A04F9397CDFD6BB0...  
    -\> Locally signing key AB19265E5D7D20687D303246BA1DFB64FFF979E7...  
    ==\> Importing owner trust values...  
    ==\> Disabling revoked keys in keyring...  
    -\> Disabling key F5A361A3A13554B85E57DDDAAF7EF7873CFD4BB6...  
    -\> Disabling key 7FA647CD89891DEDC060287BB9113D1ED21E1A55...  
    -\> Disabling key D4DE5ABDE2A7287644EAC7E36D1A9E70E19DAA50...  
    -\> Disabling key BC1FBE4D2826A0B51E47ED62E2539214C6C11350...  
    -\> Disabling key 4A8B17E20B88ACA61860009B5CED81B7C2E5C0D2...  
    -\> Disabling key 63F395DE2D6398BBE458F281F2DBB4931985A992...  
    -\> Disabling key 0B20CA1931F5DA3A70D0F8D2EA6836E1AB441196...  
    -\> Disabling key 8F76BEEA0289F9E1D3E229C05F946DED983D4366...  
    -\> Disabling key 66BD74A036D522F51DD70A3C7F2A16726521E06D...  
    -\> Disabling key 81D7F8241DB38BC759C80FCE3A726C6170E80477...  
    -\> Disabling key E7210A59715F6940CF9A4E36A001876699AD6E84...  
    ==\> Updating trust database...  
    gpg: next trustdb check due at 2015-03-31  
    [[email protected] ~]$ sudo pacman -Syu  
    :: Synchronizing package databases...  
    core 117.0 KiB 191K/s 00:01 [\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#] 100%  
    extra 1716.8 KiB 840K/s 00:02 [\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#] 100%  
    community 2.3 MiB 832K/s 00:03 [\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#] 100%  
    antergos is up to date  
    :: Starting full system upgrade...  
    resolving dependencies...  
    looking for inter-conflicts...  
      
    Packages (9): adwaita-icon-theme-3.14.1-1 cups-2.0.0-2 cups-filters-1.0.61-2  
    git-2.1.3-1 libcups-2.0.0-2 libpipeline-1.4.0-1  
    numix-icon-theme-0.r229.634c1c1-1 sqlite-3.8.7.1-1  
    system-config-printer-1.5.3-3  
      
    Total Download Size: 10.69 MiB  
    Total Installed Size: 74.07 MiB  
    Net Upgrade Size: -0.64 MiB  
      
    :: Proceed with installation? [Y/n] y  
    :: Retrieving packages ...  
    libpipeline-1.4.0-1... 36.3 KiB 171K/s 00:00 [\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#] 100%  
    libcups-2.0.0-2-x86\_64 298.8 KiB 459K/s 00:01 [\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#] 100%  
    cups-filters-1.0.61... 668.1 KiB 631K/s 00:01 [\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#] 100%  
    cups-2.0.0-2-x86\_64 6.7 MiB 700K/s 00:10 [\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#] 100%  
    system-config-print... 885.6 KiB 713K/s 00:01 [\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#] 100%  
    numix-icon-theme-0.... 2.2 MiB 599K/s 00:04 [\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#] 100%  
    (9/9) checking keys in keyring [\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#] 100%  
    (9/9) checking package integrity [\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#] 100%  
    (9/9) loading package files [\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#] 100%  
    (9/9) checking for file conflicts [\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#] 100%  
    (9/9) checking available disk space [\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#] 100%  
    (1/9) upgrading adwaita-icon-theme [\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#] 100%  
    (2/9) upgrading libcups [\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#] 100%  
    (3/9) upgrading cups-filters [\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#] 100%  
    (4/9) upgrading cups [\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#] 100%  
    warning: directory permissions differ on /var/cache/cups/  
    filesystem: 775 package: 770  
    \> systemd unit names have been renamed  
    \> you should systemctl stop and disable cups.service and  
    \> systemctl daemon-reload, start and enable org.cups.cupsd.service  
    (5/9) upgrading git [\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#] 100%  
    (6/9) upgrading libpipeline [\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#] 100%  
    (7/9) upgrading numix-icon-theme [\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#] 100%  
    (8/9) upgrading sqlite [\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#] 100%  
    (9/9) upgrading system-config-printer [\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#] 100%  
    [[email protected] ~]$   
    
    

    What I am interested in learning is this command here:

    sudo pacman-key --populate archlinux antergos
    

    By the way, I have marked this as solved

    Also, is this correct? Would you please have a look lots.0.logs?
    Is there anything that is amiss with the following output following the systemctl recommendations from the above output?

    [[email protected] ~]$ sudo systemctl stop cups.service  
    [sudo] password for frankenstein:   
    Warning: Unit file of cups.service changed on disk, 'systemctl daemon-reload' recommended.  
    Warning: Stopping cups.service, but it can still be activated by:  
    cups.socket  
    cups.path  
    [[email protected] ~]$ sudo systemctl daemon-reload  
    [[email protected] ~]$ sudo systemctl start org.cups.cupsd.service
    

    Download " antergos-wallpapers-extra " and enjoy community sponsored wallpapers.

    Use the "Linux Beginner Search Engine"

    https://cse.google.com/cse/home?cx=017607476515012185699:b_owgx6xyi0

  • Pacman uses a gnupg keyring to authenticate official packages. Your keys became out of sync causing the previous errors. The commands I provided reset the keyring.

    The notice about cups is just informing you that the systemd service file for cups was changed and those changes wont be picked up by system d until you either A. run the reload command or B. reboot your system

    Cheers!

  • @“lots.0.logs”:1z7vsnl8 said:

    Hi,

    Please run the following commands:[command:1z7vsnl8]sudo pacman-key --init
    sudo pacman-key --populate archlinux antergos[/command:1z7vsnl8]

    Let me know if you still have trouble with it.

    Cheers![/quote:1z7vsnl8]
    I had the same issue, but these commands didn’t fix it. I ran them both and then tried

    sudo pacamn -Syu 
    

    and received this as my output

    :: Synchronizing package databases...  
    > core is up to date  
    > extra is up to date  
    > community is up to date  
    > multilib is up to date  
    > antergos is up to date  
    > :: Starting full system upgrade...  
    > resolving dependencies...  
    > looking for inter-conflicts...  
    >   
    > Packages (60): antergos-keyring-20140915-1 at-spi2-core-2.14.1-1 avahi-0.6.31-14  
    > bluez-5.25-1 bluez-utils-5.25-1 colord-1.2.5-1 cups-2.0.0-3  
    > cups-filters-1.0.61-3 curl-7.39.0-1 dhcpcd-6.6.1-1 efibootmgr-0.11.0-1  
    > file-5.20-2 firefox-33.1-2 gettext-0.19.3-1 gnome-desktop-1:3.14.2-1  
    > gnome-disk-utility-3.14.0-1 gnutls-3.3.10-1 gst-libav-1.4.4-1  
    > gst-plugins-bad-1.4.4-1 gst-plugins-base-1.4.4-1  
    > gst-plugins-base-libs-1.4.4-1 gst-plugins-good-1.4.4-1  
    > gst-plugins-ugly-1.4.4-1 gstreamer-1.4.4-1 gtk3-3.14.5-1  
    > gtksourceview3-3.14.2-1 gvfs-1.22.2-1 gvfs-mtp-1.22.2-1 hwids-20141030-1  
    > jansson-2.7-1 kmod-18-2 ldns-1.6.17-2 libaio-0.3.110-1 libcups-2.0.0-3  
    > libedit-20141030\_3.1-1 libguess-1.2-1 libjpeg-turbo-1.3.1-2  
    > libmediainfo-0.7.71-1 libpng-1.6.14-1 libreoffice-fresh-4.3.3-2  
    > libsystemd-217-6 lightdm-webkit-theme-antergos-2.0.6-1 lz4-123-1  
    > man-db-2.7.1-1 mediainfo-0.7.71-1 numix-frost-themes-1.1.1-1  
    > numix-icon-theme-0.r229.634c1c1-1 numix-icon-theme-square-1:0.r74.f1b7833-1  
    > pinentry-0.8.4-1 poppler-0.28.1-1 poppler-glib-0.28.1-1 procps-ng-3.3.10-1  
    > protobuf-2.6.1-1 systemd-217-6 systemd-sysvcompat-217-6 tcl-8.6.3-1  
    > usbutils-008-1 vte-common-0.38.2-1 xorg-server-1.16.2-1  
    > xorg-server-common-1.16.2-1  
    >   
    > Total Download Size: 3.94 MiB  
    > Total Installed Size: 705.33 MiB  
    > Net Upgrade Size: 4.77 MiB  
    >   
    > :: Proceed with installation? [Y/n] y  
    > :: Retrieving packages ...  
    > lightdm-webkit-theme-ant... 824.1 KiB 16.8M/s 00:00 [\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#] 100%  
    > numix-frost-themes-1.1.1... 153.0 KiB 49.8M/s 00:00 [\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#] 100%  
    > numix-icon-theme-0.r229.... 2.2 MiB 40.6M/s 00:00 [\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#] 100%  
    > numix-icon-theme-square-... 853.5 KiB 892K/s 00:01 [\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#] 100%  
    > (60/60) checking keys in keyring [\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#] 100%  
    > (60/60) checking package integrity [\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#] 100%  
    > error: lightdm-webkit-theme-antergos: signature from "Antergos Build Server (Automated Package Build System) <[email protected]\>" is marginal trust  
    > :: File /var/cache/pacman/pkg/lightdm-webkit-theme-antergos-2.0.6-1-any.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).  
    > Do you want to delete it? [Y/n] y  
    > error: numix-frost-themes: signature from "Antergos Build Server (Automated Package Build System) <[email protected]\>" is marginal trust  
    > :: File /var/cache/pacman/pkg/numix-frost-themes-1.1.1-1-any.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).  
    > Do you want to delete it? [Y/n] y  
    > error: numix-icon-theme: signature from "Antergos Build Server (Automated Package Build System) <[email protected]\>" is marginal trust  
    > :: File /var/cache/pacman/pkg/numix-icon-theme-0.r229.634c1c1-1-any.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).  
    > Do you want to delete it? [Y/n] y  
    > error: numix-icon-theme-square: signature from "Antergos Build Server (Automated Package Build System) <[email protected]\>" is marginal trust  
    > :: File /var/cache/pacman/pkg/numix-icon-theme-square-1:0.r74.f1b7833-1-any.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).  
    > Do you want to delete it? [Y/n] y  
    > error: failed to commit transaction (invalid or corrupted package)  
    > Errors occurred, no packages were upgraded.  
    > 
    
  • Doesn’t work for me too. Tried the commands in this post. still facing the same error!

  • Hi,

    It looks like you have not installed any updates for an extended period. With a rolling release like Antergos, that is the worst thing you could do and will always result in problems at some point. Keep that in mind going forward. We recommend that you install updates at minimum once per week. The following commands should get you back on track:[command:29ne43b3]sudo pacman -S antergos-keyring
    sudo pacman-key --init
    sudo pacman-key --populate archlinux antergos
    sudo pacman -Syu[/command:29ne43b3]

    Best Regards,

  • @“lots.0.logs”:l00bzrfl said:

    Hi,

    It looks like you have not installed any updates for an extended period. With a rolling release like Antergos, that is the worst thing you could do and will always result in problems at some point. Keep that in mind going forward. We recommend that you install updates at minimum once per week. The following commands should get you back on track:[command:l00bzrfl]sudo pacman -S antergos-keyring
    sudo pacman-key --init
    sudo pacman-key --populate archlinux antergos
    sudo pacman -Syu[/command:l00bzrfl]

    Best Regards,[/quote:l00bzrfl]
    Thanks, that worked. It had only been a little over a week since I updated last, but I’ll keep that in mind.

  • Thanks. That worked for me too!

  • Same here as of today but the following solved it =) cheers

    sudo pacman-key --init  
    sudo pacman-key --populate archlinux antergos
    
  • Now iam having the same issue. Will follow this command. I will update on how this goes.

  • Hi Dustin,

    This is what i got after running the command.
    **********************************************************************************************************************************
    [[email protected] ~]$ su
    Password:
    [[email protected] joseph]# sudo pacman -S antergos-keyring
    warning: antergos-keyring-20140915-1 is up to date – reinstalling
    resolving dependencies…
    looking for inter-conflicts…

    Packages (1): antergos-keyring-20140915-1

    Total Installed Size: 0.03 MiB
    Net Upgrade Size: 0.00 MiB

    :: Proceed with installation? [Y/n] Y
    (1/1) checking keys in keyring [######################] 100%
    (1/1) checking package integrity [######################] 100%
    (1/1) loading package files [######################] 100%
    (1/1) checking for file conflicts [######################] 100%
    (1/1) checking available disk space [######################] 100%
    (1/1) reinstalling antergos-keyring [######################] 100%
    ==> Appending keys from antergos.gpg…
    ==> Locally signing trusted keys in keyring…
    -> Locally signing key 24B445614FAC071891EDCE49CDBD406AA1AA7A1D…
    -> Locally signing key D95436A2E18DA94A72B1A5E2AEA529BF122902E5…
    -> Locally signing key EC3B5CE8FE98DFDF51B705536D6DDA3D2A45C7B4…
    ==> Importing owner trust values…
    ==> Updating trust database…
    gpg: next trustdb check due at 2015-03-31
    [[email protected] joseph]# sudo pacman-key --init
    [[email protected] joseph]# sudo pacman-key --populate archlinux antergos
    ==> Appending keys from archlinux.gpg…
    ==> Appending keys from antergos.gpg…
    ==> Locally signing trusted keys in keyring…
    -> Locally signing key 0E8B644079F599DFC1DDC3973348882F6AC6A4C2…
    -> Locally signing key 684148BB25B49E986A4944C55184252D824B18E8…
    -> Locally signing key 24B445614FAC071891EDCE49CDBD406AA1AA7A1D…
    -> Locally signing key D95436A2E18DA94A72B1A5E2AEA529BF122902E5…
    -> Locally signing key EC3B5CE8FE98DFDF51B705536D6DDA3D2A45C7B4…
    -> Locally signing key 44D4A033AC140143927397D47EFD567D4C7EA887…
    -> Locally signing key 27FFC4769E19F096D41D9265A04F9397CDFD6BB0…
    -> Locally signing key AB19265E5D7D20687D303246BA1DFB64FFF979E7…
    ==> Importing owner trust values…
    ==> Disabling revoked keys in keyring…
    -> Disabling key F5A361A3A13554B85E57DDDAAF7EF7873CFD4BB6…
    -> Disabling key 7FA647CD89891DEDC060287BB9113D1ED21E1A55…
    -> Disabling key D4DE5ABDE2A7287644EAC7E36D1A9E70E19DAA50…
    -> Disabling key BC1FBE4D2826A0B51E47ED62E2539214C6C11350…
    -> Disabling key 4A8B17E20B88ACA61860009B5CED81B7C2E5C0D2…
    -> Disabling key 63F395DE2D6398BBE458F281F2DBB4931985A992…
    -> Disabling key 0B20CA1931F5DA3A70D0F8D2EA6836E1AB441196…
    -> Disabling key 8F76BEEA0289F9E1D3E229C05F946DED983D4366…
    -> Disabling key 66BD74A036D522F51DD70A3C7F2A16726521E06D…
    -> Disabling key 81D7F8241DB38BC759C80FCE3A726C6170E80477…
    -> Disabling key E7210A59715F6940CF9A4E36A001876699AD6E84…
    ==> Updating trust database…
    gpg: next trustdb check due at 2015-03-31
    [[email protected] joseph]# sudo pacman -Syu
    :: Synchronizing package databases…
    core is up to date
    extra is up to date
    community 2.4 MiB 31.1K/s 01:19 [######################] 100%
    antergos 304.8 KiB 27.7K/s 00:11 [######################] 100%
    :: Starting full system upgrade…
    :: Replace attica with extra/attica-qt4? [Y/n] Y
    :: Replace dirmngr with core/gnupg? [Y/n] Y
    :: Replace mutter-wayland with extra/mutter? [Y/n] Y
    resolving dependencies…
    looking for inter-conflicts…

    Packages (299): accountsservice-0.6.39-1 adwaita-icon-theme-3.14.1-1
    at-spi2-atk-2.14.1-1 at-spi2-core-2.14.1-1 atk-2.14.0-1
    attica-0.4.2-1 [removal] attica-qt4-0.4.2-1 avahi-0.6.31-14
    binutils-2.24-8 bluez-5.25-2 boost-libs-1.57.0-2
    ca-certificates-mozilla-3.17.2-1 cairo-1.14.0-2
    calibre-2.12.0-1 cantarell-fonts-0.0.16-1 caribou-0.4.15-1
    cheese-3.14.2-1 chromium-39.0.2171.71-1 clamav-0.98.5-1
    clutter-1.20.0-2 clutter-gtk-1.6.0-1 cmatrix-1.2a-9
    colord-1.2.5-1 cronie-1.4.12-1 cups-2.0.1-1
    cups-filters-1.0.61-3 curl-7.39.0-1 db-5.3.28-2
    dbus-1.8.12-1 dbus-glib-0.102-2 dconf-0.22.0-1
    device-mapper-2.02.114-1 dhcpcd-6.6.4-1
    dirmngr-1.1.1-3 [removal] elfutils-0.160-1 empathy-3.12.7-1
    enca-1.16-1 evince-3.14.1-2 evolution-data-server-3.12.8-1
    expat-2.1.0-4 fakeroot-1.20.2-1 ffmpeg-1:2.5-1 file-5.20-2
    file-roller-3.14.2-1 filesystem-2014.10-3 firefox-34.0.5-1
    flac-1.3.1-1 flashplugin-11.2.202.424-1 fluidsynth-1.1.6-4
    folks-0.10.0-1 gcr-3.14.0-1 gdk-pixbuf2-2.31.1-1
    gdm-3.14.1-2 gedit-3.14.1-1 geoclue2-2.1.10-1
    geocode-glib-3.14.0-1 gettext-0.19.3-1 gjs-1.42.0-1
    glib-networking-2.42.0-1 glib2-2.42.1-1 glibc-2.20-4
    glibmm-2.42.0-1 gnome-bluetooth-3.14.0-1
    gnome-calculator-3.14.1-1 gnome-color-manager-3.14.2-1
    gnome-control-center-3.14.2-1 gnome-desktop-1:3.14.2-1
    gnome-disk-utility-3.14.0-1 gnome-keyring-3.14.0-1
    etc…(i cut some off due to thr thread)

    Total Installed Size: 3013.99 MiB
    Net Upgrade Size: -17.67 MiB

    :: Proceed with installation? [Y/n] Y
    (296/296) checking keys in keyring [######################] 100%
    (296/296) checking package integrity [######################] 100%
    (296/296) loading package files [######################] 100%
    (296/296) checking for file conflicts [######################] 100%
    error: failed to commit transaction (conflicting files)
    adwaita-icon-theme: /usr/share/icons/Adwaita/index.theme exists in filesystem
    Errors occurred, no packages were upgraded.
    [[email protected] joseph]#

  • Hi,

    You can safely use the --force command option for this case:[command:2ignulfk]sudo pacman -Syu --force[/command:2ignulfk]

    It’s important that you update your system at least once a week. Doing so will save you from future headaches :-)

    Best Regards,
    Dustin

  • Hi Justin,

    Guess what i found after reading this command from arch…
    *********************************
    pacman -Q0 /usr/share/icons/Adwaita/index/.theme …it gives me …
    /usr/share/icons/Adwaita/index.theme is owned by libxcursor 1.1.14-2

    So if i remove the libxcursor should that solve the issue?? and i just type the command sudo pacman -Syu --force and this will solve the issue too ??

    Thanks

  • You cant remove libxcursor. Just use the force option. It’s safe in this case. In the future, I dont recommend using it unless you are certain its safe (or a developer says its safe

  • Hi Justin,

    (Yes and you are a developer :))

    Thanks …i did sudo pacman -Syu --force …and it worked …got my Antergos updated now. phew!!

    Cheers

  • I used all these codes, but none of them worked till I used these codes from Manjaro forum:
    and I changed any “manjaro” to “antergos”.

    sudo rm -r /etc/pacman.d/gnupg
    sudo pacman -Sy gnupg archlinux-keyring manjaro-keyring
    sudo pacman-key --init
    sudo pacman-key --populate archlinux manjaro 
    sudo pacman-key --refresh-keys 
    sudo pacman -Sc
    
  • 3 years old treat - closing
    @sina :

    wget http://mirrors.antergos.com/antergos/x86_64/antergos-keyring-20170524-1-any.pkg.tar.xz
    pacman -U antergos-keyring-20170524-1-any.pkg.tar.xz
    sudo pacman -Scc
    sudo pacman-key --refresh-keys
    sudo pacman -Syu
    

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3-wm#gnome-shell

Posts 20Views 11675
Log in to reply