• VMware plus other application max cpu cores


    Dear all,

    I have a weird problem under Antergos.

    I use VMware WS10 / VMplayer6 to run a Win7 VM within my Linux setup. I use VMware over VBox because I’m addicted to the VMware unity mode, so I have a seamless integration of Linux and Win. Anyway, after some time of working, I notice that VMware and the application I at the moment use actively both max out one CPU core fully, making the system kind of slow and painful to work with.

    Example: I browsing with google-chrome of Antergos happily for an hour or longer. And suddenly, chrome maxes out 1 core and VMware a second one, even though the VM should be idle, since there is no application active. That does not happen with chrome alone but also for example with crossover apps (standard use case for my daily work). After it starts to happen, it continues with about every application usage. Fix is to reboot and I have some peace again for some time.

    it does not seem to be DE related since I have the same issue under Cinnamon.

    However, it seems to be an Antergos / Arch issue, since I do not observe it under LMDE on the some machine. I didn’t find anything on Google or DuckDuckGo.

    Any ideas would be greatly appreciated.

    Thanks and cheers!

    Dell Latitude E6230 with Intel i7, 8GB RAM, 500 GB SSD
    dual boot: Antergos and Debian Stretch both 64bit and running gnome-shell
    surviving in a Windows world with VMware WS and Codeweavers Crossover

  • Dear all,

    I have a weird problem under Antergos.

    I use VMware WS10 / VMplayer6 to run a Win7 VM within my Linux setup. I use VMware over VBox because I’m addicted to the VMware unity mode, so I have a seamless integration of Linux and Win. Anyway, after some time of working, I notice that VMware and the application I at the moment use actively both max out one CPU core fully, making the system kind of slow and painful to work with.

    Example: I browsing with google-chrome of Antergos happily for an hour or longer. And suddenly, chrome maxes out 1 core and VMware a second one, even though the VM should be idle, since there is no application active. That does not happen with chrome alone but also for example with crossover apps (standard use case for my daily work). After it starts to happen, it continues with about every application usage. Fix is to reboot and I have some peace again for some time.

    it does not seem to be DE related since I have the same issue under Cinnamon.

    However, it seems to be an Antergos / Arch issue, since I do not observe it under LMDE on the some machine. I didn’t find anything on Google or DuckDuckGo.

    Any ideas would be greatly appreciated.

    Thanks and cheers!

    Dell Latitude E6230 with Intel i7, 8GB RAM, 500 GB SSD
    dual boot: Antergos and Debian Stretch both 64bit and running gnome-shell
    surviving in a Windows world with VMware WS and Codeweavers Crossover

  • Hmm…I’m not familiar with VMWare. Virtualbox has “Seamless Mode”, should be the same thing as VMWare’s Unity mode. Though I’m just guessing, havent tried it myself. ANyway, its possible that there’s a setting in VMWare’s configuration for limiting the VM’s CPU usage that is probably set by Linux Mint at install. Arch generally does not pre configure software settings, they will come with the default settings as released by the developer. I’d recommend reviewing the data available in the Arch wiki for using VMWare. Hope it helps!

    Cheers!

  • Hi Dustin,

    and thanks for your reply. I checked the VMware configs under /etc in both my installations and they seem to be the same. In both cases, VMware was installed from the bundle downloaded from the vmware site, so I guess there is no surprise it’s the same.

    I did check the Arch wiki already and once more more carefully today. However, there is nothing related to the issue I’m seeing.

    @“lots.0.logs”:11a9mag6 said:

    Hmm…I’m not familiar with VMWare. Virtualbox has “Seamless Mode”, should be the same thing as VMWare’s Unity mode. [/quote:11a9mag6]

    Last time I checked (admittedly a few years ago:) Vbox’s “Seamless Mode” restricted the Windows windows to the virtual desktop where VBox was running. Unity lets you freely move the windows apps around on your workspaces just like native linux apps. Then VBox seems to “just” access the VM in some sort of seamless RDP session. Maybe that has changed.
    Anyway, VMware works for me nicely since many years and my boss is paying :)

    VMware just released an update. Maybe that fixes it. Other main difference between my LMDE and Antergos installs is the Gnome version. My LMDE is on 3.8 while Antergos updated to 3.14 (the issue was with me in 3.12 already, though).

    Cheers!

    Dell Latitude E6230 with Intel i7, 8GB RAM, 500 GB SSD
    dual boot: Antergos and Debian Stretch both 64bit and running gnome-shell
    surviving in a Windows world with VMware WS and Codeweavers Crossover

  • @“Leaphorn”:25erjixz said:

    Last time I checked (admittedly a few years ago:) Vbox’s “Seamless Mode” restricted the Windows windows to the virtual desktop where VBox was running.[/quote:25erjixz]A few years is a long time lol…Seamless mode now works just as you described Unity mode. (just fyi)

  • Well, maybe I will give Vbox a spin again some time if I need some play time :) Thanks for the info, though!

    Dell Latitude E6230 with Intel i7, 8GB RAM, 500 GB SSD
    dual boot: Antergos and Debian Stretch both 64bit and running gnome-shell
    surviving in a Windows world with VMware WS and Codeweavers Crossover

Posts 6Views 937
Log in to reply