• \[SOLVED\] TP-Link TL-WN822N losses


    Hi. I need your help adjusting something wrong with my Arch-based distro and USB WiFi adapter: the last one is a TP-Link TL-WN822N.

    The issue is this one: it often happens that automatically network disconnects from the home’s WiFi network, not only when the computer is locked, but even if I’m surfing the internet or just using it.
    Maybe this will help someone understanding something more specifically:

    $ lsusb | grep TL-WN822N  
    Bus 001 Device 005: ID 0cf3:7015 Atheros Communications, Inc. TP-Link TL-WN821N v3 / TL-WN822N v2 802.11n [Atheros AR7010+AR9287]
    

    If you need some other tests, I obviously will do it.

    SOLVED. More informations to: [http://forum.antergos.com/viewtopic.php?f=21&t=2392#p11637][0]">viewtopic.php?f=21&t=2392#p11637

    [0]: <a href=

  • Hi. I need your help adjusting something wrong with my Arch-based distro and USB WiFi adapter: the last one is a TP-Link TL-WN822N.

    The issue is this one: it often happens that automatically network disconnects from the home’s WiFi network, not only when the computer is locked, but even if I’m surfing the internet or just using it.
    Maybe this will help someone understanding something more specifically:

    $ lsusb | grep TL-WN822N  
    Bus 001 Device 005: ID 0cf3:7015 Atheros Communications, Inc. TP-Link TL-WN821N v3 / TL-WN822N v2 802.11n [Atheros AR7010+AR9287]
    

    If you need some other tests, I obviously will do it.

    SOLVED. More informations to: [http://forum.antergos.com/viewtopic.php?f=21&t=2392#p11637][0]">viewtopic.php?f=21&t=2392#p11637

    [0]: <a href=

  • Hi,

    Please post the output of this command:[command:3d91t7wo]sudo lsmod | grep ath[/command:3d91t7wo]

    Also post your journal log immediately following an occurrence of the issue. Thanks.

  • @“lots.0.logs”:27b9l0fg said:

    Hi,
    Please post the output of this command:[command:27b9l0fg]sudo lsmod | grep ath[/command:27b9l0fg]
    Also post your journal log immediately following an occurrence of the issue. Thanks.[/quote:27b9l0fg]

    Here you have, mate:

    \# lsmod | grep ath  
    > ath9k\_htc 64528 0   
    > ath9k\_common 21746 1 ath9k\_htc  
    > ath9k\_hw 424382 2 ath9k\_common,ath9k\_htc  
    > ath 26067 3 ath9k\_common,ath9k\_htc,ath9k\_hw  
    > mac80211 604456 1 ath9k\_htc  
    > cfg80211 445286 4 ath,ath9k\_common,mac80211,ath9k\_htc  
    > usbcore 199381 5 ehci\_hcd,ehci\_pci,usbhid,ath9k\_htc,xhci\_hcd  
    > led\_class 12859 2 sdhci,ath9k\_htc
    
  • It seems I found the solution to this issue: I just needed to disable bluetooth functions, by populating my [i:3fg2e4eq]/etc/modprobe.d/blacklist.conf[/i:3fg2e4eq] with:

    btusb  
    bluetooth  
    install btusb /bin/false  
    install bluetooth /bin/false
    
Posts 5Views 1678
Log in to reply