• Changes to Microcode Updates For Intel CPUs


    Thank you, it worked!

    Azrael: I have Intel CPU also, computer worked just fine before and after making intel-specific changes, I see no difference in performance. Maybe some finer functions are affected.

  • @Azrael^^ & @HJD09 this fix is not going to effect whether or not your system boots but whether or not your system uses microcode from Intel and updates to that microcode.

    You can choose to ignore the intel-ucode package if you want to but you will not be able to receive microcode updates or utilize them anymore. Microcode applies to many things but most cpu improvements and security fixes. If you do not go through this process you will simply not be able to update your microcode.

    I think that anyone using Arch based system should go through this process because it is certainly worth having those updates because microcode is rather important but the point of having Arch is to get updates as fast as possible and if you choose to not do it then why are you using an Arch based system? :)

    Personal: http://michaeltunnell.com
    Business: http://visuex.com

  • Ok, the problem I think was that…I wasn’t sure about what microcode is. That is why I wasn’t understanding this. Thank you for clarifying!

  • @“Azrael^^”:1raycge9 said:

    Ok, the problem I think was that…I wasn’t sure about what microcode is. That is why I wasn’t understanding this. Thank you for clarifying![/quote:1raycge9]
    You’re welcome.

    I know these kinds of fixes make you want to

    Personal: http://michaeltunnell.com
    Business: http://visuex.com

  • [[email protected] ~]$ dmesg | grep microcode  
    [ 2.075377] microcode: CPU0 sig=0x306a9, pf=0x10, revision=0x16  
    [ 2.075384] microcode: CPU1 sig=0x306a9, pf=0x10, revision=0x16  
    [ 2.075388] microcode: CPU2 sig=0x306a9, pf=0x10, revision=0x16  
    [ 2.075395] microcode: CPU3 sig=0x306a9, pf=0x10, revision=0x16  
    [ 2.075453] microcode: Microcode Update Driver: v2.00 <[email protected]\>, Peter Oruba  
    [[email protected] ~]$
    

    Awesom guide…works fine

  • Looks like the latest grub update (grub 1:2.02.beta2-5) fixes the automatic loading of intel microcode. See the changelist:

    [url:2sqil6xv]https://projects.archlinux.org/svntogit/packages.git/commit/trunk?h=packages/grub&id=e9986fb7c29be259e680b91a3732f1a12dbf02b7[/url:2sqil6xv]

    Here is some of the changes:

    diff --git a/trunk/grub-intel-ucode.patch b/trunk/grub-intel-ucode.patch  
    new file mode 100644  
    index 0000000..de6bd28  
    --- /dev/null  
    +++ b/trunk/grub-intel-ucode.patch  
    @@ -0,0 +1,26 @@  
    +diff --git a/util/grub.d/10\_linux.in b/util/grub.d/10\_linux.in  
    +index d2e2a8f..f67e50f 100644  
    +--- a/util/grub.d/10\_linux.in  
    ++++ b/util/grub.d/10\_linux.in  
    [email protected]@ -65,6 +65,12 @@ case x"$GRUB\_FS" in  
    + ;;  
    + esac  
    +  
    ++intel\_ucode=  
    ++if test -e "/boot/intel-ucode.img" ; then  
    ++ gettext\_printf "Found Intel Microcode image\\n" \>&2  
    ++ intel\_ucode="$(make\_system\_path\_relative\_to\_its\_root /boot/intel-ucode.img)"  
    ++fi  
    ++  
    + title\_correction\_code=  
    +  
    + linux\_entry ()  
    [email protected]@ -136,7 +142,7 @@ EOF  
    + message="$(gettext\_printf "Loading initial ramdisk ...")"  
    + sed "s/^/$submenu\_indentation/" << EOF  
    + echo '$(echo "$message" | grub\_quote)'  
    +- initrd ${rel\_dirname}/${initrd}  
    ++ initrd ${intel\_ucode} ${rel\_dirname}/${initrd}  
    + EOF  
    + fi  
    + sed "s/^/$submenu\_indentation/" << EOF
    
  • So a fresh installation should not have this kind of problem, am I correct?

  • Currently the process for existing users using grub and intel microcode:
    1. Update to the latest grub release (grub 1:2.02.beta2-5)
    2. Install intel-ucode
    3. Run: # grub-mkconfig -o /boot/grub/grub.cfg
    4. Reboot
    5. Verify that the changes worked: dmesg | grep microcode

    Refer to url:
    [url:2p7fg6d6]https://wiki.archlinux.org/index.php/Microcode#Grub[/url:2p7fg6d6]

  • @“DNAngel”:3rdwhxiw said:

    So a fresh installation should not have this kind of problem, am I correct?[/quote:3rdwhxiw]
    Not sure but follow / verify using the “existing user” process in my prior post.

  • Has this been taken care with latest installations or do we still need to do it manually?

  • Hi,
    Short answer: You have to do it manually.
    Long answer: The installer does not know/care if you’re using intel or not, so it’s not installing the intel-ucode package.

    Cheers!

  • @karasu Yes I install it manually after installing Antergos but do we need to do the grub or thats no longer necessary?

  • After installing it, it’s best to run
    sudo grub-mkconfig -o /boot/grub/grub.cfg

    That way grub will find the ucode and add it to your boot.

    Cheers!

Posts 34Views 13051
Log in to reply