• Changes to Microcode Updates For Intel CPUs


    Microcodes on Intel CPUs is no longer loaded automatically, as it needs to be loaded very early in the boot process. This requires manual adjustments in the bootloader. If you have an Intel CPU, please follow
    [b:6hhpcnnx][the instructions in the Arch wiki[/url:6hhpcnnx].[/b:6hhpcnnx]

    This will be taken care of for new installations within the next few days. Let us know if you have any questions!

    Best Regards,]0

  • Microcodes on Intel CPUs is no longer loaded automatically, as it needs to be loaded very early in the boot process. This requires manual adjustments in the bootloader. If you have an Intel CPU, please follow
    [b:6hhpcnnx][the instructions in the Arch wiki[/url:6hhpcnnx].[/b:6hhpcnnx]

    This will be taken care of for new installations within the next few days. Let us know if you have any questions!

    Best Regards,]0

  • Tengo dudas de como actualizar, según las instrucciones del enlace hay que instalar de primero [b:3rezj83v]intel-ucode 20140913-1[/b:3rezj83v], pero da este problema

    teto ~ $ sudo pacman -S intel-ucode  
    resolviendo dependencias...  
    verificando conflictos...  
      
    Paquetes (1):  
      
    Nombre Versión nueva Cambio Neto Tamaño de la descarga  
      
    extra/intel-ucode 20140624-1 0.63 MiB 0.46 MiB  
      
    Tamaño Total de Descarga: 0.46 MiB  
    Tamaño Total Instalado: 0.63 MiB  
      
    :: ¿Continuar con la instalación? [S/n] s  
    :: Recuperando paquetes ...  
    error: error al obtener archivo 'intel-ucode-20140624-1-any.pkg.tar.xz' desde dfw.mirror.rackspace.com: The requested URL returned error: 404 Not Found  
    error: error al obtener archivo 'intel-ucode-20140624-1-any.pkg.tar.xz' desde archlinux.limun.org: The requested URL returned error: 404 Not Found  
    error: error al obtener archivo 'intel-ucode-20140624-1-any.pkg.tar.xz' desde mirror.de.leaseweb.net: The requested URL returned error: 404 Not Found  
    error: error al obtener archivo 'intel-ucode-20140624-1-any.pkg.tar.xz' desde archlinux.mirror.kangaroot.net: The requested URL returned error: 404 Not Found  
    error: error al obtener archivo 'intel-ucode-20140624-1-any.pkg.tar.xz' desde ftp.nluug.nl: The requested URL returned error: 404 Not Found  
    error: error al obtener archivo 'intel-ucode-20140624-1-any.pkg.tar.xz' desde archlinux.mirrors.uk2.net: The requested URL returned error: 404 Not Found  
    error: error al obtener archivo 'intel-ucode-20140624-1-any.pkg.tar.xz' desde mirror.us.leaseweb.net: The requested URL returned error: 404 Not Found  
    error: error al obtener archivo 'intel-ucode-20140624-1-any.pkg.tar.xz' desde archlinux.limun.org: The requested URL returned error: 404 Not Found  
    error: error al obtener archivo 'intel-ucode-20140624-1-any.pkg.tar.xz' desde ftp.tsukuba.wide.ad.jp: The requested URL returned error: 404 Not Found  
    error: error al obtener archivo 'intel-ucode-20140624-1-any.pkg.tar.xz' desde mirror.chmuri.net: The requested URL returned error: 404 Not Found  
    error: error al obtener archivo 'intel-ucode-20140624-1-any.pkg.tar.xz' desde ftp.tku.edu.tw: The requested URL returned error: 404 Not Found  
    error: error al obtener archivo 'intel-ucode-20140624-1-any.pkg.tar.xz' desde mirror.one.com: The requested URL returned error: 404 Not Found  
    error: error al obtener archivo 'intel-ucode-20140624-1-any.pkg.tar.xz' desde lug.mtu.edu: The requested URL returned error: 404 Not Found  
    error: error al obtener archivo 'intel-ucode-20140624-1-any.pkg.tar.xz' desde mirror.pregi.net: The requested URL returned error: 500 Internal Server Error  
    error: error al obtener archivo 'intel-ucode-20140624-1-any.pkg.tar.xz' desde hkg.mirror.rackspace.com: The requested URL returned error: 404 Not Found  
    error: error al obtener archivo 'intel-ucode-20140624-1-any.pkg.tar.xz' desde archlinux.polymorf.fr: The requested URL returned error: 404 Not Found  
    error: error al obtener archivo 'intel-ucode-20140624-1-any.pkg.tar.xz' desde mirror.nexcess.net: The requested URL returned error: 404 Not Found  
    error: error al obtener archivo 'intel-ucode-20140624-1-any.pkg.tar.xz' desde ftp.lysator.liu.se: The requested URL returned error: 404 Not Found  
    error: error al obtener archivo 'intel-ucode-20140624-1-any.pkg.tar.xz' desde mirror.unitedcolo.de: The requested URL returned error: 404 Not Found  
    error: error al obtener archivo 'intel-ucode-20140624-1-any.pkg.tar.xz' desde mirror.us.leaseweb.net: Protocol "rsync" not supported or disabled in libcurl  
    atención: falló al recuperar algunos archivos  
    error: error al realizar la transacción (error de descarga de biblioteca)  
    Ocurrieron errores, no se actualizaron paquetes  
    
    

    Entonces usé la opción de bajarlo del mirror [b:3rezj83v](intel-ucode-20140913-1-any.pkg.tar.xz)[/b:3rezj83v], nos sé como instalarlo, así que lo descomprimí y me dió dos carpetas una que se llama [b:3rezj83v]boot[/b:3rezj83v] y que contiene [b:3rezj83v]intel-ucode.img[/b:3rezj83v] y la otra [b:3rezj83v]usr/share/licenses[/b:3rezj83v] la cual contiene [b:3rezj83v]intel-ucode[/b:3rezj83v]. Pregunta: [i:3rezj83v]¿sólo debo mover estos archivos a las carpetas correspondientes de mi raíz?[/color:3rezj83v][/i:3rezj83v]
    [b:3rezj83v]Segundo paso:[/b:3rezj83v]
    Grub
    Tango-view-fullscreen.png This article or section needs expansion.
    Reason: Instructions for grub are missing. (Discuss)
    For the time being, you can manually add /intel-ucode.img in your grub.cfg as follows:
    […]
    echo 'Loading initial ramdisk …'
    initrd /intel-ucode.img /initramfs-linux.img
    […]
    Remember that the path to /intel-ucode.img is relative to the boot partition, just as that of initramfs. This means that if you have a dedicated /boot partition you should use /intel-ucode.img; else use /boot/intel-ucode.img.
    Es que no entiendo como ponerlo en el grub.cfg. A los moderadores, de antemano muchas gracias por su paciencia.
    Saludos
    PD. tengo instalado KDE en una notebook HP 430 Intel Pentium CPU P6200 @ 2.133GHz

  • Hola,

    Primero, la actualización es muy reciente, ahora mismo algunos mirrors aún no estan actualizados, pero algunos si lo estan. A mi me ha funcionado.

    Prueba a ejecutar:

      
    pacman -Syu  
    pacman -S intel-ucode  
    
    

    Para instalar un paquete que te has descargado no tienes que descomprimirlo, simplemente ejecuta:

    pacman -U paquete.xz
    

    El segundo paso es bastante chapuza, te dice de editar directamente el grub.cfg (cosa que no se recomienda, puesto que es un fichero que se genera automáticamente con grub-mkconfig).

    Edita pues el grub.cfg (/boot/grub/grub.cfg) y añade /intel-ucode.img a la linea del initrd tal que así:

    initrd /intel-ucode.img /initramfs-linux.img
    

    Saludos!

  • Karasu

  • please provide instructions in english- the wiki wasn’t very helpful for me

    [img:1pt1tebw]http://i59.tinypic.com/33e3r08.png[/img:1pt1tebw]
    [b:1pt1tebw]Don't forget to mark your thread as [SOLVED] [/b:1pt1tebw]

  • Hi Max, I’ll translate my previous message hoping that it will help you. If you have more questions please just ask.

    My previous post now in English:

    Hi,

    First, that update is recent, so some mirrors are not updated yet, but others are. I’ve tried and it worked here.

    Try to update first your pacman db and then install the package:

      
    pacman -Syu  
    pacman -S intel-ucode  
    
    

    Oh, to install a downloaded package you don’t have to decompress it, just run:

    pacman -U package.xz
    

    The second step is a bit of a botched job, as it tells you to edit the grub.cfg file (which in normal circumstances you should not do, as it’s an automatically generated file by the command grub-mkconfig).

    So, edit the grub.cfg file (/boot/grub/grub.cfg) and just add /intel-ucode.img to the initrd line, so it looks like this:

    initrd /intel-ucode.img /initramfs-linux.img
    

    Cheers!

  • Thanks karasu!

    [img:1pt1tebw]http://i59.tinypic.com/33e3r08.png[/img:1pt1tebw]
    [b:1pt1tebw]Don't forget to mark your thread as [SOLVED] [/b:1pt1tebw]

  • karasu, are the 2nd and 3rd steps optional?

    1st step worked, but 2nd resulted “error: ‘package.xz’: could not find or read package”, and for 3rd: “initrd /intel-ucode.img /initramfs-linux.img
    bash: initrd: command not found”.

    Thank you.

  • Hi the second “step” was something specific to the OP’s question. You only need to do the first step and the last step. The last one is not a command. You must edit your grub.cfg file, changing the initrd line to look like the example.

    Cheers!

  • Hello can you explain what that do ? I don’t understand if I need to do it or not.

    Long Live Antergos
    [Major Linux Problems on the Desktop or Why Linux is not (yet) Ready for the Desktop, 2016 edition] (http://linuxfonts.narod.ru/why.linux.is.not.ready.for.the.desktop.current.html)

  • do you know if you have the haswell gpu?

    [img:1pt1tebw]http://i59.tinypic.com/33e3r08.png[/img:1pt1tebw]
    [b:1pt1tebw]Don't forget to mark your thread as [SOLVED] [/b:1pt1tebw]

  • Hi,

    Run this command:[command:2d60niap]sudo sed -i ‘s%initrd\t/initramfs-linux\.img%initrd\t/intel-ucode\.img /initramfs-linux\.img%g’ /boot/grub/grub.cfg[/command:2d60niap]

    Cheers!

  • @“maxpro4u”:1om3s02b said:

    do you know if you have the haswell gpu?[/quote:1om3s02b]

    no I don’t. I have an old Intel Pentium T4400.

    Long Live Antergos
    [Major Linux Problems on the Desktop or Why Linux is not (yet) Ready for the Desktop, 2016 edition] (http://linuxfonts.narod.ru/why.linux.is.not.ready.for.the.desktop.current.html)

  • Tutorial:

    1. You need to update your pacman database and it will ask you to update packages which is fine, go ahead and do that.

    sudo pacman -Syu
    

    2. Now install the intel-ucode package.

    pacman -S intel-ucode
    

    3. The next step is to update the grub.xfg file to include ucode. The following command will open the file grub.cfg in gedit as root so you can edit it.

    sudo gedit "/boot/grub/grub.cfg"
    

    4. This file will have a lot of lines that were auto-generated by Grub. Search for the following, “initrd”. You will find two instances of that in the file. The first instance will include the term “initramfs-linux.img”. There you will add “/intel-ucode.img” in front of it so it looks like:

    initrd /intel-ucode.img /initramfs-linux.img
    

    5. Save the grub.cfg changes and restart…you should be back up with everything up to date.

    Personal: http://michaeltunnell.com
    Business: http://visuex.com

  • Thanks, I did it, and when I run:

      
    dmesg | grep microcode
    

    I got result:

    [ 0.000000] CPU0 microcode updated early to revision 0x29, date = 2013-06-12  
    [ 0.138001] CPU1 microcode updated early to revision 0x29, date = 2013-06-12  
    [ 0.480101] microcode: CPU0 sig=0x206a7, pf=0x10, revision=0x29  
    [ 0.480115] microcode: CPU1 sig=0x206a7, pf=0x10, revision=0x29  
    [ 0.480216] microcode: Microcode Update Driver: v2.00 <[email protected]\>, Peter Oruba
    

    So, this means that it works, doesn’t it?

    Asus X201EP | Intel Celeron 2x 1.10 GHz | 4 GB DDR3 RAM | Antergos 64-Bit.

  • lots.0.logs, how editing of grub.cfg file works in Antergos?
    When I tried right click on file name and open it in text editor, permission was denied. And I don’t see option “Open folder as Administrator”. If this tread is not a place for this, maybe in separate thread?
    Thank you.

    nekosan: it looks like people who have PC with Intel processor have to do that manually: enter first command in Terminal, and edit grub.cfg file through text editor. I’m not qualified to advice about anything in Antergos, this is how it would have worked in Linux Mint.

  • @“HJD09”:2nflhrax said:

    lots.0.logs, how editing of grub.cfg file works in Antergos?
    When I tried right click on file name and open it in text editor, permission was denied. And I don’t see option “Open folder as Administrator”. If this tread is not a place for this, maybe in separate thread?
    [/quote:2nflhrax]

    The command:

    sudo gedit "/boot/grub/grub.cfg"
    

    Would give us sufficient right to edit it (as administrator).

    Asus X201EP | Intel Celeron 2x 1.10 GHz | 4 GB DDR3 RAM | Antergos 64-Bit.

  • @“HJD09”:217j1e64 said:

    lots.0.logs, how editing of grub.cfg file works in Antergos?
    When I tried right click on file name and open it in text editor, permission was denied. And I don’t see option “Open folder as Administrator”. If this tread is not a place for this, maybe in separate thread?
    Thank you.[/quote:217j1e64]You can open as root using this command[command:217j1e64]sudo -E gedit /file/to/open[/command:217j1e64]
    If you want to get it done quickly, you could just copy/paste the sed command from my previous post

  • I also have doubts. Is this even necessary?? Yes, I have an intel CPU, just like almost everyone, but my laptop has been working fine and I haven’t installed intel-ucode. What it does? Should I install and make the grub changes??

Posts 34Views 13291
Log in to reply