• Lightdm with cinnamon default session


    I switched from lightdm to LXDM, because I couldn’t get cinnamon as default. Since I installed gnome3 first, lightdm simply wouldn’t allow me to either remove gnome3 from the session list (even after deleting it) or have cinnamon as the default. Even after editing the conf files.

    Is there any way to switch back to lightdm and with cinnamon as default?

    I used this command to get to LXDM…
    sudo systemctl disable lightdm && sudo systemctl enable lxdm

    But this command doesn’t work
    sudo systemctl disable lxdm && sudo systemctl enable lightdm

    When I reboot it just doesn’t load a dm at all until I put it back to lxdm in the console and use that.

  • I switched from lightdm to LXDM, because I couldn’t get cinnamon as default. Since I installed gnome3 first, lightdm simply wouldn’t allow me to either remove gnome3 from the session list (even after deleting it) or have cinnamon as the default. Even after editing the conf files.

    Is there any way to switch back to lightdm and with cinnamon as default?

    I used this command to get to LXDM…
    sudo systemctl disable lightdm && sudo systemctl enable lxdm

    But this command doesn’t work
    sudo systemctl disable lxdm && sudo systemctl enable lightdm

    When I reboot it just doesn’t load a dm at all until I put it back to lxdm in the console and use that.

  • It sounds like something is not correct in your lightdm configuration. Try this:[command:14j94pn5]sudo pacman -Rc lightdm --nosave
    sudo pacman -Syy lightdm-webkit-theme-antergos
    sudo systemctl disable lxdm && sudo systemctl enable lightdm[/command:14j94pn5]

  • That fixed it.
    Thanks.

Posts 4Views 2122
Log in to reply