• Wi-fi connection problems on HP Envy TS 17 laptop


    Hello, I’ve just finished installing Antergos on my laptop, and am unable to connect to my wpa2 wireless connection. I can see the network in the network manager, and it asks for my password but just seems to get stuck at ‘connecting’. It never pops up any error and never connects. Any ideas? The driver seems to be installed and I’m fresh out of ideas as to how to troubleshoot this. I’ve looked around online but can’t seem to find anyone else with this particular problem. I’m running Antergos with Gnome3 and networkmanager.

    Thanks in advance for any help on this!

  • Hello, I’ve just finished installing Antergos on my laptop, and am unable to connect to my wpa2 wireless connection. I can see the network in the network manager, and it asks for my password but just seems to get stuck at ‘connecting’. It never pops up any error and never connects. Any ideas? The driver seems to be installed and I’m fresh out of ideas as to how to troubleshoot this. I’ve looked around online but can’t seem to find anyone else with this particular problem. I’m running Antergos with Gnome3 and networkmanager.

    Thanks in advance for any help on this!

  • I’d call you “bro” for this. As I have HP too and I faced the exactly same issue.

    I don’t know what exactly solved my problem but I first installed [wicd[/url:zim06ydk] then I tried installing [wireless drivers[/url:zim06ydk] then I mistakenly completely uninstalled Gnome shell and had to reinstall it back. Yep, then my wifi was working!

    UPDATE: I also played with “[ip link[/url:zim06ydk]” and “dhcpcd” commands! (dhcpcd is very powerful! It can easily stop both your wired and wireless internet access. because it did mine).

    I tell you dude, I had a horrible experience getting wifi working on my arch!]2]1]0

    Archlinux x64

    AMD A4-3305M Processor
    6GB RAM
    1GB+512MB Hybrid AMD GPU

  • Yeah, I think I might try removing networkmanager and try wicd. I had the exact same problem during installation, and switched to wired ethernet. That does work, but as this is a laptop, i’d rather use the wireless.

    I have an Intel 3160 wireless card, that is listed and shown as up, but dormant. The wired connection is listed as up and default. Any way to change this? Even if I turn off the wired connection, the wireless will not connect.

    What’s really annoying, is there does not seem to be any errors.

  • Tried wicd yet?

    btw could you post the result of “ip link” command in terminal?

    Archlinux x64

    AMD A4-3305M Processor
    6GB RAM
    1GB+512MB Hybrid AMD GPU

  • I did try wicd, but my results were the same. I could connect via wired connection, but not via wireless. I went back to nm.

    Results of ip link:

    [1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN mode DEFAULT group default
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    2: eno1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP mode DEFAULT group default qlen 1000
    link/ether a0:1d:48:ff:ec:20 brd ff:ff:ff:ff:ff:ff
    3: wlo1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP mode DORMANT group default qlen 1000
    link/ether a0:88:69:13:d3:00 brd ff:ff:ff:ff:ff:ff]

  • I also ran systemctl --type=service, and here are the results. Maybe there is a service I am missing?

    UNIT LOAD ACTIVE SUB DESCRIPTION
    accounts-daemon.service loaded active running Accounts Service
    bluetooth.service loaded active running Bluetooth service
    colord.service loaded active running Manage, Install and Generate
    cups.service loaded active running CUPS Printing Service
    dbus.service loaded active running D-Bus System Message Bus
    geoclue.service loaded active running Location Lookup Service
    kmod-static-nodes.service loaded active exited Create list of required stati
    lightdm.service loaded active running Light Display Manager
    ModemManager.service loaded active running Modem Manager
    NetworkManager.service loaded active running Network Manager
    polkit.service loaded active running Authorization Manager
    rtkit-daemon.service loaded active running RealtimeKit Scheduling Policy
    [email protected]:intel_backlight.service loaded active exited Load/S
    systemd-journald.service loaded active running Journal Service
    systemd-logind.service loaded active running Login Service
    systemd-random-seed.service loaded active exited Load/Save Random Seed
    systemd-remount-fs.service loaded active exited Remount Root and Kernel File
    [email protected] loaded active exited Load/Save RF Kill Switch St
    [email protected] loaded active exited Load/Save RF Kill Switch St
    systemd-sysctl.service loaded active exited Apply Kernel Variables
    systemd-timesyncd.service loaded active running Network Time Synchronization
    systemd-tmpfiles-setup-dev.service loaded active exited Create Static Device No

  • ^ This is too complicated for a normal linux user like me xD
    wifi-radar is another GUI alternative(didn’t work for me)

    In terminal, You can check the link status of your wifi

    iwconfig wlo1
    

    then you can try

    dhcpcd wlo1
    

    or you can use

    iwconfig wlo1 essid "your\_essid"
    

    *Your ESSID is your wifi name(write in between " " if there are spaces in name)

    or if your wifi is password protected

    iwconfig wlo1 essid "your\_essid" key your\_key
    

    Archlinux x64

    AMD A4-3305M Processor
    6GB RAM
    1GB+512MB Hybrid AMD GPU

  • I am currently re-installing Antergos to have a clean install with a different desktop environment. As soon as it’s completed, I will run those commands. When I ran them before, everything looked good - this is why it’s so frustrating…I can’t seem to find a “problem”, yet it doesn’t work. It should only be a few more minutes, and I will post the results of the above.

  • Hi,

    Check the following files to ensure the content is exactly as shown:[config=/etc/pam.d/lightdm:1y8d3g39]#%PAM-1.0
    auth include system-login
    auth optional pam_gnome_keyring.so
    account include system-login
    password include system-login
    session include system-login
    session optional pam_gnome_keyring.so auto_start[/config:1y8d3g39]
    [config=/etc/pam.d/passwd:1y8d3g39]#%PAM-1.0
    #password required pam_cracklib.so difok=2 minlen=8 dcredit=2 ocredit=2 retry=3
    #password required pam_unix.so sha512 shadow use_authtok
    password required pam_unix.so sha512 shadow nullok
    password optional pam_gnome_keyring.so[/config:1y8d3g39]If you had to make corrections to either of the files, reboot your system. Upon logging in you should be prompted by gnome-keyring asking if you wish to unlock the keyring. If it asks to set a password for the keyring, be sure to use the same password as your user account. Please let me know the result. Thanks!

    Best Regards,

  • OK, I checked those files and added/edited the lines for the gnome-keyring as shown. However, the problem persists. Also, I was not prompted to unlock the keyring, or to add a password.

  • what happens when you run this:[command:2hbv6tpc]gnome-keyring-daemon --start
    gnome-keyring-daemon --unlock[/command:2hbv6tpc]

  • When I run:

    gnome-keyring-daemon --start

    I get these lines:

    GPG_AGENT_INFO=/run/user/1000/keyring/gpg:0:1
    SSH_AUTH_SOCK=/run/user/1000/keyring/ssh

    Running:

    gnome-keyring-daemon --unlock

    seems to leave me at a blinking cursor.

    Also, not sure if this makes a difference or not, but it seems as though it’s getting stuck at ‘setting network address’. I have no trouble getting an address via a wired connection though. It will authenticate just fine, then never gets an ip.

  • I don’t know if this helps, but:

    [[email protected] ~]$ dmesg | grep firmware
    [ 7.949728] iwlwifi 0000:01:00.0: Direct firmware load for iwlwifi-3160-10.ucode failed with error -2
    [ 8.210690] Bluetooth: hci0: Intel Bluetooth firmware file: intel/ibt-hw-37.7.10-fw-1.0.2.3.d.bseq
    [ 8.250443] iwlwifi 0000:01:00.0: loaded firmware version 25.222.9.0 op_mode iwlmvm
    [ 8.331889] Bluetooth: hci0: Intel Bluetooth firmware patch completed and activated

    It seems the firmware is not loading? I checked the /lib/firmware folder, and this firmware is not present. Instead I have iwlwifi-3160-9.ucode; What can I do to fix this?

    Thanks so much for all the help thus far!

  • There was a change to the way intel processor microcode updates are handled. See here for details. Let me know if it works after following the instructions:

    [http://forum.antergos.com/viewtopic.php?f=5&t=2372][0]">viewtopic.php?f=5&t=2372

    [0]: <a href=

  • OK, I installed Intel-code, and there was a message that it was already installed and no files were changed. I then added it to initrd and re-booted. I had to remove both my wired and wireless profiles and reboot again, and now my wired connection will work still, but still no dice on the wireless. Not sure what to do…

    Also, the firmware is still not loading as I don’t have the iwlwifi-3160-10.ucode version. Mine only goes to 9. Is there a way to change the firmware it tries to load?

    [[email protected] ~]$ dmesg | grep iwlwifi
    [ 8.180650] iwlwifi 0000:01:00.0: irq 30 for MSI/MSI-X
    [ 8.203650] iwlwifi 0000:01:00.0: Direct firmware load for iwlwifi-3160-10.ucode failed with error -2
    [ 9.836817] iwlwifi 0000:01:00.0: loaded firmware version 25.222.9.0 op_mode iwlmvm
    [ 11.318094] iwlwifi 0000:01:00.0: Detected Intel® Dual Band Wireless AC 3160, REV=0x164
    [ 11.318162] iwlwifi 0000:01:00.0: L1 Enabled; Disabling L0S
    [ 11.318404] iwlwifi 0000:01:00.0: L1 Enabled; Disabling L0S
    [ 11.650762] iwlwifi 0000:01:00.0 wlo1: renamed from wlan0
    [ 19.931186] iwlwifi 0000:01:00.0: L1 Enabled; Disabling L0S
    [ 19.931427] iwlwifi 0000:01:00.0: L1 Enabled; Disabling L0S
    [ 146.821443] iwlwifi 0000:01:00.0 wlo1: disabling HT as WMM/QoS is not supported by the AP
    [ 146.821451] iwlwifi 0000:01:00.0 wlo1: disabling VHT as WMM/QoS is not supported by the AP

  • Here is the error I get when trying to install intel-ucode:

    error: failed to commit transaction (conflicting files)
    intel-ucode: /boot/intel-ucode.img exists in filesystem
    Errors occurred, no packages were upgraded.

    EDIT: I was able to get it installed by renaming the intel-ucode.img file to intel-ucode.img.old. However, this still does not have the iwlwifi-3160-10.ucode version, only the iwlwifi-3160-9.ucode. So, is there a different package I need to install, or can I change the version that is being loaded?

  • Hi,

    I don’t think the error message about the ucode update to version 10 is a problem. Version 10 has not been released yet. The latest is version 9. It clearly shows that it is successfully loading the firmware:

    [ 9.836817] iwlwifi 0000:01:00.0: loaded firmware version 25.222.9.0 op\_mode iwlmvm
    

    Try creating the the following config files as shown:[config=/etc/modprobe.d/iwlmvm.conf:3784ztji]options iwlmvm power_scheme=1[/config:3784ztji]
    [config=/etc/modprobe.d/iwlwifi.conf:3784ztji]options iwlwifi bt_coex_active=Y swcrypto=1 11n_disable=1[/config:3784ztji]Reboot your system afterwards and check the result. If its still nto working please post your journal log. Instructions are posted in the forum if you need them.

    Best Regards,

  • OK, I tried adding the .conf files as instructed, with no result. The wireless connection is still stuck at ‘setting network address’. So, I am including my journal logs as requested. Your help is very much appreciated, thank you!

    :exclamation:Sorry, this attachment is unavailable.

  • Hmm…try this:

    [command:2c8ydefp]sudo pacman -S dhclient
    sudo systemctl disable dhcpd
    sudo systemctl enable dhclient[/command:2c8ydefp]

    Then make the following config file change:[config=/etc/NetworkManager/NetworkManager.conf:2c8ydefp]dhcp = dhclient[/config:2c8ydefp]

    Finally, reboot and check the result.

    Cheers!

Posts 20Views 4604
Log in to reply