• \[SOLVED\] Touchpad configuration


    I just installed the (not so) new Antergos distro. Very nice work I must say but as always I have some issues/questions.

    My first question is about my touchpad. I can configure it in the system settings but, vertical (and horizontal) scrolling cannot be set. Scrolling with two fingers is checked but grayed out (not changable) and is not working on my pad.

    My question is can I edit the /etc/X11/xorg.conf.d/50-synaptics.conf with additional parameters (which I got from the PClinuxOS support site :-p )

    Antergos: funny name, serious distro

  • I just installed the (not so) new Antergos distro. Very nice work I must say but as always I have some issues/questions.

    My first question is about my touchpad. I can configure it in the system settings but, vertical (and horizontal) scrolling cannot be set. Scrolling with two fingers is checked but grayed out (not changable) and is not working on my pad.

    My question is can I edit the /etc/X11/xorg.conf.d/50-synaptics.conf with additional parameters (which I got from the PClinuxOS support site :-p )

    Antergos: funny name, serious distro

  • @“bootz”:2qa685jy said:

    I just installed the (not so) new Antergos distro. Very nice work I must say but as always I have some issues/questions.

    My first question is about my touchpad. I can configure it in the system settings but, vertical (and horizontal) scrolling cannot be set. Scrolling with two fingers is checked but grayed out (not changable) and is not working on my pad.

    My question is can I edit the /etc/X11/xorg.conf.d/50-synaptics.conf with additional parameters (which I got from the PClinuxOS support site :-p )[/quote:2qa685jy]

    Tried the solution I used on PClinuxOS but that doesn’t work. So anyone who could help me (it is working on Manjaro, also Arch)

    Antergos: funny name, serious distro

  • Try removing that file to see if the control center let you check those grayed out options, just out of curiosity

  • I had the same issue until I installed the libsynaptiks package from the repos. Now GNOME Control Center configures my touch pad like it should.

  • With the 50-synaptics file removed, Gnome doesn’t know my mousepad (works though). With the file and the libsynaptic installed no change.

    Reinstalled antergos with RazorQT desktop (WoW, that’s fast) it works out of the box (5-synaptics file is the same as with gnome3) but I had problems to choose the correct keyboard layout.

    Reinstalled antergos with Xfce desktop and all works fine to out of the box. Libsynaptic not installed, 50-synaptic file the same as with Gnome3. It seems a te be a Gnome problem?

    Antergos: funny name, serious distro

  • Got it!

    Synclient from the terminal does the job. It doesn’t touch the 50-synaptic file so it will be written somewhere in a Gnome3 configuration file…

    Antergos: funny name, serious distro

  • What is your laptop/touchpad name?

    Don't forget to mark as [SOLVED], if your problem was solved!

  • @“I-sty”:1gp466zo said:

    What is your laptop/touchpad name?[/quote:1gp466zo]

    I do not know the name of my touchpad but the laptop is an Acer Extensa 5230E.

    Antergos: funny name, serious distro

  • @“I-sty”:3auld55n said:

    What is your laptop/touchpad name?[/quote:3auld55n]

    Think it is called an ALPS.

    Antergos: funny name, serious distro

  • Thought I had it fixed, but the fix only lasts until reboot. Set it under su but the same thing happens.

    Antergos: funny name, serious distro

  • @“bootz”:1n1z6o68 said:

    Thought I had it fixed, but the fix only lasts until reboot. Set it under su but the same thing happens.[/quote:1n1z6o68]

    Finally solved it. In dconf editor for gnome disabled org.gnome.settings-deamon.plugins.mouse. Now it respects my /etc/X11/xorg.conf.d/50-synaptics.com

    Antergos: funny name, serious distro

  • @“bootz”:sxz9ad65 said:

    Reinstalled antergos with Xfce desktop and all works fine to out of the box.[/quote:sxz9ad65]

    That is so weird. Gnome and Xfce use mostly the same libraries. Have you found a solution to this? Does the synaptiks-gtk tool allow you to configure the touch pad? I know the expected behavior is for gnome settings to do this but if either the gtk or qt GUI tool from AUR work correctly, it would make me lean towards it being a gnome-control-center bug.

  • @“lots.0.logs”:21ua5jlo said:

    @“bootz”:21ua5jlo said:

    Reinstalled antergos with Xfce desktop and all works fine to out of the box.[/quote:21ua5jlo]

    That is so weird. Gnome and Xfce use mostly the same libraries. Have you found a solution to this? Does the synaptiks-gtk tool allow you to configure the touch pad? [/quote:21ua5jlo]

    Synaptiks-gtk does not appear as an installed program under my standard Gnome installation. For as far as I can remember I didn’t observe this strange behaviour on other Linux distro’s with Gnome or any other desktop. Not too sure about Manjaro, maybe I will test it on the live CD/DVD from both.

    Antergos: funny name, serious distro

  • The synaptik-gtk has to be installed from the AUR. That is the only thing that I have different from what you tried and mine is working both from there and GNOME settings. Maybe give it a try

  • @“lots.0.logs”:38i65zen said:

    The synaptik-gtk has to be installed from the AUR. That is the only thing that I have different from what you tried and mine is working both from there and GNOME settings. Maybe give it a try

    I only see a Synaptiks-git package, is that the one?

    Antergos: funny name, serious distro

  • Sorry, I must have gotten my wires crossed thinking of another package (happens a lot when you use multiple distros LOL). Anyway, yes its synaptiks-git. Keep in mind, that is a QT based app and will pull in the QT libraries. I already had them installed so it didnt matter to me, but since your touchpad is now working you might not want to install all of those packages. I know I wouldn’t

  • @“lots.0.logs”:144m2m4r said:

    … but since your touchpad is now working you might not want to install all of those packages. I know I wouldn’t

    Well, I do not know why not, allready installed zsnes which is a 32 bit application and I got a lot of libraries with it and all is (still) working fine. But you will be right, I just did a clean install (tested bluestar with a nice KDE desktop) so I will leave it for what it is.

    Antergos: funny name, serious distro

Posts 18Views 4644
Log in to reply