• Error al actualizar JAVA


    Buenos días, tengo problemas al actualizar java a la nueva versión, esto es lo que tira la consola

    :: Iniciando actualización completa del sistema...  
    :: ¿Reemplazar java-common con extra/java-runtime-common? [S/n] s  
    resolviendo dependencias...  
    verificando conflictos...  
      
    Paquetes (9):  
      
    Nombre Versión antigua Versión nueva Cambio Neto  
      
    extra/boost-libs 1.56.0-1 1.56.0-2 0.00 MiB  
    java-common 1-8 -0.01 MiB  
    extra/java-environment-common 2-1 0.00 MiB  
    extra/java-runtime-common 2-1 0.01 MiB  
    extra/jdk7-openjdk 7.u65\_2.5.2-2 7.u65\_2.5.2-3 0.00 MiB  
    extra/jre7-openjdk 7.u65\_2.5.2-2 7.u65\_2.5.2-3 0.00 MiB  
    extra/jre7-openjdk-headless 7.u65\_2.5.2-2 7.u65\_2.5.2-3 0.00 MiB  
    multilib/lib32-pcre 8.35-1 8.36-1 0.05 MiB  
    extra/speech-dispatcher 0.8-3 0.8.1-1 0.05 MiB  
      
    Tamaño Total Instalado: 110.38 MiB  
    Tamaño neto a actualizar: 0.12 MiB  
      
    :: ¿Continuar con la instalación? [S/n] s  
    (8/8) verificando llaves en el llavero [------------------------------------] 100%  
    (8/8) verificando la integridad de los paquetes [------------------------------------] 100%  
    (8/8) cargando los archivos del paquete... [------------------------------------] 100%  
    (8/8) verificando conflictos entre archivos [------------------------------------] 100%  
    error: error al realizar la transacción (archivos en conflicto)  
    java-runtime-common: /usr/bin/java existe en el sistema de archivos  
    java-runtime-common: /usr/bin/keytool existe en el sistema de archivos  
    java-runtime-common: /usr/bin/orbd existe en el sistema de archivos  
    java-runtime-common: /usr/bin/pack200 existe en el sistema de archivos  
    java-runtime-common: /usr/bin/policytool existe en el sistema de archivos  
    java-runtime-common: /usr/bin/rmid existe en el sistema de archivos  
    java-runtime-common: /usr/bin/rmiregistry existe en el sistema de archivos  
    java-runtime-common: /usr/bin/servertool existe en el sistema de archivos  
    java-runtime-common: /usr/bin/tnameserv existe en el sistema de archivos  
    java-runtime-common: /usr/bin/unpack200 existe en el sistema de archivos  
    java-runtime-common: /usr/lib/jvm/default existe en el sistema de archivos  
    java-runtime-common: /usr/lib/jvm/default-runtime existe en el sistema de archivos  
    java-environment-common: /usr/bin/appletviewer existe en el sistema de archivos  
    java-environment-common: /usr/bin/extcheck existe en el sistema de archivos  
    java-environment-common: /usr/bin/idlj existe en el sistema de archivos  
    java-environment-common: /usr/bin/jar existe en el sistema de archivos  
    java-environment-common: /usr/bin/jarsigner existe en el sistema de archivos  
    java-environment-common: /usr/bin/javac existe en el sistema de archivos  
    java-environment-common: /usr/bin/javadoc existe en el sistema de archivos  
    java-environment-common: /usr/bin/javah existe en el sistema de archivos  
    java-environment-common: /usr/bin/javap existe en el sistema de archivos  
    java-environment-common: /usr/bin/jcmd existe en el sistema de archivos  
    java-environment-common: /usr/bin/jconsole existe en el sistema de archivos  
    java-environment-common: /usr/bin/jdb existe en el sistema de archivos  
    java-environment-common: /usr/bin/jhat existe en el sistema de archivos  
    java-environment-common: /usr/bin/jinfo existe en el sistema de archivos  
    java-environment-common: /usr/bin/jmap existe en el sistema de archivos  
    java-environment-common: /usr/bin/jps existe en el sistema de archivos  
    java-environment-common: /usr/bin/jrunscript existe en el sistema de archivos  
    java-environment-common: /usr/bin/jsadebugd existe en el sistema de archivos  
    java-environment-common: /usr/bin/jstack existe en el sistema de archivos  
    java-environment-common: /usr/bin/jstat existe en el sistema de archivos  
    java-environment-common: /usr/bin/jstatd existe en el sistema de archivos  
    java-environment-common: /usr/bin/native2ascii existe en el sistema de archivos  
    java-environment-common: /usr/bin/rmic existe en el sistema de archivos  
    java-environment-common: /usr/bin/schemagen existe en el sistema de archivos  
    java-environment-common: /usr/bin/serialver existe en el sistema de archivos  
    java-environment-common: /usr/bin/wsgen existe en el sistema de archivos  
    java-environment-common: /usr/bin/wsimport existe en el sistema de archivos  
    java-environment-common: /usr/bin/xjc existe en el sistema de archivos  
    Ocurrieron errores, no se actualizaron paquetes
    

    Por su ayuda, muchas gracias

  • Buenos días, tengo problemas al actualizar java a la nueva versión, esto es lo que tira la consola

    :: Iniciando actualización completa del sistema...  
    :: ¿Reemplazar java-common con extra/java-runtime-common? [S/n] s  
    resolviendo dependencias...  
    verificando conflictos...  
      
    Paquetes (9):  
      
    Nombre Versión antigua Versión nueva Cambio Neto  
      
    extra/boost-libs 1.56.0-1 1.56.0-2 0.00 MiB  
    java-common 1-8 -0.01 MiB  
    extra/java-environment-common 2-1 0.00 MiB  
    extra/java-runtime-common 2-1 0.01 MiB  
    extra/jdk7-openjdk 7.u65\_2.5.2-2 7.u65\_2.5.2-3 0.00 MiB  
    extra/jre7-openjdk 7.u65\_2.5.2-2 7.u65\_2.5.2-3 0.00 MiB  
    extra/jre7-openjdk-headless 7.u65\_2.5.2-2 7.u65\_2.5.2-3 0.00 MiB  
    multilib/lib32-pcre 8.35-1 8.36-1 0.05 MiB  
    extra/speech-dispatcher 0.8-3 0.8.1-1 0.05 MiB  
      
    Tamaño Total Instalado: 110.38 MiB  
    Tamaño neto a actualizar: 0.12 MiB  
      
    :: ¿Continuar con la instalación? [S/n] s  
    (8/8) verificando llaves en el llavero [------------------------------------] 100%  
    (8/8) verificando la integridad de los paquetes [------------------------------------] 100%  
    (8/8) cargando los archivos del paquete... [------------------------------------] 100%  
    (8/8) verificando conflictos entre archivos [------------------------------------] 100%  
    error: error al realizar la transacción (archivos en conflicto)  
    java-runtime-common: /usr/bin/java existe en el sistema de archivos  
    java-runtime-common: /usr/bin/keytool existe en el sistema de archivos  
    java-runtime-common: /usr/bin/orbd existe en el sistema de archivos  
    java-runtime-common: /usr/bin/pack200 existe en el sistema de archivos  
    java-runtime-common: /usr/bin/policytool existe en el sistema de archivos  
    java-runtime-common: /usr/bin/rmid existe en el sistema de archivos  
    java-runtime-common: /usr/bin/rmiregistry existe en el sistema de archivos  
    java-runtime-common: /usr/bin/servertool existe en el sistema de archivos  
    java-runtime-common: /usr/bin/tnameserv existe en el sistema de archivos  
    java-runtime-common: /usr/bin/unpack200 existe en el sistema de archivos  
    java-runtime-common: /usr/lib/jvm/default existe en el sistema de archivos  
    java-runtime-common: /usr/lib/jvm/default-runtime existe en el sistema de archivos  
    java-environment-common: /usr/bin/appletviewer existe en el sistema de archivos  
    java-environment-common: /usr/bin/extcheck existe en el sistema de archivos  
    java-environment-common: /usr/bin/idlj existe en el sistema de archivos  
    java-environment-common: /usr/bin/jar existe en el sistema de archivos  
    java-environment-common: /usr/bin/jarsigner existe en el sistema de archivos  
    java-environment-common: /usr/bin/javac existe en el sistema de archivos  
    java-environment-common: /usr/bin/javadoc existe en el sistema de archivos  
    java-environment-common: /usr/bin/javah existe en el sistema de archivos  
    java-environment-common: /usr/bin/javap existe en el sistema de archivos  
    java-environment-common: /usr/bin/jcmd existe en el sistema de archivos  
    java-environment-common: /usr/bin/jconsole existe en el sistema de archivos  
    java-environment-common: /usr/bin/jdb existe en el sistema de archivos  
    java-environment-common: /usr/bin/jhat existe en el sistema de archivos  
    java-environment-common: /usr/bin/jinfo existe en el sistema de archivos  
    java-environment-common: /usr/bin/jmap existe en el sistema de archivos  
    java-environment-common: /usr/bin/jps existe en el sistema de archivos  
    java-environment-common: /usr/bin/jrunscript existe en el sistema de archivos  
    java-environment-common: /usr/bin/jsadebugd existe en el sistema de archivos  
    java-environment-common: /usr/bin/jstack existe en el sistema de archivos  
    java-environment-common: /usr/bin/jstat existe en el sistema de archivos  
    java-environment-common: /usr/bin/jstatd existe en el sistema de archivos  
    java-environment-common: /usr/bin/native2ascii existe en el sistema de archivos  
    java-environment-common: /usr/bin/rmic existe en el sistema de archivos  
    java-environment-common: /usr/bin/schemagen existe en el sistema de archivos  
    java-environment-common: /usr/bin/serialver existe en el sistema de archivos  
    java-environment-common: /usr/bin/wsgen existe en el sistema de archivos  
    java-environment-common: /usr/bin/wsimport existe en el sistema de archivos  
    java-environment-common: /usr/bin/xjc existe en el sistema de archivos  
    Ocurrieron errores, no se actualizaron paquetes
    

    Por su ayuda, muchas gracias

  • Yo tuve el mismo problema ayer, y lo solucioné borrando esos archivos que la consola marca como ya existentes (todos son accesos directos). Después de hacer eso, actualicé de nuevo y el proceso se completó con éxito.

    Espero te sirva. Saludos.

  • Muchas gracias Ariel por tu consejo, ya pude actualizar el sistema.!!!
    Saludos

  • \# archlinux-java unset  
    \# pacman -Sydd --asdeps java-runtime-common  
    :: java-runtime-common and java-common are in conflict. Remove java-common? [y/N] y  
    \# archlinux-java fix  
    \# pacman -Syu
    
Posts 5Views 1312
Log in to reply