• Unusual VLC Behaviour


    Here’s an odd one: I’m running GNOME 3 Antergos, and when I try to play an .flv or .mp4 file from within nautilus – via right click, ‘open with VLC’ – VLC crashes (occasionally bumping my CPU usage up to a permanent 100 percent.) However, when I open VLC either using the icon, or through a terminal ($ vlc), navigate to the same file manually, and then open it manually, it plays just fine.

    Any idea what’s going on here? I’m using 2.1.5 Rincewind.

    Many thanks.

    Lenovo H50-50 Sharkbay, Intel® Core i7 4790 Haswell CPU @ 3.60 GH, 2047MB NVIDIA GeForce GT 720, 8.00GB Single-Channel DDR3 @ 798MHz, Windows 10 Pro 64-bit, Antergos 64-bit, 2GB WDC (SATA), 3GB TOSHIBA (SATA).

  • Here’s an odd one: I’m running GNOME 3 Antergos, and when I try to play an .flv or .mp4 file from within nautilus – via right click, ‘open with VLC’ – VLC crashes (occasionally bumping my CPU usage up to a permanent 100 percent.) However, when I open VLC either using the icon, or through a terminal ($ vlc), navigate to the same file manually, and then open it manually, it plays just fine.

    Any idea what’s going on here? I’m using 2.1.5 Rincewind.

    Many thanks.

    Lenovo H50-50 Sharkbay, Intel® Core i7 4790 Haswell CPU @ 3.60 GH, 2047MB NVIDIA GeForce GT 720, 8.00GB Single-Channel DDR3 @ 798MHz, Windows 10 Pro 64-bit, Antergos 64-bit, 2GB WDC (SATA), 3GB TOSHIBA (SATA).

  • Haha WOW!

    In such cases(if possible) I find and use some alternative to the software.
    You can use SMplayer, it’s a fantastic media player with support for more file types than vlc.(I could only find one tho)

    Archlinux x64

    AMD A4-3305M Processor
    6GB RAM
    1GB+512MB Hybrid AMD GPU

  • Thanks for the SMPlayer recommendation. I’m wondering whether the above problem is an idiosyncratic Gnome 3.12 problem rather than a VLC problem. SMPlayer will do for now, however. It seems to have what I need. Thanks again.

    Lenovo H50-50 Sharkbay, Intel® Core i7 4790 Haswell CPU @ 3.60 GH, 2047MB NVIDIA GeForce GT 720, 8.00GB Single-Channel DDR3 @ 798MHz, Windows 10 Pro 64-bit, Antergos 64-bit, 2GB WDC (SATA), 3GB TOSHIBA (SATA).

  • You’re welcome.

    @“melchizedek”:376o2tyl said:

    when I open VLC either using the icon, or through a terminal ($ vlc), navigate to the file manually, and then open it manually, it plays just fine.[/quote:376o2tyl]

    Must be Gnome’s problem. Do the videos run fine when loaded from Nautilus/files in totem/videos?

    Archlinux x64

    AMD A4-3305M Processor
    6GB RAM
    1GB+512MB Hybrid AMD GPU

  • @“Yash”:o1iwfag9 said:

    Must be Gnome’s problem. Do the videos run fine when loaded from Nautilus/files in totem/videos?[/quote:o1iwfag9]

    Yeah. the same files that crash VLC from nautilus run fine on SMPlayer. Totem won’t play anything currently, but that’s likely because of the file types rather than a problem with Totem.

    For some reason VLC just won’t run .flv and .mp4 files from a file browser. Same issue if I drop into GNOME classic or MATE. Everything works fine in XFCE, however. Not sure what the connection is. I can’t imagine GNOME 3 having much in common with MATE these days.

    Lenovo H50-50 Sharkbay, Intel® Core i7 4790 Haswell CPU @ 3.60 GH, 2047MB NVIDIA GeForce GT 720, 8.00GB Single-Channel DDR3 @ 798MHz, Windows 10 Pro 64-bit, Antergos 64-bit, 2GB WDC (SATA), 3GB TOSHIBA (SATA).

Posts 6Views 1344
Log in to reply