• Antergos + KDE, no audio


    I just installed Antergos and KDE from the latest ISO on a Toshiba Portege Z30A. Unfortunately audio doesn’t seem to work, but it worked fine in the Gnome-based live installer.

    The audio icon in the tray area has a red circle around it and the tooltip says “Volume at 0% - HDA Intel HDMI - IEC958”. I tried changing the volume level but to no avail. In “Audio Setup” I can see “hda intel pch alc283 analog” as default along with 4 o 5 “cards” flagged as intel HDMI (selecting any of them and clicking the Test button reports failure).

    I noticed pulseaudio is not installed but I guess it’s ok… A few things other I’ve tried:

    speaker-test reports “unable to open slave. playback open error -2, no such file or directory” (however this also happens in the live installer, where audio works.)

    aplay -l shows:

    card 0: hdmi 0
    card 0: hdmi 1
    card 0: hdmi 2
    card 1: pcm(alc283 analog) hdmi 2

    so I created /etc/modprobe.d/alsa-base.conf and tried to force alsa with: options snd_hda_intel index=1
    but it didn’t work.

    I’m not quite sure where to look for possible hints as to my problem, so I’d appreciate any assistance.

  • I just installed Antergos and KDE from the latest ISO on a Toshiba Portege Z30A. Unfortunately audio doesn’t seem to work, but it worked fine in the Gnome-based live installer.

    The audio icon in the tray area has a red circle around it and the tooltip says “Volume at 0% - HDA Intel HDMI - IEC958”. I tried changing the volume level but to no avail. In “Audio Setup” I can see “hda intel pch alc283 analog” as default along with 4 o 5 “cards” flagged as intel HDMI (selecting any of them and clicking the Test button reports failure).

    I noticed pulseaudio is not installed but I guess it’s ok… A few things other I’ve tried:

    speaker-test reports “unable to open slave. playback open error -2, no such file or directory” (however this also happens in the live installer, where audio works.)

    aplay -l shows:

    card 0: hdmi 0
    card 0: hdmi 1
    card 0: hdmi 2
    card 1: pcm(alc283 analog) hdmi 2

    so I created /etc/modprobe.d/alsa-base.conf and tried to force alsa with: options snd_hda_intel index=1
    but it didn’t work.

    I’m not quite sure where to look for possible hints as to my problem, so I’d appreciate any assistance.

  • HI,

    Are you sure pulse audio was not installed? It should have been installed. Double check and let me know. Thanks.

    Oh, you might try checking alsamixer to be sure none of your outputs are muted (MM).

    Best Regards,

  • No, pulseaudio is not installed. I even formatted and reinstalled everything.

    After reading your reply I installed pulseaudio and rebooted: now audio works, although the volume icon appears after a delay of several seconds (it’s an ultrabook, it loads almost instantly).

    I can’t help but worry if something else is missing now…

  • After booting check your journal log for any issues related to the volume icon’s delayed appearance. Start at the end and read it back up from there:[command]sudo journalctl -b 0

  • The only thing of interest are 2 lines saying “pulseaudio: daemon already running”.

Posts 6Views 1715
Log in to reply