• Blank screen (screen saver gnome)


    Hi,

    I love Antergos 🙂
    Long time I searched for a solution for a strange problem:
    my screen never went black even that I defined in the power settings to “blank screen” after 5 minutes.

    eventually the solution was to install gnome-screensaver and enable it on startup by running:

    $ sudo cp -p /usr/share/applications/gnome-screensaver.desktop /etc/xdg/autostart/
    

    (and ofcourse to start the gnome-screensaver process)
    This was suggested to me in the arch forums: [https://bbs.archlinux.org/viewtopic.php?pid=1464222#p1464222][0]">[https://bbs.archlinux.org/viewtopic.php][1] … 2#p1464222

    I would like to see this change in Antergos since I’m sure that more people with Gnome are suffering from the same issue.
    I would have done the change by myself, but I did not find how can I suggest (maybe via git) solutions…

    Thanks for the help guys, you are awesome 😄

    [0]: <a href=
    [1]: https://bbs.archlinux.org/viewtopic.php

  • Hi,

    I love Antergos 🙂
    Long time I searched for a solution for a strange problem:
    my screen never went black even that I defined in the power settings to “blank screen” after 5 minutes.

    eventually the solution was to install gnome-screensaver and enable it on startup by running:

    $ sudo cp -p /usr/share/applications/gnome-screensaver.desktop /etc/xdg/autostart/
    

    (and ofcourse to start the gnome-screensaver process)
    This was suggested to me in the arch forums: [https://bbs.archlinux.org/viewtopic.php?pid=1464222#p1464222][0]">[https://bbs.archlinux.org/viewtopic.php][1] … 2#p1464222

    I would like to see this change in Antergos since I’m sure that more people with Gnome are suffering from the same issue.
    I would have done the change by myself, but I did not find how can I suggest (maybe via git) solutions…

    Thanks for the help guys, you are awesome 😄

    [0]: <a href=
    [1]: https://bbs.archlinux.org/viewtopic.php

  • After reading this…

    " I’m running GNOME, and everything’s broken! What’s wrong?
    Probably you are not running xscreensaver at all, but but are running “gnome-screensaver” instead. You should stop.
    XScreenSaver is secure, stable, and mature; whereas gnome-screensaver is bug-ridden, unreliable, and an ongoing security disaster (for all the reasons outlined in the On Toolkits page).
    Gnome-screensaver was created in 2005 by people who thought it was a better idea to rewrite all of xscreensaver from scratch instead of sending me patches for the changes they desired in xscreensaver itself.
    Then in 2013, Ubuntu Unity re-wrote the screen saver engine from scratch again, introducing numerous security holes that would be hilarious if they weren’t so sad.
    The only sensible (and secure) way to use a screen saver under GNOME is to turn off gnome-screensaver, and use xscreensaver instead. How you go about this is explained in the “Using GNOME” section of the xscreensaver manual".
    [http://www.jwz.org/xscreensaver/faq.html#gnome-screensaver][0]">[http://www.jwz.org/xscreensaver/faq.htm][1] … creensaver

    I prefered to install xscreensaver, just to be sure I will not run into any trouble…
    [http://www.jwz.org/xscreensaver/][0]">[http://www.jwz.org/xscreensaver/][2]

    You can also take a look here…
    [https://wiki.archlinux.org/index.php/XScreenSaver][0]">[https://wiki.archlinux.org/index.php/XScreenSaver][3]

    [0]: <a href=
    [1]: http://www.jwz.org/xscreensaver/faq.htm
    [2]: http://www.jwz.org/xscreensaver/
    [3]: https://wiki.archlinux.org/index.php/XScreenSaver

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 18.04 64bit Gnome
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • Hi,

    Just an FYI, gnome-screensaver is no longer being maintained which is why we removed it from Antergos. The default GNOME install uses xscreensaver by default.

    Best Regards,

  • @“lots.0.logs”:3jm5kozo said:

    Just an FYI, gnome-screensaver is no longer being maintained which is why we removed it from Antergos. The default GNOME install uses xscreensaver by default. [/quote:3jm5kozo]
    It does NOT work in the default Gnome instal. I had to instal xscreensaver myself…

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 18.04 64bit Gnome
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • How long ago was that? It’s been included doe a few months now. I’ll check on it in case there is a problem.

  • @“lots.0.logs”:1lud17cn said:

    How long ago was that? It’s been included doe a few months now. I’ll check on it in case there is a problem.[/quote:1lud17cn]
    Ever since i installed Antergos, almost 4 months ago. That is, 10th of June.
    After your reply, I tried activating the option again, but still the screen insists on been active…

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 18.04 64bit Gnome
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • I have issue with not working blanking too.

Posts 8Views 2768
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.