• {SOLVED} hello . i got key/keyring errors


    error: key "Antergos Build Server (Automated Package Build System) " could not be imported
    error: required key missing from keyring

  • error: key "Antergos Build Server (Automated Package Build System) " could not be imported
    error: required key missing from keyring

  • I spoke with [b:uei6l2um]mim86[/b:uei6l2um] about this separately and another error he was receiving was:

    File /var/cache/pacman/pkg/numix-icon-theme-square-1:0.r67.f809e2c-1-any.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
    

    I updated the same numix-icon-theme-square package that tried to and it worked just fine for me so I am not sure what the problem was.


    Another user, named [b:uei6l2um]Siva[/b:uei6l2um], with the same issue but running the following command

    sudo pacman -Sy antergos-keyring
    

    and then updating the icon theme via

    sudo pacman -Syu
    

    and it has worked for him…so now helping out mim86 to see if the same thing solved it for them.

    Personal: http://michaeltunnell.com
    Business: http://visuex.com

  • it worked thanks !

  • Ok so the issue is still unknown but the solution was to set SigLevel to “SigLevel = Never”

    reinstall antergos-keyring.2014-09-15 package

    reset SigLevel back to “SigLevel = PackageRequired”

    reinstall the numix icon pack via pacman. Once all that was done the error was solved.


    So I am not sure why the error occurred or why this solved it but it did so that’s good. :)

    Personal: http://michaeltunnell.com
    Business: http://visuex.com

  • We released an update the the keyring package a few weeks ago that includes additional signing keys for our new automated build server. The keyring package must be updated prior to attempting to install any packages that are signed by the new keys. We though a few weeks was enough time for everyone to have the updated keys. We may have been wrong about that (oops)

    Best Regards,

  • thx for the reply Dustin

  • I got the same error again today but for different packages . I ran the following command sudo pacman-key --init; sudo pacman-key --populate archlinux antergos; sudo pacman-key --refresh-keys
    It work but i got the following message. warning: directory permissions differ on /var/db/sudo/
    filesystem: 700 package: 711
    i don’t know why i got that warning.

  • Another user in the IRC, named [b:1euk7li4]arpan[/b:1euk7li4], had the same issue but we were able to fix it with the same commands that the previous user, Siva used.

    Slexy paste of their output before running the commands to fix it…in case this is useful. [http://slexy.org/view/s20HLj0m0z][0]">[http://slexy.org/view/s20HLj0m0z][1]

    sudo pacman -Sy antergos-keyring
    

    and then updating via

    sudo pacman -Syu
    

    [b:1euk7li4]Update: 2014-10-09 3:18pm CST[/b:1euk7li4]
    Another user in the IRC named, [b:1euk7li4]djschnei[/b:1euk7li4], was experiencing this issue and this solution fixed for them as well…so this seems to be the solution to the problem.

    [b:1euk7li4]Update: 2014-10-10 4:44pm CST[/b:1euk7li4] - gooberfoob confirmed fix
    [b:1euk7li4]Update: 2014-10-16 10:30pm CST[/b:1euk7li4] - zuse5121 confirmed fix
    [b:1euk7li4]Update: 2014-10-17 2:31am CST[/b:1euk7li4] - cc_INC confirmed fix

    [0]: <a href=
    [1]: http://slexy.org/view/s20HLj0m0z

    Personal: http://michaeltunnell.com
    Business: http://visuex.com

  • In some cases it may be necessary to reinitialize the keyring like this:[command:2mlyryxf]sudo pacman-key --init
    sudo pacman-key --populate archlinux antergos[/command:2mlyryxf]
    That’s after you’ve updated the antergos-keyring package of course.

    Cheers!

  • thanks all. i think it worked

Posts 11Views 3817
Log in to reply