• Kernel 3.16.4 x86\_64


    Kernel 3.16.4 seems to cause problems with nvidia gt210 and the nvidia 340xx driver.
    I had to revert to the nvidia 304xx driver to get my system back… Just an FYI…

  • Kernel 3.16.4 seems to cause problems with nvidia gt210 and the nvidia 340xx driver.
    I had to revert to the nvidia 304xx driver to get my system back… Just an FYI…

  • I confirm this, I did some search on Arch forum and the solution is to revert to kernel 3.16.3. Or wait for an update of the kernel but it can take time.

    I’d like to do that but I don’t know how if someone could help me Ido this ?

    Long Live Antergos
    [Major Linux Problems on the Desktop or Why Linux is not (yet) Ready for the Desktop, 2016 edition] (http://linuxfonts.narod.ru/why.linux.is.not.ready.for.the.desktop.current.html)

  • Thanks for sharing!

    @nekosan:
    The easiest way to download a package is to install downgrader from AUR.
    Remember to, at least, downgrade linux and linux-headers packages!
    More info: [url:68gunzlp]https://wiki.archlinux.org/index.php/downgrading_packages[/url:68gunzlp]

  • Thanks karasu.

    After that will I be abble to install a futur update of the kernel ?

    I read the wiki but I’m affraid to make some mistake and I don’t want to kill my actual install and an update can take days to come out.

    EdIt : I tested downgrader on my VM and have a segfault :/

    [[email protected] ~]$ downgrader  
      
    Downgrader, version 1.8.0-1 (libalpm.so.8)  
    usage: downgrader [ -h ] [-q] [ -l <package name\> ] <PACKAGE\_NAME\>  
    options:  
    -h <print this help and exit\>  
    -q <quiet working, without any notifications\>   
    -l N <gave a list of available packages versions for downgrade package N\>  
    [[email protected] ~]$ downgrader -l linux  
    Downgrade package: linux   
    Erreur de segmentation (core dumped)  
    
    

    Long Live Antergos
    [Major Linux Problems on the Desktop or Why Linux is not (yet) Ready for the Desktop, 2016 edition] (http://linuxfonts.narod.ru/why.linux.is.not.ready.for.the.desktop.current.html)

  • Hi,

    I really don’t know why is segfaulting, maybe it’s because you’re trying to downgrade a kernel while you’re using it.

    You can try the hard way ™ :

    1. Boot from the Antergos liveCD (if you’re using a VM, just put the ISO).
    2. Open a terminal and change to user root with sudo su
    3. Mount your root partition (and the boot one if you have a separated one)
    4. Mount dev, sys, and proc systems
    5. chroot into the mounted root partition
    6. Go to /var/cache/pacman/pkg
    7.

    pacman -U linux-VERSION\_YOU\_WANT\_TO\_INSTALL.xz linux-headers-VERSION\_YOU\_WANT\_TO\_INSTALL.xz
    

    If you need help with any step, just tell me.

    Cheers!

  • same here (as already pointed out in g+ by John Lee).
    Instead of downgrading the kernel, I downgraded the driver to 304 and it’s working fine.
    Lovely cascading events with nvidia cards. first nvidia drops support for G8x, G9x and GT2xx GPU in the current driver (343 at the moment) and a few days later the kernel doesn’t support the 340 driver.

  • An other way to use old package : [https://wiki.archlinux.org/index.php/Arch_Rollback_Machine][0]">[https://wiki.archlinux.org/index.php/Ar][1] … ck_Machine

    [0]: <a href=
    [1]: https://wiki.archlinux.org/index.php/Ar

    Long Live Antergos
    [Major Linux Problems on the Desktop or Why Linux is not (yet) Ready for the Desktop, 2016 edition] (http://linuxfonts.narod.ru/why.linux.is.not.ready.for.the.desktop.current.html)

  • Sorry for the double post :

    An update for the nvidia-340xx have been done it seem to work now.

    Long Live Antergos
    [Major Linux Problems on the Desktop or Why Linux is not (yet) Ready for the Desktop, 2016 edition] (http://linuxfonts.narod.ru/why.linux.is.not.ready.for.the.desktop.current.html)

  • i’ll jus do an -Rdd to 304 an d test if the 340 works…

    [edit]
    no kernel update…
    no 340 update…

    304 update…

  • When I did a pacman -Syu I got an update for nvidia-340xx from version 340.46-2 to 340.46-3. Then X started where it doans’t before.

    Long Live Antergos
    [Major Linux Problems on the Desktop or Why Linux is not (yet) Ready for the Desktop, 2016 edition] (http://linuxfonts.narod.ru/why.linux.is.not.ready.for.the.desktop.current.html)

Posts 11Views 1415
Log in to reply