• \[Lightdm\] Customize Antergos theme


    Hello,

    I was trying to custom the Antergos Lightdm theme but I all fucked it up.

    I was trying to have my own backgrounds on random but something went wrong I don’t know what all I could get was a black BG. So I tried to reinstall it from this : [https://github.com/Antergos/lightdm-webkit-theme-antergos][0]">[https://github.com/Antergos/lightdm-web][1] … e-antergos I got some errors but I set the good chmod and chown so now it work

    So how could I customize the theme to have my own BG randomize ?

    Thank.

    [0]: <a href=
    [1]: https://github.com/Antergos/lightdm-web

    Long Live Antergos
    [Major Linux Problems on the Desktop or Why Linux is not (yet) Ready for the Desktop, 2016 edition] (http://linuxfonts.narod.ru/why.linux.is.not.ready.for.the.desktop.current.html)

  • Hello,

    I was trying to custom the Antergos Lightdm theme but I all fucked it up.

    I was trying to have my own backgrounds on random but something went wrong I don’t know what all I could get was a black BG. So I tried to reinstall it from this : [https://github.com/Antergos/lightdm-webkit-theme-antergos][0]">[https://github.com/Antergos/lightdm-web][1] … e-antergos I got some errors but I set the good chmod and chown so now it work

    So how could I customize the theme to have my own BG randomize ?

    Thank.

    [0]: <a href=
    [1]: https://github.com/Antergos/lightdm-web

    Long Live Antergos
    [Major Linux Problems on the Desktop or Why Linux is not (yet) Ready for the Desktop, 2016 edition] (http://linuxfonts.narod.ru/why.linux.is.not.ready.for.the.desktop.current.html)

  • Bump.

    I’d also like to change the clock from 12h to 24h system is that possible ?

    Long Live Antergos
    [Major Linux Problems on the Desktop or Why Linux is not (yet) Ready for the Desktop, 2016 edition] (http://linuxfonts.narod.ru/why.linux.is.not.ready.for.the.desktop.current.html)

  • lots.0.logs we need you!

  • Hi,

    I’m afraid what’s required to use your own images is too much to outline here. I’ll add the feature request to our github and try to implement it soon. Regarding the 24 hour clock, open the greeter.js file and find the function that has a list of locales. It’s easy to spot (locales are written in the standard format. eg: en_US). Remove your current system local from the list of locales. Save the changes and you’ll get the 24hr clock going forward (until the next update)

    Best Regards,
    Dustin

  • Hi thank you a lot.

    But my local isn’t in the list. I use fr_FR, I just see LightDM language is set to English (maybe en_US) so I think it is LightDM itself that is not set to the good local.

    I’ll look to change LightDM local. Thanks anyway.

    And again thanks to the foture add of a little bit of customization in the antergos theme.

    Edit :

    After some tests it seem that one og LDM or LDM webkit is not translated in french I found nothing mor at the moment.

    Long Live Antergos
    [Major Linux Problems on the Desktop or Why Linux is not (yet) Ready for the Desktop, 2016 edition] (http://linuxfonts.narod.ru/why.linux.is.not.ready.for.the.desktop.current.html)

  • That should not have any effect in this case. The theme accesses your locale settings from webkitgtk (the engine that powers Gnome’s Epiphany Web Browser as well as the Midori Browser). If you cant figure out how to change the setting, I’d recommend simply removing en_US from the list of locales in the theme file

    Cheers!

  • Also, to get rid of the AM/PM stuff that has no relevance on a 24h clock, edit greeter.js, and changed: time.innerHTML = hh + “:” + mm + " " + suffix;
    to: time.innerHTML = hh + “:” + mm;

Posts 8Views 2505
Log in to reply