• ATTN: Additional action required to install Antergos


    Until the ISO can be updated, follow these steps to install Antergos.

    1. Exit the installer when it initially appears.

    2. Press [b:ffqb5yxp]Alt+F2[/b:ffqb5yxp], input “[b:ffqb5yxp]cnchi-dev[/b:ffqb5yxp]”, and then press [b:ffqb5yxp]Enter[/b:ffqb5yxp].

    3. Wait 2-5 minutes while the installer is updated. (Could take longer on slower connections)

    4. The installer will restart automatically, follow the prompts to install.

    Best Regards,

  • Until the ISO can be updated, follow these steps to install Antergos.

    1. Exit the installer when it initially appears.

    2. Press [b:ffqb5yxp]Alt+F2[/b:ffqb5yxp], input “[b:ffqb5yxp]cnchi-dev[/b:ffqb5yxp]”, and then press [b:ffqb5yxp]Enter[/b:ffqb5yxp].

    3. Wait 2-5 minutes while the installer is updated. (Could take longer on slower connections)

    4. The installer will restart automatically, follow the prompts to install.

    Best Regards,

  • I had to install git first before testing.sh would run correctly.

  • Was this with the most recent ISO or an older one?

  • I think you should provide a link to this forum page on the download[/url:15keiadm] page untill the next release rolls out.

    Archlinux x64

    AMD A4-3305M Processor
    6GB RAM
    1GB+512MB Hybrid AMD GPU

  • Hi, there. New here. First post =J

    So i downloaded the 32-bit iso from homepage, created a live usb, booted up, tried to install Antergos, failed because of the ‘‘cnchi can’t continue’’ problem. Found workaround form this topic, but i can only get to step 3. I see the notification (gnome3) at the bottom that cnchi is updating, but after that - nothing.

    So i ran it from terminal and i get some python ImportError:

    [[email protected] ~]$ cnchi-dev   
    cp: cannot stat '/usr/share/cnchi/scripts/testing.sh': No such file or directory  
    Previous testing setup detected, skipping downloads...  
    Verifying that nothing is mounted from a previous install attempt.  
    Getting latest version of Cnchi from testing branch...  
    remote: Counting objects: 10951, done.  
    remote: Compressing objects: 100% (3364/3364), done.  
    remote: Total 10951 (delta 7574), reused 10908 (delta 7545)  
    Receiving objects: 100% (10951/10951), 15.64 MiB | 1.46 MiB/s, done.  
    Resolving deltas: 100% (7574/7574), done.  
    From https://github.com/Antergos/Cnchi  
    \* branch master -\> FETCH\_HEAD  
    \* [new branch] master -\> origin/master  
    Starting Cnchi...  
    [[email protected] ~]$ Using GTK v3.12.2  
    [2014-11-22 01:03:17] [cnchi.py] ERROR: No module named 'requests'  
    Traceback (most recent call last):  
    File "/usr/share/cnchi/cnchi.py", line 60, in do\_activate  
    import mainwindow  
    File "/usr/share/cnchi/src/mainwindow.py", line 36, in <module\>  
    import check  
    File "/usr/share/cnchi/src/check.py", line 34, in <module\>  
    from rank\_mirrors import AutoRankmirrorsThread  
    File "/usr/share/cnchi/src/rank\_mirrors.py", line 34, in <module\>  
    import requests  
    ImportError: No module named 'requests'  
    [2014-11-22 01:03:17] [cnchi.py] ERROR: Can't create Cnchi's main window. Exiting...  
      
    [[email protected] ~]$  
    
    

    Any suggestions?

  • Hi,

    Before running cnchi-dev command, run this:[command:hiiwh583]sudo pacman -S python-requests[/command:hiiwh583]Let me know if that works!

  • For some reason I cannot download this python package or even update repos, some issue with not finding a database. Here’s my log:

      
    [[email protected] ~]$ sudo pacman -S python-requests  
    warning: database file for 'core' does not exist  
    warning: database file for 'extra' does not exist  
    warning: database file for 'community' does not exist  
    warning: database file for 'antergos' does not exist  
    error: target not found: python-requests  
    
    

    After that i tried sudo pacman -Syu (–debug).
    Short:

      
    [[email protected] ~]$ sudo pacman -Syu  
    :: Synchronizing package databases...  
    core is up to date  
    extra 1723.1 KiB 421K/s 00:04 [\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#] 100%  
    community is up to date  
    antergos 297.1 KiB 871K/s 00:00 [\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#] 100%  
    :: Starting full system upgrade...  
    :: Replace ati-dri with extra/mesa-dri? [Y/n] Y  
    :: Replace intel-dri with extra/mesa-dri? [Y/n] Y  
    :: Replace mutter-wayland with extra/mutter? [Y/n] Y  
    :: Replace nouveau-dri with extra/mesa-dri? [Y/n] Y  
    :: Replace svga-dri with extra/mesa-dri? [Y/n] Y  
    error: failed to prepare transaction (could not find database)  
    
    

    Debug: [url:lieh3qd4]http://pastebin.com/a1aT2pQk[/url:lieh3qd4]

    NB! Does not matter whether i say Y or N to driver replacement.

  • @m3l:

    It seems you don’t have db files ¿?

    Please, try running sudo pacman -Syyuu

  • @karasu:

      
    [[email protected] ~]$ sudo pacman -Syyuu  
    :: Synchronizing package databases...  
    core 117.2 KiB 580K/s 00:00 [\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#] 100%  
    extra 1723.1 KiB 1292K/s 00:01 [\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#] 100%  
    community 2.4 MiB 1539K/s 00:02 [\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#] 100%  
    antergos 297.1 KiB 1248K/s 00:00 [\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#] 100%  
    :: Starting full system upgrade...  
    :: Replace ati-dri with extra/mesa-dri? [Y/n] Y  
    :: Replace intel-dri with extra/mesa-dri? [Y/n] Y  
    :: Replace mutter-wayland with extra/mutter? [Y/n] Y  
    :: Replace nouveau-dri with extra/mesa-dri? [Y/n] Y  
    :: Replace svga-dri with extra/mesa-dri? [Y/n] Y  
    error: failed to prepare transaction (could not find database)  
    [[email protected] ~]$  
    
    

    Debug: [url:3bepl1ca]http://pastebin.com/6n96Gvqj[/url:3bepl1ca]

  • Hi,

    From your log:

    debug: opened tempfile for download: /var/lib/pacman/sync/core.db.sig.part (wb)
    debug: curl returned error 22 from transfer
    debug: failed retrieving file ‘core.db.sig’ from archlinux.polymorf.fr : The requested URL returned error: 404 Not Found
    debug: “/var/lib/pacman/sync/core.db.sig” is not readable: No such file or directory
    debug: sig path /var/lib/pacman/sync/core.db.sig could not be opened
    debug: missing optional signature

    You could try to update your mirrorlist:
    [url:vsmd39dc]https://www.archlinux.org/mirrorlist/?country=all&protocol=http&ip_version=4[/url:vsmd39dc]
    save it to /etc/pacman.d/mirrorlist
    remember to uncomment at least one of the mirrors (remove # from the start)

    If it still doesn’t work, please post here your /etc/pacman.conf

  • Hi,

    Try it once more but don’t upgrade any packages. Use this command instead:[command:wxqe3ae4]sudo pacman -Syy python-requests[/command:wxqe3ae4]

  • @lots.0.logs:

      
    [[email protected] pacman.d]$ sudo pacman -Syy python-requests  
    :: Synchronizing package databases...  
    core 117.2 KiB 895K/s 00:00 [\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#] 100%  
    extra 1723.2 KiB 2.17M/s 00:01 [\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#] 100%  
    community 2.4 MiB 2.01M/s 00:01 [\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#] 100%  
    antergos 297.1 KiB 990K/s 00:00 [\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#] 100%  
    error: failed to prepare transaction (could not find database)  
    
    

    @karasu:
    Updated mirrorlist, tried different mirrors, still same error.

    Previous command with debug enabled and pacman.conf posted to pastebin.
    [url:20vc06vd]http://pastebin.com/UQcuZzzg[/url:20vc06vd]

  • Hi,

    I updated Cnchi so it doesn’t fail when it does not find the requests module. Please, reboot and start with the live iso, then use the cnchi-dev command to update Cnchi and start installing.

    Another solution would be to install python-requests BEFORE running cnchi for the very first time.

    Cheers!

  • Actually, i just realized myself that i could download python-requests and install it manually.
    So that’s what i did and it worked! Got cnchi-dev working and I’m installing Antergos right now.

    What i did:

      
    wget http://ftp.eenet.ee/pub/archlinux/community/os/i686/python-requests-2.4.3-1-any.pkg.tar.xz  
    sudo pacman -U python-requests-2.4.3-1-any.pkg.tar.xz  
    
    

    Thx to [u:288jioow]karasu[/u:288jioow] and [u:288jioow]lots.0.logs[/u:288jioow]

  • Actually, i just realized myself that i could download python-requests and install it manually.

    Now, I feel like an idiot. Glad you solved it.

  • Is this still required on the 1.11 install medium? I didn’t update it, and everything seems to be working alright, other than a dhcpcd issue I mentioned in another thread.

Posts 17Views 6521
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.