• \[SOLVED\]Antergos on a Multi-boot USB drive (Yumi)


    Hi,

    I am having trouble getting Antergos working on a multi-boot USB drive. I can get the vanilla version of arch to work on it but Antergos doesn’t seem to want to work. The multi-boot installer im using is [Yumi[/url:2j0yxmiz].

    This is the error i am getting when i try to run the live installer using the grub option in Yumi [Image1[/url:2j0yxmiz]. This is the error i get when trying to run the live installer using the SYSLINUX option in Yumi [Image2[/url:2j0yxmiz].

    EDIT: I’ve taken the “ARCH” folder out of the ISO and placed it in the root directory for the flash drive and it got past the issue with the SYSLINUX (Image2)not finding the file but now it gets stuck on the same spot as the grub installer did (Image1).[/color:2j0yxmiz] My solution below fixed the need of having the ARCH folder in the root directory of the USB drive as it corrects the path issues.
    EDIT2: I seem to have solved my Issue after some trial and error.
    My solution:
    I edited the isolinux.cfg file under \multiboot\antergos-2014.08.07-x86_64\isolinux\ and added in the highlighted code and changed the archisolabel to the label of the USB Drive. Obviously the exact string will depend on the version of Antergois that is being used but this seems to have solved the issue.
    label start
    kernel [b:2j0yxmiz]/multiboot/antergos-2014.08.07-x86_64[/b:2j0yxmiz]/arch/boot/vmlinuz
    append initrd=[b:2j0yxmiz]/multiboot/antergos-2014.08.07-x86_64[/b:2j0yxmiz]/arch/boot/archiso.img archisobasedir=[b:2j0yxmiz]/multiboot/antergos-2014.08.07-x86_64[/b:2j0yxmiz]/arch archisolabel=[b:2j0yxmiz]MULTIBOOT[/b:2j0yxmiz]]2]1]0

  • Hi,

    I am having trouble getting Antergos working on a multi-boot USB drive. I can get the vanilla version of arch to work on it but Antergos doesn’t seem to want to work. The multi-boot installer im using is [Yumi[/url:2j0yxmiz].

    This is the error i am getting when i try to run the live installer using the grub option in Yumi [Image1[/url:2j0yxmiz]. This is the error i get when trying to run the live installer using the SYSLINUX option in Yumi [Image2[/url:2j0yxmiz].

    EDIT: I’ve taken the “ARCH” folder out of the ISO and placed it in the root directory for the flash drive and it got past the issue with the SYSLINUX (Image2)not finding the file but now it gets stuck on the same spot as the grub installer did (Image1).[/color:2j0yxmiz] My solution below fixed the need of having the ARCH folder in the root directory of the USB drive as it corrects the path issues.
    EDIT2: I seem to have solved my Issue after some trial and error.
    My solution:
    I edited the isolinux.cfg file under \multiboot\antergos-2014.08.07-x86_64\isolinux\ and added in the highlighted code and changed the archisolabel to the label of the USB Drive. Obviously the exact string will depend on the version of Antergois that is being used but this seems to have solved the issue.
    label start
    kernel [b:2j0yxmiz]/multiboot/antergos-2014.08.07-x86_64[/b:2j0yxmiz]/arch/boot/vmlinuz
    append initrd=[b:2j0yxmiz]/multiboot/antergos-2014.08.07-x86_64[/b:2j0yxmiz]/arch/boot/archiso.img archisobasedir=[b:2j0yxmiz]/multiboot/antergos-2014.08.07-x86_64[/b:2j0yxmiz]/arch archisolabel=[b:2j0yxmiz]MULTIBOOT[/b:2j0yxmiz]]2]1]0

  • Hi, I have this same problem and have found your post through google.

    Thank you for leaving the solution here, but I was unable to understand how should i edit the file(maybe because my poor english and the highlighting marks not working).

    This is my current isolinux.cfg

    default start
    implicit 1
    display isolinux.msg

    ui gfxboot bootlogo isolinux.msg

    prompt 1
    timeout 200

    label start
    kernel /arch/boot/vmlinuz
    append initrd=/arch/boot/intel_ucode.img,/arch/boot/archiso.img archisobasedir=arch archisolabel=ANTERGOS earlymodules=loop modules-load=loop rd.modules-load=loop udev.log-priority=crit rd.udev.log-priority=crit quiet

    label harddisk
    com32 whichsys.c32
    append -iso- chain.c32 hd0

    label hdt
    kernel hdt.c32

    label memtest
    kernel memtest

    Could you give me some help?

    EDIT: I found out what you meant, in case someone has the same problem here is my new configuration:
    label start
    kernel /multiboot/antergos-2015.09.13-x86_64/arch/boot/vmlinuz
    append initrd=/multiboot/antergos-2015.09.13-x86_64/arch/boot/archiso.img archisobasedir=/multiboot/antergos-2015.09.13-x86_64/arch archisolabel=MULTIBOOT

Posts 3Views 3536
Log in to reply