• Spacebar=delete in lightdm - can't login


    After I updated yesterday, and just turned my laptop off, when I went to login today I kept getting a login error. Then I noticed when I hit the spacebar (which is in my password), the whole line is deleted, leaving me with a blank box.

    I was able to go to one of the other terminals (ctrl-alt-f4) and login just fine. I changed my password to one without spaces and can login. Once in gnome the space bar works as one would expect.

    I tried logging out and rebooting, but the error remains consistent.

    This is the env which is showing, which looks right:

    $ systemctl show-environment  
    LANG=en\_US.UTF-8  
    LC\_COLLATE=en\_US.UTF-8  
    PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin
    

    There also doesn’t seem to be any problems here either as far as I can tell, but I’m not expert:

    $ cat /etc/X11/xorg.conf.d/00-keyboard.conf   
    \# Read and parsed by systemd-localed. It's probably wise not to edit this file  
    \# manually too freely.  
    Section "InputClass"  
    Identifier "system-keyboard"  
    MatchIsKeyboard "on"  
    Option "XkbLayout" "us"  
    EndSection
    

    This error occurs when I am using a usb keyboard or the laptop keyboard. help?

  • After I updated yesterday, and just turned my laptop off, when I went to login today I kept getting a login error. Then I noticed when I hit the spacebar (which is in my password), the whole line is deleted, leaving me with a blank box.

    I was able to go to one of the other terminals (ctrl-alt-f4) and login just fine. I changed my password to one without spaces and can login. Once in gnome the space bar works as one would expect.

    I tried logging out and rebooting, but the error remains consistent.

    This is the env which is showing, which looks right:

    $ systemctl show-environment  
    LANG=en\_US.UTF-8  
    LC\_COLLATE=en\_US.UTF-8  
    PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin
    

    There also doesn’t seem to be any problems here either as far as I can tell, but I’m not expert:

    $ cat /etc/X11/xorg.conf.d/00-keyboard.conf   
    \# Read and parsed by systemd-localed. It's probably wise not to edit this file  
    \# manually too freely.  
    Section "InputClass"  
    Identifier "system-keyboard"  
    MatchIsKeyboard "on"  
    Option "XkbLayout" "us"  
    EndSection
    

    This error occurs when I am using a usb keyboard or the laptop keyboard. help?

  • Hi,

    This seems to be a bug in our greeter theme. Thanks for reporting it. I will take a look asap.

    Cheers!

  • Thanks!

Posts 4Views 1013
Log in to reply