• \[Solved\] gcc multilib update problem


    Hi all,

    since a few days, when I try to update my system, I get dependency errors on glibc:

      
    \> yaourt -Syu --aur  
    :: Synchronizing package databases...  
    core is up to date  
    extra 1774,4 KiB 3,86M/s 00:00 [\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#] 100%  
    community 2,3 MiB 9,49M/s 00:00 [\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#] 100%  
    multilib-testing 6,7 KiB 0,00B/s 00:00 [\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#] 100%  
    multilib is up to date  
    antergos is up to date  
    error: failed to prepare transaction (unexpected error)  
    :: Starting full system upgrade...  
    resolving dependencies...  
    warning: cannot resolve "glibc\>=2.20", a dependency of "gcc-libs-multilib"  
    warning: cannot resolve "glibc\>=2.20", a dependency of "gcc-libs-multilib"  
    warning: cannot resolve "glibc\>=2.20", a dependency of "gcc-libs-multilib"  
    warning: cannot resolve "gcc-libs-multilib=4.9.1-2", a dependency of "gcc-multilib"  
    warning: cannot resolve "glibc\>=2.20", a dependency of "gcc-libs-multilib"  
    :: The following packages cannot be upgraded due to unresolvable dependencies:  
    gcc-libs-multilib gcc-multilib  
      
    :: Do you want to skip the above packages for this upgrade? [y/N] ^C  
    Interrupt signal received  
    
    

    Looks like the mentioned multilib require 2.20 while the repos currently provide 2.19. Or is the dependency wrong? lib32-glibc is at 2.20 …

    Thanks and cheers,

    Riko

  • Hi all,

    since a few days, when I try to update my system, I get dependency errors on glibc:

      
    \> yaourt -Syu --aur  
    :: Synchronizing package databases...  
    core is up to date  
    extra 1774,4 KiB 3,86M/s 00:00 [\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#] 100%  
    community 2,3 MiB 9,49M/s 00:00 [\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#] 100%  
    multilib-testing 6,7 KiB 0,00B/s 00:00 [\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#] 100%  
    multilib is up to date  
    antergos is up to date  
    error: failed to prepare transaction (unexpected error)  
    :: Starting full system upgrade...  
    resolving dependencies...  
    warning: cannot resolve "glibc\>=2.20", a dependency of "gcc-libs-multilib"  
    warning: cannot resolve "glibc\>=2.20", a dependency of "gcc-libs-multilib"  
    warning: cannot resolve "glibc\>=2.20", a dependency of "gcc-libs-multilib"  
    warning: cannot resolve "gcc-libs-multilib=4.9.1-2", a dependency of "gcc-multilib"  
    warning: cannot resolve "glibc\>=2.20", a dependency of "gcc-libs-multilib"  
    :: The following packages cannot be upgraded due to unresolvable dependencies:  
    gcc-libs-multilib gcc-multilib  
      
    :: Do you want to skip the above packages for this upgrade? [y/N] ^C  
    Interrupt signal received  
    
    

    Looks like the mentioned multilib require 2.20 while the repos currently provide 2.19. Or is the dependency wrong? lib32-glibc is at 2.20 …

    Thanks and cheers,

    Riko

  • If you enabled multilib-testing you must also enable the regular testing repo. However, I don’t recommend using the testing repos. Packages do not stay in testing very long. It’s more like a staging repo than a testing repo.

    Cheers!

  • Thanks! Disabled multilib-testing in pacman.conf and everything goes through.

    Cheers and thanks again!

Posts 4Views 1805
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.