• Help with messed up fonts!


    So I’ve been using antergos with gnome for a couple of years now with minimal dramas. I decided to give kde a go just out of interest, so I installed sddm, plasma and kde-applications.

    Booted into plasma and messed around with some themes and then booted back into gnome and all my fonts are messed up completely, still mostly legible but not very nice on the eyes, I can’t seem to get them back to how they were before. Even changing the fonts in gnome-tweaks doesn’t seem to help. I even went into chromium settings and changed the fonts there but has made no difference at all to the fonts in chromium.

    Does anyone have any ideas how I can revert all font settings to the way they were as default? Because this sucks! Difficult to read, seems like they are not rendering properly, any help would be greatly appreciated!!!

  • Mixing two DEs in the same partition is a bad idea. Mixing Gtk-based and Qt-based DEs (Gnome and Kde) in the same partition is the worst idea. The problem you describe is only a tip of the iceberg.

    First, run fc-cache -fv in terminal. And also sudo fc-cache -fv.

    Then, if you have LCD, set fonts to:

    1. In Plasma

      • vendor default settings. If it works bad, then set:
        • anti-aliasing to enabled
        • sub-pixel rendering to RGB
        • hinting to slight
        • disable forcing font DPI
    2. In Gnome

      • hinting to slight
      • antialiasing to subpixel (or rgba, whichever is present)
      • palette (or RGBA order), if present, to RGB

    Though I’m not sure in final result of mixing together two such a different font rendering engines.

    The best solution is to install Gnome and Kde in two different, separated, independent partitions.

  • Thanks for your advice, I have already removed Kde. That’s what I get for reading random forum posts about switching from Gnome to Kde.

    Unfortunately I am still having the rendering issue, I assume it’s to do with the DPI setting, I’m going to go through the fonts & font configuration sections of the arch wiki and hopefully sort it out. I can’t seem to find any DPI settings for fonts in Gnome, do you have any suggestions on this?

    Thanks again for your time

  • afaik Antergos was setting up qt5ct per default on gtk based DE’s.
    qt5ct is not good for using inside plasma/kde (and other qt-based) so may the config for it are screwed by using kde…

  • @joekamprad said in Help with messed up fonts!:

    …Antergos was setting up qt5ct per default on gtk based DE’s.

    Yes, that’s true. Anetrgos was adding qt5ct to Gnome, Cinnamon, Xfce, Openbox, Enlightenment and Budgie DEs by default.

    qt5ct is an excellent font tool for Gtk DEs. I didn’t mention it because IIRC it works with fonts for Qt apps only. I don’t use qt5ct for a long time, so almost surely I’m wrong.

    qt5ct definitely worth a try in Gnome.

    Caution: Never use qt5ct in Plasma. Otherwise it will destroy all styles, fonts, themes, everything in Plasma’s look-and-feel.

  • Thanks for all the info!

    Didn’t manage to fix it and with antergos being d/c have just switched to manjaro. Everything running fine again. Though have got EndeavourOS running in a VM to play around with, so might end up doing another switch soon, looks pretty good so far!

fonts26 messed7 Posts 6Views 149
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.