• Antefree isn't disastrous


    Hi Antepeople ☺ ,

    In Antefree you may miss the convenience of precompiled packages, which were available from removed [antergos] repo.

    Though most of them are available from AUR, you may dislike to have AUR packages in the system.

    No worries. We can replace [antergos] with other third-party repos.

    I use [disastrousaur] for years. Despite of its name, it’s very reliable. No disasters, not a single problem with it. The repo is shortly described in Unofficial user repositories article in ArchWiki.

    There are hundreds of packages in the repo, including most of those from [antergos].

    Let’s add [disastrousaur] to Antefree. The steps are:

    1. Import maintainer’s key
    2. Verify key’s fingerprint
    3. Locally sign the key
    4. Add the repo to pacman.conf
    5. Force databases update

    In details.

    1. Import maintainer’s key

    Command

    sudo pacman-key --recv-keys CBAE582A876533FD
    

    Example

    ┌──[just]@[alexafg]:~$
    └─> dt && sudo pacman-key --recv-keys CBAE582A876533FD
    Current datetime:
    2019-07-06 15:41:15
    
    gpg: key CB8DA19D1551E92F: 1 duplicate signature removed
    gpg: key CB8DA19D1551E92F: 1 signature reordered
    gpg: key CB8DA19D1551E92F: public key "XDFR Alliance Signing (Felix Golatofski) <[email protected]>" imported
    gpg: Total number processed: 1
    gpg:               imported: 1
    ==> Updating trust database...
    gpg: next trustdb check due at 2019-10-03
    ┌──[just]@[alexafg]:~$
    └─>
    

    Proceed with verifying the key.

    2. Verify the fingerprint

    Command

    sudo pacman-key --finger CBAE582A876533FD
    

    Example

    ┌──[just]@[alexafg]:~$
    └─> dt && sudo pacman-key --finger CBAE582A876533FD
    Current datetime:
    2019-07-06 15:44:51
    
    pub   ed25519 2018-10-21 [SC]
          79A6 40BD 69FF 4388 3865  4415 CB8D A19D 1551 E92F
    uid           [ unknown] XDFR Alliance Signing (Felix Golatofski) <[email protected]>
    sub   cv25519 2018-10-21 [E]
    
    ┌──[just]@[alexafg]:~$
    └─>
    

    Next, locally sign the key as trusted.

    3. Locally sign the imported key

    Command

    sudo pacman-key --lsign-key CBAE582A876533FD
    

    Example

    ┌──[just]@[alexafg]:~$
    └─> dt && sudo pacman-key --lsign-key CBAE582A876533FD
    Current datetime:
    2019-07-06 15:49:13
    
      -> Locally signing key CBAE582A876533FD...
    ==> Updating trust database...
    gpg: marginals needed: 3  completes needed: 1  trust model: pgp
    gpg: depth: 0  valid:   1  signed:   9  trust: 0-, 0q, 0n, 0m, 0f, 1u
    gpg: depth: 1  valid:   9  signed:  83  trust: 1-, 0q, 0n, 8m, 0f, 0u
    gpg: depth: 2  valid:  75  signed:  14  trust: 75-, 0q, 0n, 0m, 0f, 0u
    gpg: next trustdb check due at 2019-10-03
    ┌──[just]@[alexafg]:~$
    └─>
    

    We now trust the key to sign packages. We can add the repo and get the list of its packages.

    4. Add the repo to pacman.conf

    Edit /etc/pacman.conf. Add the repo at the bottom of the file, below all standard Arch repos.

    #==2019.07.06
    #--just added.
    #--place the repo
    #--at the lowest
    #--priority.
    [disastrousaur]
    Server = https://mirror.repohost.de/$repo/$arch
    #==
    

    The repo uses default Arch SigLevel = Required DatabaseOptional, so setting SigLevel for this repo is not neccessary.

    Save /etc/pacman.conf

    5. Force local databases update

    Command

    sudo pacman -Syy
    

    Example

    ┌──[just]@[alexafg]:~$
    └─> dt && sudo pacman -Syy
    Current datetime:
    2019-07-06 15:52:24
    
    :: Synchronizing package databases...
     core                133.6 KiB  2.46M/s 00:00 [--------] 100%
     extra              1636.5 KiB  4.27M/s 00:00 [--------] 100%
     community             4.8 MiB  6.14M/s 00:01 [--------] 100%
     multilib            170.8 KiB  6.95M/s 00:00 [--------] 100%
     disastrousaur       186.5 KiB  1097K/s 00:00 [--------] 100%
     disastrousaur.sig   119.0   B  0.00B/s 00:00 [--------] 100%
    ┌──[just]@[alexafg]:~$
    └─>
    
    

    6. List all available packages

    Command

    sudo pacman -Sl disastrousaur
    

    Example (675 packages in total)

    ┌──[just]@[alexafg]:~$
    └─> dt && sudo pacman -Sl disastrousaur
    Current datetime:
    2019-07-06 15:54:08
    
    disastrousaur 1pass-hg r58.1390348facc7-1
    disastrousaur acroread 9.5.5-9
    disastrousaur adobe-air-sdk 2.6-10
    disastrousaur aerc 0.1.2-1
    disastrousaur aften 0.0.8-3
    disastrousaur akonadi-qt4 1.13.0-14
    disastrousaur als-controller 20160117-1
    disastrousaur als-dkms r27-1
    disastrousaur alternating-layouts-git r30.5fa7b18-1
    disastrousaur amarok 2.9.0.r367.fc370bbebf-1
    disastrousaur amidst 4.2-2
    disastrousaur android-emulator 29.0.11-1
    disastrousaur android-file-transfer-linux-git continuous.r0.g7fedd8e-1
    disastrousaur android-platform 28_r06-1
    disastrousaur android-sdk 26.1.1-1
    disastrousaur android-sdk-build-tools r28.0.3-1
    disastrousaur android-sdk-platform-tools 29.0.1-1
    disastrousaur android-studio 3.4.1.0-1
    disastrousaur android-support r23.2.1-1
    disastrousaur android-support-repository r47-1
    disastrousaur android-udev-git 20190315.r5.geeb5e90-1
    disastrousaur aosp-devel 0.3-1
    disastrousaur apachedirectorystudio 2.0.0.v20180908.14-0
    disastrousaur arch-firefox-search 0.8.2-8
    disastrousaur archlinux-artwork 1.6-6
    disastrousaur archlinux-java-run 5-1
    disastrousaur asterisk 16.4.0-1
    disastrousaur asterisk-cisco 16.3.0-1
    disastrousaur asus-kbd-backlight 1.2-1
    disastrousaur asus-n550jx-subwoofer-fix 0.1-1
    disastrousaur atheme 7.2.10_r2-1
    disastrousaur atlauncher 3.2.4.0-1
    disastrousaur attica-qt4 0.4.2-7
    disastrousaur audible-activator-git 1:0.2+r3.20181128.2e97c84-1
    disastrousaur aur-auto-vote-git 144.3ea89cc-1
    disastrousaur aur-out-of-date 2.1.0-2
    disastrousaur auracle-git r258.ab0e8d9-1
    disastrousaur aurman 2.19.1-1
    disastrousaur aurto 0.9.3-1
    disastrousaur aurutils 2.3.1-1
    disastrousaur aurutils-git 2.3.1.r52.g6da4f82-1
    disastrousaur aurvote 1.9-3
    disastrousaur aurvote-git r27.fd413f1-2
    disastrousaur automoc4 0.9.88-9
    disastrousaur batify 1.0-3
    disastrousaur batterymon-clone 1.4.2-1
    disastrousaur bcc 0.10.0-2
    disastrousaur bcc-tools 0.10.0-2
    disastrousaur belle-sip 1.6.3-1
    disastrousaur bibus 1.5.2-6
    disastrousaur bitwarden-bin 1.14.0-1
    disastrousaur bkchem 0.14.0_pre2-3
    disastrousaur bless 0.6.2-1
    disastrousaur bluej 4.2.1-2
    disastrousaur bluez-hcitool 5.45-1
    disastrousaur bluez-rfcomm 5.45-1
    disastrousaur bluez-utils-compat 5.50-3
    disastrousaur brave-bin 0.65.121-5
    disastrousaur brightnessctl 0.4-1
    disastrousaur brother-brgenml1 3.1.0_1-3
    disastrousaur bumblebee-status 1.8.0-1
    disastrousaur bumblebee-status-git r1096.ed25538-1
    disastrousaur bytecode-viewer 2.9.20-1
    disastrousaur c-icap 0.5.5-1
    disastrousaur cfengine 3.10.4-1
    disastrousaur cfr 0.145-1
    disastrousaur checkupdates-aur 0.04-1
    disastrousaur chef-dk 4.0.60-1
    disastrousaur chkboot 1.3-1
    disastrousaur chromium-dev 76.0.3809.12-1
    disastrousaur chromium-snapshot-bin 77.0.3818.0.r667265-1
    disastrousaur chromium-vaapi-bin 75.0.3770.100-1
    disastrousaur chromium-widevine 1:4.10.1440.18-2
    disastrousaur cinnamon-sound-effects 5.7-1
    disastrousaur clamav-unofficial-sigs 5.6.2-4
    disastrousaur clion 1:2019.1.4-2
    disastrousaur clion-cmake 1:2019.1.4-2
    disastrousaur clion-gdb 1:2019.1.4-2
    disastrousaur clion-jre 1:2019.1.4-2
    disastrousaur clion-lldb 1:2019.1.4-2
    disastrousaur cloudprint-cups-git 1:20160502.r16.g1f27903-1
    disastrousaur codecs64 20071007-1
    disastrousaur coin 4.0.0a+11927+me74da184f75b-1
    disastrousaur coin-docs 4.0.0a+11927+me74da184f75b-1
    disastrousaur collabora-online-server-nodocker 4.0.4-1
    disastrousaur compass-icon-theme 1.3.8-1
    disastrousaur compass-icon-theme-kde 1.3.8-1
    disastrousaur cryfs-git 0.10.2.r131.gd2e5ba7f-1
    disastrousaur cryptocat 3.2.08-1
    disastrousaur cuberite 1.12b1014-2
    disastrousaur cylon 5.6-8
    disastrousaur cyrus-imapd 3.0.10-1
    disastrousaur cyrus-imapd-docs 3.0.10-1
    disastrousaur daala-git 0.0.r1697.gd10a875-1
    disastrousaur datagrip 2019.1.3-1
    disastrousaur datagrip-jre 2019.1.3-1
    disastrousaur debtap 3.2.2-1
    disastrousaur deezer 4.7.2-1
    disastrousaur devolo-dlan-cockpit 5.0.2-1
    disastrousaur digimend-kernel-drivers-dkms-git 9.r37.gf7edb78-1
    disastrousaur discord 0.0.9-3
    disastrousaur discord-canary 0.0.85-1
    disastrousaur dockd 1.21-1
    disastrousaur dovecot-libsodium-plugin 1.0-1
    disastrousaur downgrade 6.2.1-0
    disastrousaur dropbox 75.4.141-1
    disastrousaur dxvk-bin 1.2.2-0
    disastrousaur dxvk-win32-bin 1.1.1-2
    disastrousaur dxvk-win64-bin 1.1.1-2
    disastrousaur e2guardian 5.3.2-1
    disastrousaur easyeda 2.0.0-0
    disastrousaur etcher-bin 1.5.51-1
    disastrousaur excalibar-git 0.0.1-1
    disastrousaur excavator 1.5.14a-1
    disastrousaur exe-thumbnailer 0.10.0-1
    disastrousaur expac-git 9.2.g6be7fe1-1
    disastrousaur f3 7.1-1
    disastrousaur fakeuser-git r8.2f456e0-1
    disastrousaur feedthebeast 1.4.17-2
    disastrousaur fernflower-git r453.f4a6388-1
    disastrousaur fetchpkg 0.3-7
    disastrousaur fingerprint-gui 1.09-6
    disastrousaur firefox-beta-bin 68.0rc1-1
    disastrousaur firefox-esr 60.7.2-1
    disastrousaur firefox-esr-bin 60.7.2-1
    disastrousaur firefox-extension-gnome-keyring-git 0.13.r50.0e96ff7-1
    disastrousaur firefox-kde-opensuse 67.0.4-1
    disastrousaur firefox-nightly 69.0a1.20190528-1
    disastrousaur flacon 5.4.0-1
    disastrousaur flutter 1.5.4.hotfix.2-1
    disastrousaur food_gui 1.2.1-1
    disastrousaur frame 2.5.0-1
    disastrousaur franz-bin 5.1.0-1
    disastrousaur freecad 0.18.16117-1
    disastrousaur freetype2-old-hinting 2.10.0-2
    disastrousaur freshplayerplugin 0.3.11-1
    disastrousaur fselect 0.6.3-1
    disastrousaur fsharp 4.5.0-3
    disastrousaur gam 4.88-1
    disastrousaur gamin 0.1.10-9 [installed]
    disastrousaur gcc5 5.5.0-3
    disastrousaur gcc6 6.5.0-2
    disastrousaur gcc6-fortran 6.5.0-2
    disastrousaur gcc6-gcj 6.5.0-2
    disastrousaur gcc6-libs 6.5.0-2
    disastrousaur gcc7 7.4.1+20181207-4
    disastrousaur gcc7-fortran 7.4.1+20181207-4
    disastrousaur gcc7-libs 7.4.1+20181207-4
    disastrousaur geis 2.2.17-2
    disastrousaur geteltorito 0.6-1
    disastrousaur ghidra 9.0.1-1
    disastrousaur git-etc 2.4.0-1
    disastrousaur gitbucket 4.31.2-1
    disastrousaur gmvault 1.9.1-3
    disastrousaur gn-git r1570.19f79dec-1
    disastrousaur gnome-breeze-git 103.21c9617-1
    disastrousaur gnome-python 2.28.1-12
    disastrousaur gnome-shell-extension-arch-update 31-1
    disastrousaur gnome-shell-extension-extended-gestures-git 93.b6bd0b9-1
    disastrousaur gnome-shell-extension-gsconnect 24-1
    disastrousaur gnunet-git 0.11.5.r27984.5541e2e3f-1
    disastrousaur goblocks 1.4.0-1
    disastrousaur gonvert 0.2.39-1
    disastrousaur google-chrome 75.0.3770.100-1
    disastrousaur google-chrome-beta 76.0.3809.46-1
    disastrousaur google-chrome-dev 77.0.3833.0-1
    disastrousaur gotop-bin 3.0.0-2
    disastrousaur gpointing-device-settings 1.5.1-5
    disastrousaur grace 5.1.25-6
    disastrousaur grail 3.1.1-1
    disastrousaur gromacs 2019.3-2
    disastrousaur grpc 1.19.0-1
    disastrousaur grpc-cli 1.19.0-1
    disastrousaur grub-themes-vimix 1.0-1
    disastrousaur h5ai 0.29.2-1
    disastrousaur hangups 0.4.9-1
    disastrousaur hdaps-gl 0.0.5-5
    disastrousaur hdapsicon-git 2eec2c7-1
    disastrousaur heimdall 1.4.2-1
    disastrousaur hfsprogs 540.1.linux3-1
    disastrousaur homebridge-git 0.4.46.r16.g84b4733-1
    disastrousaur hpfall-git r5.be24a8b-2
    disastrousaur hplip-plugin 3.19.6-1
    disastrousaur hpoj 0.91-21
    disastrousaur htmlcxx 0.87-1
    disastrousaur hunspell-ru 20131101-2
    disastrousaur i2p 0.9.40-1
    disastrousaur i2p-bin 0.9.40-1
    disastrousaur i2pd 2.26.0-2
    disastrousaur i3-git 4.16.r135.gb6485c98-1
    disastrousaur i3-gnome 1:3.32.1-1
    disastrousaur i3-gnome-git 5.2.r4.g859779d-1
    disastrousaur i3cat-git r38.c6d29dd-1
    disastrousaur i3pystatus-git 3.35.r321.g071f0ce-1
    disastrousaur i3status-rust-git 0.9.0.r648.gd04d08c-1
    disastrousaur icinga2 2.10.5-1
    disastrousaur icingaweb2 2.6.3-1
    disastrousaur ideviceinstaller-git 1.1.0.r24.g46e6e2a-1
    disastrousaur idnkit 2.3-4
    disastrousaur iio-sensor-proxy-git 2.5.r15.afd8707-1
    disastrousaur indicator-kdeconnect 1:0.9.4-1
    disastrousaur indicator-keylock 3.1.0-1
    disastrousaur inspircd 3.1.0-1
    disastrousaur intel-hybrid-codec-driver 2.0.0.r169.edead0c-2
    disastrousaur intellij-idea-ultimate-edition 2019.1.3-1
    disastrousaur intellij-idea-ultimate-edition-jre 2019.1.3-1
    disastrousaur interbench 0.31-4
    disastrousaur ipmiview 2.16.0-1
    disastrousaur isl 0.21-1
    disastrousaur iso-flag-png 1.0.2-1
    disastrousaur ix 1.0-1
    disastrousaur j4-dmenu-desktop-git 2.17.r8.g7c75b79-1
    disastrousaur j4-make-config-git r69.feee58f-1
    disastrousaur j4status-git 448.6dd031e-1
    disastrousaur java-openjdk-ea-bin 13b27-1
    disastrousaur java-openjfx-bin 11.0.2-2
    disastrousaur java-openjfx-ea-bin 13b9-2
    disastrousaur java-service-wrapper 3.5.39-1
    disastrousaur java32-environment-common 2-2
    disastrousaur java32-runtime-common 2-2
    disastrousaur jd-core-java 1.2-1
    disastrousaur jdk 12.0.1-1
    disastrousaur jdk6 6u45-7
    disastrousaur jdk7 7u80-1
    disastrousaur jdk7-j9-bin 7.0.10.45-1
    disastrousaur jdk7r1-j9-bin 7.1.4.45-1
    disastrousaur jdk8 8u212-1
    disastrousaur jdk8-openj9-bin 8.-1
    disastrousaur jdk9 9.0.4-1
    disastrousaur joplin 1.0.160-1
    disastrousaur jre 12.0.1-1
    disastrousaur jre6 6u45-4
    disastrousaur jre7 7u80-1
    disastrousaur jre8 8u211-1
    disastrousaur jre9 9.0.4-1
    disastrousaur json-parser-git 1:v1.1.0.r20.gb42439a-1
    disastrousaur kalu 4.3.0-1
    disastrousaur kalu-kde 4.3.0-1
    disastrousaur kcm-pointing-devices-git r63.8d34a61-1
    disastrousaur kcm-polkit-kde-git 1:179.ee53590-1
    disastrousaur kded-rotation-git r15.3934f02-1
    disastrousaur kdeicons-nouvekdegray 20140129-1
    disastrousaur kdelibs 4.14.38-4
    disastrousaur kdepimlibs4 4.14.10-15
    disastrousaur kdeplasma-applets-netctl-gui 1.4.9-1
    disastrousaur keepassc 1.7.0-1
    disastrousaur keepassx 0.4.4-3
    disastrousaur keepassx2 2.0.3-2
    disastrousaur keeweb-desktop 1.8.2-1
    disastrousaur keybase-bin 4.1.0_20190612201656+952fee6c59-1
    disastrousaur kingston_fw_updater 205-010
    disastrousaur kmozillahelper 1:5.0.3-1
    disastrousaur kpcli 3.2-2
    disastrousaur krakatau-git r504.258ae9a-1
    disastrousaur ksuperkey 0.4-2
    disastrousaur kubectl-bin 1.15.0-1
    disastrousaur kubectx 0.6.3-1
    disastrousaur laptop-mode-tools 1.72.2-4
    disastrousaur laptop-mode-tools-git 1.72.2.36.g3a944ae-1
    disastrousaur lcdtest 1.18-1
    disastrousaur lenovo-throttling-fix-git 0.167.952128d-1
    disastrousaur lib32-check 0.12.0-1
    disastrousaur lib32-freetype2-old-hinting 2.10.0-2
    disastrousaur lib32-gtk-engines 2.21.0-3
    disastrousaur lib32-libevdev 1.7.0-1
    disastrousaur lib32-libstdc++5 3.3.6-8
    disastrousaur lib32-ncurses5-compat-libs 6.1-2
    disastrousaur lib32-pangox-compat 0.0.2-1
    disastrousaur libakonadi-qt4 1.13.0-14
    disastrousaur libbdplus 0.1.2-1
    disastrousaur libc++ 8.0.0-1
    disastrousaur libc++abi 8.0.0-1
    disastrousaur libc++experimental 8.0.0-1
    disastrousaur libcmrt 1.0.6-2
    disastrousaur libdbusmenu-qt4 0.9.3+16.04.20160218-1
    disastrousaur libechonest-qt5 2.3.1-1
    disastrousaur libestr 0.1.11-1
    disastrousaur libexcalibar-git 0.0.1-1
    disastrousaur libfastjson 0.99.8-2
    disastrousaur libfprint-git 1:0.99.0.r7.g6f4c378-1
    disastrousaur libfprint-vfs0090-git 1:0.99.0.r91.g2e2e382-1
    disastrousaur libfprint-vfs0097-git 0.7.0.r97.gd031869-1
    disastrousaur liblogging 1.0.6-3
    disastrousaur libmonero-wallet 0.14.1.0-3
    disastrousaur libnetctlgui 1.4.9-1
    disastrousaur libnetctlgui-qt4 1.4.9-1
    disastrousaur libpurple-carbons 0.2.2-1
    disastrousaur libpurple-lurch 0.6.8-1
    disastrousaur libpurple-meanwhile 2.10.12-1
    disastrousaur libqxt 0.6.2-5
    disastrousaur librelp 1.4.0-1
    disastrousaur libreoffice-extension-languagetool 4.5.1-1
    disastrousaur libressl 2.9.2-1
    disastrousaur libselinux 2.9-1
    disastrousaur libsepol 2.9-1
    disastrousaur libssh-gnutls 0.9.0-1
    disastrousaur libssh-gnutls-docs 0.9.0-1
    disastrousaur libthinkpad 2.6-4
    disastrousaur libunique3 3.0.2-10
    disastrousaur libva-intel-driver-g45-h264 1:2.3.0-1
    disastrousaur libva-intel-driver-hybrid 2.3.0-2
    disastrousaur libva-vdpau-driver-chromium 0.7.4-4
    disastrousaur libvpx-git 1.8.0.r485.g4d0fe85c19-1
    disastrousaur libxmp 4.4.1-1
    disastrousaur light-git 1.2.r18.g215dbcd-1
    disastrousaur lineageos-devel 0.1-1
    disastrousaur linphone 3.12.0-1
    disastrousaur linux-mainline 5.2rc7-1
    disastrousaur linux-mainline-docs 5.2rc7-1
    disastrousaur linux-mainline-headers 5.2rc7-1
    disastrousaur linuxtv-dvb-apps 1505-2
    disastrousaur lua-argparse 0.6.0-1
    disastrousaur lua-event 0.4.6-1
    disastrousaur lua-zlib 1:1.2-1
    disastrousaur lua51-event 0.4.6-1
    disastrousaur lua51-zlib 1:1.2-1
    disastrousaur lua52-event 0.4.6-1
    disastrousaur lua52-posix 33.4.0-1
    disastrousaur lua52-zlib 1:1.2-1
    disastrousaur luacheck 0.23.0-3
    disastrousaur luyten 0.5.3-1
    disastrousaur lwks 14.5.0-1
    disastrousaur mailman-core 3.2.0-1
    disastrousaur mailman-core-git r9338.b565568ed-1
    disastrousaur mailman-suite-git r32.518b834-1
    disastrousaur mailspring 1.6.3-1
    disastrousaur mapcrafter-git v.2.3.1.r52.g5aa16da-1
    disastrousaur masterpdfeditor 5.4.33-1
    disastrousaur matomo 3.9.1-1
    disastrousaur mattermost 5.12.1-1
    disastrousaur mattermost-desktop 4.2.1-1
    disastrousaur mbpfan-git 2.1.1.r2.gf870822-1
    disastrousaur mcpelauncher-linux-git v0.1.beta.2.r48.g88ad96a-1
    disastrousaur mcpelauncher-msa-git v0.1.beta.2.r3.g31a815c-1
    disastrousaur mcpelauncher-msa-ui-qt-git v0.1.beta.2.r3.g31a815c-1
    disastrousaur mcpelauncher-ui-git v0.1.beta.1.r12.g98ac412-1
    disastrousaur meanwhile 1.0.2-9
    disastrousaur med 4.0.0-3
    disastrousaur med-docs 4.0.0-3
    disastrousaur megasync 4.2.0-1
    disastrousaur memtest86-efi 8.2-2
    disastrousaur minecraft latest-29
    disastrousaur minecraft-launcher 2.1.5410-1
    disastrousaur minecraft-server 1.14.3-2
    disastrousaur minecraft-technic-launcher 4.407-1
    disastrousaur mint-sounds 2.1.8.1-1
    disastrousaur mint-x-icons 1.5.1-1
    disastrousaur mintlocale 1.5.1-1
    disastrousaur minutor-git 2.2.0.r19.g93ac26c-1
    disastrousaur mkinitcpio-chkcryptoboot 0.0.6-1
    disastrousaur mkinitcpio-ppp 0.0.4-3
    disastrousaur mkinitcpio-systemd-tool 17-1
    disastrousaur moarvm 2019.03-1
    disastrousaur monero 0.14.1.0-3
    disastrousaur monero-bin 0.14.1.0-1
    disastrousaur mozilla-extension-gnome-keyring-git 0.13.r50.0e96ff7-1
    disastrousaur msbuild-stable 16.0_xamarinxplat.2018.09.26.17.53_0xamarin3_ubuntu1404b1-1
    disastrousaur multimc-git 0.6.5.r24.g6c30076b-1
    disastrousaur multimc5 0.6.5-2
    disastrousaur mvim-git v0.1.0.r16.gb0bb8d6-1
    disastrousaur nagios 4.4.3-1
    disastrousaur naturaldocs 1.52-1
    disastrousaur nautilus-dropbox 2019.02.14-1
    disastrousaur ncurses5-compat-libs 6.1-1
    disastrousaur netctl-gui 1.4.9-1
    disastrousaur netctl-gui-qt4 1.4.9-1
    disastrousaur netctlgui-helper 1.4.9-1
    disastrousaur netctlgui-helper-qt4 1.4.9-1
    disastrousaur nextcloud-app-keeweb 0.5.1-1
    disastrousaur nitrux-icon-theme 3.5.3-1
    disastrousaur nitrux-icon-theme-kde 3.5.3-1
    disastrousaur nodejs-jsdoc 3.5.5-2
    disastrousaur nodejs-nativefier 7.6.12-1
    disastrousaur nordvpn-bin 3.1.0_6-1
    disastrousaur nouveau-fw 325.15-1
    disastrousaur nqp 2019.03-1
    disastrousaur numix-circle-icon-theme-git 0.r45.64afc58-1
    disastrousaur numix-frost-themes 3.6.6-1
    disastrousaur numix-icon-theme-git 0.r1982.88ba36545-1
    disastrousaur nuttcp 8.1.4-1
    disastrousaur nvm 0.34.0-3
    disastrousaur nvme-cli 1.8.1-1
    disastrousaur obexftp 0.24.2-5
    disastrousaur ocz-ssd-utility 2.3.2963-2
    disastrousaur oczclout 4.02.00.695-4
    disastrousaur ocztoolbox 4.9.0.634-4
    disastrousaur oh-my-zsh-git r5117.486fa1010-1
    disastrousaur onlyoffice-bin 5.2.8.3-1
    disastrousaur opencl-amd 19.10.785425-1
    disastrousaur openh264 2.0.0-1
    disastrousaur openhab2 2.4.0-1
    disastrousaur opennhrp 0.14-1
    disastrousaur openobex 1.7.2-3
    disastrousaur openvr-git 1.4.18.r0.g02bc73b-2
    disastrousaur openwrt-devel 0.1-1
    disastrousaur opera-adblock-complete 11.05.2013-1
    disastrousaur opus-git 1.3.1.2.g86e5f5ea-1
    disastrousaur p3x-onenote 2019.4.114-1
    disastrousaur pacaur 4.8.6-1
    disastrousaur package-query 1.9-3 [installed: 1.9.r380-3]
    disastrousaur pakku 0.13-2
    disastrousaur pamac-aur 8.0.2-1 [installed]
    disastrousaur pamac-classic 6.7.2-1
    disastrousaur pambase-selinux 20190105.1-1
    disastrousaur pamtester 0.1.2-3
    disastrousaur papirus-color-scheme 20161203-1
    disastrousaur papirus-plasma-theme 20161203-1
    disastrousaur perl-checkupdates-aur 0.04-1
    disastrousaur perl-crypt-rijndael 1.13-1
    disastrousaur perl-extutils-makemaker-aur 7.36-1
    disastrousaur perl-file-keepass 2.03-4
    disastrousaur perl-pod-pom 0.28-1
    disastrousaur perl-pod-pom-view-restructured 1.000002-1
    disastrousaur perl-term-shellui 0.92-4
    disastrousaur perl-www-aur 0.22-3
    disastrousaur phantomjs 2.1.1-13
    disastrousaur phonon-qt4 4.10.2-5
    disastrousaur phonon-qt4-gstreamer 4.9.0-1
    disastrousaur phonon-qt4-vlc 0.10.2-1
    disastrousaur php-grpc 1.19.0-1
    disastrousaur php-igbinary 3.0.1-1
    disastrousaur php-imagick 3.4.3-5
    disastrousaur php-pear 1:1.10.15-1
    disastrousaur php-redis 4.3.0-1
    disastrousaur pianobooster 0.6.4b-1
    disastrousaur pidgin-encryption 3.1-3
    disastrousaur pidgin-gpg-git r68.026bc8a-1
    disastrousaur pidgin-latex 1.5.0-1
    disastrousaur pidgin-light 2.13.0-1
    disastrousaur pidgin-sipe 1.24.0-2
    disastrousaur pikaur 1.4.3-1
    disastrousaur pioneer 20190203-1
    disastrousaur pjproject 2.9-2
    disastrousaur pkgbrowser 0.21-3
    disastrousaur pkgbuild-watch 20120622-1
    disastrousaur plasma5-applet-netctl-gui 1.4.9-1
    disastrousaur plasma5-applets-kde-arch-update-notifier-git 7.2.1.r1.ga330639-1
    disastrousaur plasma5-applets-redshift-control-git 1:r26.e04266c-1
    disastrousaur plymouth 0.9.4-4
    disastrousaur plymouth-git 0.9.4.r113.g566af35-1
    disastrousaur plymouth-theme-arch-breeze-git r4.f7789af-1
    disastrousaur plymouth-theme-monoarch 0.1-1
    disastrousaur polkit-kde 0.99.0-6
    disastrousaur polkit-qt4 0.112.0+git20180107-1
    disastrousaur polybar 3.3.1-2
    disastrousaur postfix-policyd-spf-perl 2.011-1
    disastrousaur postman-bin 7.2.2-1
    disastrousaur powerstat-git 0.02.18.r2.g6aa355c-1
    disastrousaur preloader-signed 20130208-1
    disastrousaur procyon-decompiler 0.5.34-1
    disastrousaur profile-cleaner 2.37-1
    disastrousaur proguard 6.1.1-1
    disastrousaur prometheus-haproxy-exporter-bin 0.10.0-1
    disastrousaur prometheus-node-exporter-bin 0.18.0-1
    disastrousaur prosody-hg r10043+.ce8e18f20693+-1
    disastrousaur pulseaudio-ctl 1.66-1
    disastrousaur purple-discord-git v0.0.r537.22de4c6-1
    disastrousaur purple-events 0.99.1-2
    disastrousaur purple-gnome-keyring 1.1-3
    disastrousaur purple-icyque-git r50.a10e28e-1
    disastrousaur purple-rocketchat 1-1
    disastrousaur purple-skypeweb-git 1.5.r23.5d29285-1
    disastrousaur pyqt4-common 4.12.3-3
    disastrousaur python-aiosmtpd 1.1-1
    disastrousaur python-atpublic 0.5-1
    disastrousaur python-backports.ssl 0.0.9-1
    disastrousaur python-bcc 0.10.0-2
    disastrousaur python-django-allauth 0.36.0-1
    disastrousaur python-django-appconf 1.0.2-1
    disastrousaur python-django-compressor 2.1-1
    disastrousaur python-django-crispy-forms 1.7.2-1
    disastrousaur python-django-gravatar 1.4.0-1
    disastrousaur python-django-paintstore 0.1-1
    disastrousaur python-django-rest-framework 3.9.3-1
    disastrousaur python-falcon 2.0.0-1
    disastrousaur python-flufl-bounce 2.3-1
    disastrousaur python-flufl-i18n 1.1.3-1
    disastrousaur python-flufl-lock 2.4.1-1
    disastrousaur python-google-auth-oauthlib 0.3.0-1
    disastrousaur python-keepmenu-git r89.ddc7262-1
    disastrousaur python-kppy 1.5.2-1
    disastrousaur python-lazr-config 2.1-1
    disastrousaur python-lazr-delegates 2.0.3-1
    disastrousaur python-lazr-smtptest 2.0.3-1
    disastrousaur python-mailman-hyperkitty-plugin 1.1.0-1
    disastrousaur python-mailmanclient 3.1.0-1
    disastrousaur python-mechanicalsoup 0.11.0-1
    disastrousaur python-openid 3.0.10-1
    disastrousaur python-pivy 0.6.4-2
    disastrousaur python-pjproject 2.9-2
    disastrousaur python-pyqt4 4.12.3-3
    disastrousaur python-pyuserinput-git r260.1502266119.ac2d4c7-1
    disastrousaur python-qscintilla-qt4 2.10.8-4
    disastrousaur python-qscintilla-qt4-common 2.10.8-4
    disastrousaur python-rcssmin 1.0.6-1
    disastrousaur python-readlike 0.1.2-1
    disastrousaur python-reparser 1.4.3-1
    disastrousaur python-rjsmin 1.0.12-1
    disastrousaur python-robot-detection 0.4.0-1
    disastrousaur python-sip-pyqt4 4.19.16-2
    disastrousaur python-social-auth 0.2.21-1
    disastrousaur python2-backports.ssl 0.0.9-1
    disastrousaur python2-bcc 0.10.0-2
    disastrousaur python2-django-allauth 0.36.0-1
    disastrousaur python2-django-appconf 1.0.2-1
    disastrousaur python2-django-compressor 2.1-1
    disastrousaur python2-django-crispy-forms 1.7.2-1
    disastrousaur python2-django-gravatar 1.4.0-1
    disastrousaur python2-django-haystack 2.4.0-1
    disastrousaur python2-django-mailman3 1.1.0-1
    disastrousaur python2-django-paintstore 0.1-1
    disastrousaur python2-django-postorius 1.1.2-1
    disastrousaur python2-django-rest-framework 3.9.3-1
    disastrousaur python2-falcon 2.0.0-1
    disastrousaur python2-flufl-bounce 2.3-1
    disastrousaur python2-flufl-i18n 1.1.3-1
    disastrousaur python2-flufl-lock 2.4.1-1
    disastrousaur python2-gconf 2.28.1-12
    disastrousaur python2-imapclient 1.0.2-1
    disastrousaur python2-ipaddr 2.2.0-1
    disastrousaur python2-lazr-config 2.1-1
    disastrousaur python2-lazr-delegates 2.0.3-1
    disastrousaur python2-lazr-smtptest 2.0.3-1
    disastrousaur python2-mailmanclient 3.1.0-1
    disastrousaur python2-mechanicalsoup 0.11.0-1
    disastrousaur python2-pivy 20101207-1
    disastrousaur python2-pyqt4 4.12.3-3
    disastrousaur python2-pyside2 5.12.1-1
    disastrousaur python2-qscintilla-qt4 2.10.8-4
    disastrousaur python2-rcssmin 1.0.6-2
    disastrousaur python2-rjsmin 1.0.12-2
    disastrousaur python2-robot-detection 0.4.0-1
    disastrousaur python2-shiboken2 5.12.1-1
    disastrousaur python2-sip-pyqt4 4.19.16-2
    disastrousaur python2-social-auth 0.2.21-1
    disastrousaur q4wine 1.3.11-1
    disastrousaur qdep 1.0.1-1
    disastrousaur qemu-arm-static 2.12.0r3-2
    disastrousaur qjson 0.9.0-3
    disastrousaur qlcplus 4.12.1-1
    disastrousaur qlcplus-qt5 4.12.0-1
    disastrousaur qownnotes 19.7.1-1
    disastrousaur qscintilla-qt4 2.10.8-4
    disastrousaur qt4 4.8.7-30
    disastrousaur quisk 4.1.39-1
    disastrousaur rakudo 2019.03.1-1
    disastrousaur rambox-bin 0.6.9-1
    disastrousaur rar 5.7.1-1
    disastrousaur redshift-qt 0.4-1
    disastrousaur redshiftconf 2.2-1
    disastrousaur redshiftgui-bin 0.2.4-2
    disastrousaur repkg 1.4.0-1
    disastrousaur retdec-git 20190503_960da617-1
    disastrousaur ripcord 0.4.6-1
    disastrousaur rocketchat-desktop 2.15.3-2
    disastrousaur rspamd 1.9.2-1
    disastrousaur rsyslog 8.1904.0-1
    disastrousaur rt3290sta-dkms 2.6.0.0-5
    disastrousaur rtl-sdr-git 1:0.6.0.r2.gf68bb2f-1
    disastrousaur rtl8821ce-dkms-git 1.0.5.r40.ge7d49c2-1
    disastrousaur rts5227-dkms 1.07-8
    disastrousaur rts_bpp-dkms-git 10-1
    disastrousaur rua 0.13.10-1
    disastrousaur s-tui 0.8.3-1
    disastrousaur samba-mounter-git 157.d0207e7-1
    disastrousaur samsung_magician-consumer-ssd 1.0-1
    disastrousaur screenrotator-git 1:r25.e1de8b7-1
    disastrousaur sedutil 1.15.1-2
    disastrousaur sencha-cmd-6 6.7.0.63-2
    disastrousaur sendanywhere 9.3.5-1
    disastrousaur shim-signed 15.f8-2
    disastrousaur signal 1.25.3-1
    disastrousaur signal-desktop-bin 1.25.3-1
    disastrousaur skypeforlinux-stable-bin 8.48.0.51-1
    disastrousaur slack-desktop 3.4.2-1
    disastrousaur slack-desktop-dark 3.4.2-1
    disastrousaur slack-libpurple-git r194.c10cc72-1
    disastrousaur snapd 2.39.3-1
    disastrousaur snapd-git 2.39.3.r1091.g57f9ad71fb-1
    disastrousaur sni-qt 0.2.6-5
    disastrousaur soqt 1.6.0a+2014+m872b87e73dfb-1
    disastrousaur spigot 1.14.3+b101-1
    disastrousaur spotify 1:1.1.5.153-1
    disastrousaur statusnotifier 1.0.0-1
    disastrousaur steamcmd latest-3
    disastrousaur sway-git r5944.9670ccee-1
    disastrousaur swaybg-git r94.25c6eaf-1
    disastrousaur systemd-kcm 1.2.1-4
    disastrousaur taglib-extras 1.0.1-7
    disastrousaur tbt 0.9.3-1
    disastrousaur teamviewer 14.3.4730-1
    disastrousaur teamviewer-beta 14.3.4730-1
    disastrousaur telegram-desktop-bin 1.7.10-1
    disastrousaur telegram-purple 1.4.1-1
    disastrousaur telegram-purple-git 1.4.2.de1e68d-1
    disastrousaur telegram-qt-git r2009.90043af-1
    disastrousaur telepathy-morse-git r230.5e6f292-1
    disastrousaur thermald 1.8-2 [installed]
    disastrousaur thinkfan 1.0.2-2
    disastrousaur thinkfinger 0.3-9
    disastrousaur thinkpad-helix-utils v2.7.r16.g83a3100-1
    disastrousaur thinkpad-l380-yoga-scripts-git r62.5621f37-1
    disastrousaur thinkpad-yoga-scripts-git r57.5599d33-1
    disastrousaur throttled 0.6-2
    disastrousaur thunderbird-extension-gnome-keyring-git 0.13.r50.0e96ff7-1
    disastrousaur timeshift 19.01-3
    disastrousaur tinyssh-convert-git r93.230b9ad-1
    disastrousaur tmate 2.2.1-2
    disastrousaur tor-browser 8.5.3-1
    disastrousaur tor-browser-en 8.5.1-1
    disastrousaur tpb 0.6.4-2
    disastrousaur trizen 1:1.60-1
    disastrousaur ttcp 20071201-2
    disastrousaur ttf-emojione-color 1.4-1
    disastrousaur ttf-font-icons 1.1-1
    disastrousaur ttf-material-design-icons 3.0.1-1
    disastrousaur ttf-ms-fonts 2.0-10
    disastrousaur ttf-symbola 12.00-1
    disastrousaur ttf-twemoji-color 12.0.1-1
    disastrousaur ty3status-git 0.5.1.r4.g2a42906-1
    disastrousaur ultravnc-viewer 1.2.1.6-1
    disastrousaur unetbootin 661-1
    disastrousaur ungoogled-chromium 75.0.3770.100-1
    disastrousaur ungoogled-chromium-bin 71.0.3578.98-2
    disastrousaur unixbench 5.1.3-4
    disastrousaur urxvt-perls-git 128.1f4897c-1
    disastrousaur usbtop 1.0-1
    disastrousaur vdr 2.4.1-14
    disastrousaur vdr-api 2.4.1-1
    disastrousaur vdr-examples 2.4.1-14
    disastrousaur vesta 3.4.6-2
    disastrousaur viber 10.3.0.37-1
    disastrousaur vim-colorschemes r190.c79c769-1
    disastrousaur vim-qml-git r33.8af43da-1
    disastrousaur vim-youcompleteme-git r2506.d691404a-1
    disastrousaur vimix-gtk-themes-git r342.632770b-1
    disastrousaur vimix-icon-theme 1.3-1
    disastrousaur virtualbox-ext-oracle 6.0.8-1
    disastrousaur vivaldi 2.6.1566.44-1
    disastrousaur vuescan-bin 9.6.x-1
    disastrousaur whatsapp-nativefier 0.3.2846-1
    disastrousaur windscribe-cli 1.3_19-1
    disastrousaur wine-valve-git 4.2.r288.g7db0aa426b-1
    disastrousaur wlroots-git 0.6.0.r4.g107a1789-1
    disastrousaur wmfocus 1.1.3-1
    disastrousaur woeusb 3.3.0-1
    disastrousaur woeusb-git 3.3.0.r0.g5e9a3a7-1
    disastrousaur x264-git 157.r2969.gd4099dd4-1
    disastrousaur x265-hg 3.0_Au.r21.bac0e1acb874-1
    disastrousaur xautoclick 0.31-5
    disastrousaur xbindkeys_config-gtk2 0.1.3-4
    disastrousaur xbps-git 0.51.r383.gf5f7f6b5-1
    disastrousaur xcursor-pixelfun3 1:1.3-1
    disastrousaur xf86-input-evdev-trackpoint 2.10.5-1
    disastrousaur xf86-input-mtrack 0.4.1-1
    disastrousaur xfce4-hdaps 0.0.9-2
    disastrousaur xinput_calibrator 0.7.5-3
    disastrousaur xlite_bin 2.0-6
    disastrousaur xml2 0.5-1
    disastrousaur xmrig 2.14.4-1
    disastrousaur xmrig-donateless 2.14.1-1
    disastrousaur xpub 0.6.1-1
    disastrousaur xsecurelock-git 1.3.1.r2.gd85dccc-1
    disastrousaur xtables-addons-dkms 3.3-1
    disastrousaur yagostatus-git v0.4.0.r1.g32dbd57-1
    disastrousaur yaourt 1.9-1 [installed]
    disastrousaur yay 9.2.1-1
    disastrousaur yay-bin 9.2.1-3 [installed]
    disastrousaur yay-git 9.2.1.r9.gf406866-1
    disastrousaur ycm-generator-git r123.461e304-1
    disastrousaur yed 1:3.19-2
    disastrousaur zoom 2.8.252201.0616-1
    disastrousaur zotero 5.0.69-2
    disastrousaur zramswap 3-1
    disastrousaur zulip-electron-bin 2.3.82-2
    ┌──[just]@[alexafg]:~$
    └─>
    

    Done.

  • @just said in Antefree isn't disastrous:

    Let’s add [disastrousaur] to Antefree. The steps are:

    Import maintainer’s key
    Verify key’s fingerprint
    Locally sign the key

    Was using it happily based on your tutorial here, but as of today i get this error:

    error: disastrousaur: signature from "XDFR Alliance Signing (Felix Golatofski) <[email protected]>" is invalid
    :: Synchronizing package databases...
     core is up to date                                                                                      0.0   B  0.00B/s 00:00 [-----------------------------------------------------------------------------]   0%
     extra is up to date                                                                                     0.0   B  0.00B/s 00:00 [-----------------------------------------------------------------------------]   0%
     community is up to date                                                                                 0.0   B  0.00B/s 00:00 [-----------------------------------------------------------------------------]   0%
     multilib is up to date                                                                                  0.0   B  0.00B/s 00:00 [-----------------------------------------------------------------------------]   0%
     disastrousaur                                                                                         184.0 KiB  1840K/s 00:00 [#############################################################################] 100%
     disastrousaur.sig                                                                                     119.0   B  0.00B/s 00:00 [#############################################################################] 100%
    error: disastrousaur: signature from "XDFR Alliance Signing (Felix Golatofski) <[email protected]>" is invalid
    error: failed to update disastrousaur (invalid or corrupted database (PGP signature))
    error: failed to synchronize all databases
    

    I tried refreshing the keys: sudo pacman-key --refresh-keys. It didn’t fix the issue.
    Then I tried the following:

    pacman-key --list-sigs XDFR
    gpg: Note: trustdb not writable
    pub   ed25519 2018-10-21 [SC]
          79A640BD69FF438838654415CB8DA19D1551E92F
    uid           [  full  ] XDFR Alliance Signing (Felix Golatofski) <[email protected]>
    sig 3        CB8DA19D1551E92F 2018-10-21  XDFR Alliance Signing (Felix Golatofski) <[email protected]>
    sig   L      64034912EF57F523 2019-07-30  Pacman Keyring Master Key <[email protected]>
    sub   cv25519 2018-10-21 [E]
    sig          CB8DA19D1551E92F 2018-10-21  XDFR Alliance Signing (Felix Golatofski) <[email protected]>
    

    then i tried these commands

    sudo pacman-key --delete 79A640BD69FF438838654415CB8DA19D1551E92F
    sudo pacman-key --recv-keys 79A640BD69FF438838654415CB8DA19D1551E92F
    sudo pacman-key --lsign-key 79A640BD69FF438838654415CB8DA19D1551E92F
    sudo pacman-key --lsign-key CB8DA19D1551E92F
    sudo pacman-key --lsign-key 64034912EF57F523
    

    The above commands executed successfully, they keys have been signed locally, but I still cannot perform a system update, the error is still error: disastrousaur: signature from "XDFR Alliance Signing (Felix Golatofski) <[email protected]>" is invalid
    and sudo pacman-key -f xdfr returns:

    pub   ed25519 2018-10-21 [SC]
          79A6 40BD 69FF 4388 3865  4415 CB8D A19D 1551 E92F
    uid           [  full  ] XDFR Alliance Signing (Felix Golatofski) <[email protected]>
    sub   cv25519 2018-10-21 [E]
    

    Any idea how to fix this?

  • @nate_x said in Antefree isn't disastrous:

    …as of today i get this error:

    I’m in vacation now. Without computers, without Arch, almost without Internet. Unfortunately, can’t do much from tablets only. Will investigate deeper in next days, when I’ll be in the city for a few hours. Sorry.

    Don’t worry, it’s impossible to forget about the issue, because I should get the same error on the first upgrade.

  • ArchWiki warns about the fact that [disastrousaur] is currently under maintenance. It also states that inconveniences will be solved “in next week”. The warning is there for some months now. The “next week” is not clearly defined.

    As a temporarily workaround it is possible to switch off checks for repo’s key. Simply add below the repo’s name (in square brackets) and above the server’s address (with URL) one more line:

    SigLevel = Optional TrustAll
    

    The error message should disappear, once the line is added. The line may be removed later, when | if the error with the key will be solved.

  • thank you for this. hope you’re enjoying your vacation :)

  • Adding the SigLevel did not fix this issue for me.

  • @just
    Hello there,
    the maintainer of disastrousaur here. I got mail regarding the issues you are experiencing here. First things first. I do had a warning in the unofficial repos article of Arch Linux. But it was obsolete and I’ve changed it to an advise for people which did not see the previous one. The issues you’ve been experiencing were caused by me removing packages I was not allowed to build, cuz of license-changes made by corporations (e.g. Oracle).
    Therefore the database signature got messed up and I fixed it just now . If you are experiencing any further problems while using my repository feel free to contact me via email (Look it up via my signing key for the repo).

    Kind regards,
    Felix (TheGoliath)

  • @thegoliath Thank you very much for kind explanation and detailed description of what was happened.

    [disastrousaur] works without a problem again.

    I was about to respond that few minutes ago I upgraded some Arch systems without any problem. All systems use your repo. An example:

    :: Synchronizing package databases...
     core                     132.5 KiB  8.08M/s 00:00 [---------] 100%
     extra                   1630.7 KiB  10.6M/s 00:00 [---------] 100%
     community                  4.9 MiB  5.70M/s 00:01 [---------] 100%
     multilib                 170.5 KiB  9.80M/s 00:00 [---------] 100%
     bluestar-override         29.0   B  0.00B/s 00:00 [---------] 100%
     bluestar                  72.4 KiB   247K/s 00:00 [---------] 100%
     disastrousaur            184.1 KiB  1898K/s 00:00 [---------] 100%
     disastrousaur.sig        119.0   B  0.00B/s 00:00 [---------] 100%
     herecura                  58.7 KiB   587K/s 00:00 [---------] 100%
     revenge_repo              38.9 KiB  1051K/s 00:00 [---------] 100%
     Foreign packages: | 4 / 4
    

    I didn’t know how to explain the fact that there were some problems with your key a few days ago, but now (2019.08.01 12:20 local time) [disastrousaur] works perfectly again.

    Your post explains everything.

    Thanks again
    JT

  • A quick question here, why do all other repos have their own entry but disastrousaur has two? what’s with the .sig thing? it prickles my OCD a bit :)
    And another one:
    I’ve commented the diastrousaurus repo out because of the issues i’ve experienced with the keys, so i could do a system update. At that point a few packages went ahead and updated themselves from AUR. Now i’ve added it back, but I see this:

    warning: pamac-aur: local (8.0.3-1) is newer than disastrousaur (8.0.2-1)
    warning: slack-desktop: local (4.0.1-1) is newer than disastrousaur (4.0.0-1)
    warning: tor-browser: local (8.5.4-1) is newer than disastrousaur (8.5.3-1)
    

    Are the apps in the repo stale for security reason or is this just a maintenance thing “I update when my spare time allows…”?

  • @nate_x said in Antefree isn't disastrous:

    …what’s with the .sig thing?..

    There were very long discussions about .sig in various forums. The most useful was in Arch forum some years ago.

    If I understood correctly, a definitive answer was not found.

    Again, if I didn’t misunderstand, it happens for signed repos only - but not always, - and is due to not very correct work of some mirrors.

    At that time, I was satisfied with this explanation.

    .sig aren’t real repos, they are void (empty), don’t contain any package. Their presence is harmless.

  • @nate_x said in Antefree isn't disastrous:

    …At that point a few packages went ahead and updated themselves from AUR…

    Obviously, I can’t respond for repo’s maintainer. But slightly newer AUR pkgs is a quite common thing for most precompiled 3rd-party repos.

    As you know, AUR doesn’t have any package at all. You compile a package from sources, on your local computer, according to instructions contained in PKGBUILDs.

    Repo’s maintainer must do all that job for us. He must follow the most recent sources versions, compile them on his hardware, must distribute compiled pkgs to server(s) and mirror(s).

    PKGBUILDs in AUR practically don’t require any maintenance at all. Arch repos are maintained by hundreds of people. Most 3rd-party repos are maintained by one person.

    Keeping everything up-to-date seems to be rather big job for one maintainer.

  • Good evening (or night here in Germany xd),
    yes, I know that some packages are out of date. I’ll do some updates tomorrow. I stopped my update automation of the repo for maintenance purposes (oracle jdk etc). So you might see some shiny updates tomorrow. Secondly. The .sig repo is basically the signature file for the database itself. My repository is SigLevel = Signed
    Even the database itself is signed. That’s why you get that additional “void repo”. And that’s also what caused you all to stumble while updating. The signature for the database was not valid.

    I’ll go to bed now and answer later today.
    Cheers

antefree9 disastrous1 Posts 12Views 819
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.