• Printers


    How can i install my printer in KDE? The drivers are in the AUR and it sets up on Cinnamon when i install the drivers. On KDE it doesn’t automatically install the printer. I have tried and don’t understand how to set it up in KDE. It is the Canon MG2525 on USB. I have tried the CUPS but i can’t seem to get the right path to make it work. It sees it on usb no problem.

  • Printer works plugged on usb and you want connect it over lan/wlan?

    To Get the Current IP address for your printer, Just print the “Network Information Sheet”. This can be done by holding the “RESUME/CANCEL” button until the power lamp flashes 6 times and then release it.

  • @joekamprad Sorry for the mixed communication. I’m using KDE right now which I’m not used to. On Cinnamon when you install the printer it automatically sets up and works with drivers from the AUR. In KDE I had to use cups after installing the Drivers from the AUR and I was having trouble configuring the path but I finally figured it out. I had never used CUPS before this. Thanks for the info for another time if I remember it when I need it. 🤔

  • I have reinstalled EndeavourOS and want to install the same printer on Xfce. I have installed the drivers from the AUR. Printer did not set up automatically. Cups was not installed? I installed it but it won’t browse to http://localhost:631/
    What do i need to do to set this up?

  • I had this problem, too. You need to enable and start the cups service

    sudo systemctl enable org.cups.cupsd.service
    

    then

    sudo systemctl start org.cups.cupsd.service
    

    Should work after that.

  • sudo systenctl start avahi-daemon.service
    sudo systemctl enable avahi-daemon.service
    

    for network printers needed:

    Avahi is a free Zero-configuration networking (zeroconf) implementation, including a system for multicast DNS/DNS-SD service discovery. It allows programs to publish and discover services and hosts running on a local network with no specific configuration. For example you can plug into a network and instantly find printers to print to

  • @grenouille Thanks. Xfce doesn’t have the print options in the menu? I tried to enable cups with the wrong command late last night. (sudo systemctl enable cups.service) It was late and i didn’t feel like reading the Arch encyclopedia! I have it working now thanks.

  • @joekamprad Thanks …i’ll keep this reference in mind if i need to set up for a network printer. So now i have the printer working with cups added so if i wan’t to use the avahi-daemon.service i could set it as a network printer or do you use one or the other but not both cups.d service and avahi-daemon?

  • I guess i spoke too soon. The printer isn’t printing it say’s:
    Job stopped due to filter errors; please consult the /var/log/cups/error_log file for details.

    I’m going to have to look at this later on when i get some time. ☹

    Screenshot_2019-06-20_11-05-21.png

  • Looks like wrong driver… avahi is only needed together with cups for searching available network printers.

  • @joekamprad The driver is the MG2500 in the AUR and it works on Antergos Cinnamon and KDE and probably others without doing anything with cups which is already installed anyway. Same driver from the AUR also works on Manjaro Cinnamon. On the EndeavourOS CUPS isn’t installed and I installed the same driver but i also installed CUPS and tried to set it up. I decided for now to go back to Antergos KDE since it’s works and i can’t install Antergos Cinnamon because it’s missing a package. I’m just waiting to get to a point where i can roll over to Endeavour permanently and i can get it all working. I understand now avahi is only for network printer. This one is just usb connected and i never had to configure it with CUPS before. So i’m not sure why it’s not just working like on Antergos? I know you got bigger fish to fry so no worries. I’m going to wait a little while yet. Thanks.

  • @ricklinux said in Printers:

    So i’m not sure why it’s not just working like on Antergos? I know you got bigger fish to fry so no worries. I’m going to wait a little while yet. Thanks.

    This will be interesting to know!
    but i think there is missing something installed, or setup.

    working way to start with cups:
    https://kamprad.net/index.php/docs/hardware/printers-printing/

  • @joekamprad So i wanted to get back to you on this printing issue related to Antergos and possibly EndeavourOS. So i was able finally to reinstall Antergos Cinnamon after unchecking printing support because python2-gnomekeyring isn’t available anymore. So i installed cups and enabled it and started cups. Then i installed the MG2500 Canon driver from the AUR which is what i have always done before and the printer automatically always just installed with no configuration in CUPS when printing support was installed. Now because printing support isn’t installed and even though i installed and started CUPS the Printer doesn’t automatically install but i can configure CUPS and get it working on Antergos Cinnamon. So i looked on my other Antergos Cinnamon install that has different Brother printer on it which also automatically installed with the drivers from the AUR. Antergos was installed on this computer with printing support checked. So it has the following additional components installed.

    cups-pk-helper
    phython-pycups
    print settings (system-config-printer)

    So i installed these additional components on my newly reinstalled Antergos Cinnamon and installed the MG2500 driver from the AUR and the printer automatically installed as before. So now i have manage printing in the start menu which is CUPS and also print settings which shows my printer installed. So now i just have to try this the next time i install EndeavourOS and see if it’s the same because i could not get the printer working as it didn’t automatically install and when i configured CUPS it was giving the error for filter failed when i tried to print a test page. EndeavourOS also doesn’t have printing support on the install. I had no idea what components are needed so i just tried with cups but it didn’t work. I will eventually try it again in EndeavourOS.

printers5 Posts 13Views 278
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.