• Blank screen after upgrade - possible Nvidia driver issue

    tl;dr possible nvidia driver issue after upgrade resulting in blank screen during boot; Xorg.0.log file has possible clues(?)

    Hello. I am a very happy Antergos user, and am looking forward to the possibility of its legacy continuing through Endeavour or some similar project.

    After the initial installation in January, 2019, I have not encountered any system-wide problems until earlier this week. I did the regular update/upgrade with no obvious problems.

    I shut down my laptop for the night, and when I went to reboot the next morning, I saw the normal boot procedure start, the little systemd message that displays the version, and the disk check (the one that says file system is clean or something similar), and a few seconds later, a blank screen. Nothing else.

    I tried to access a login screen by trying to get one of the tty sessions by pressing CTRL-F1, F2, etc., to no result.

    CTRL-ALT-DEL reboots, and I can reproduce the above scenario endlessly, apparently.

    (1) After searching online, I came across a suggestion to use a live Antergos instance to mount my normal root partition, arch-chroot into that partition, and run a regular Pacman update/upgrade. It indicated success, but had no impact on the problem.

    (2) I thought maybe the boot process had progressed far enough to generate some logs (at least I hoped so), so I looked through the log folder, and it appeared that the Xorg log file was the only possible candidate for relevance.

    After looking at it, even though I didn’t understand most of it, I believe that the possible issue causing this problem is something to do with the Nvidia driver or a kernel module relating to the video card somehow.

    I am motivated to have this be a learning experience (as it already has - I had never used arch-chroot before. That was cool to be able to run commands that way.)

    However, I don’t want to just try random things from various Google searches, and risk breaking my system more seriously, so I’m asking for some suggestions about possible next steps to take in troubleshooting this issue.

    I know Antergos isn’t active any longer, but I hesitate to ask for help on an Arch forum because the reception to such requests is not what I would call friendly from my lurking there.

    I didn’t see a facility to attach a file (even though the sticky topic for attaching log files talks about doing so after zipping all the relevant files together), so I’m using a link to to hastebin for the Xorg.0.log file on my system.

    [https://hastebin.com/ejesoyixow.cpp](link url)

    Thanks for any help or suggestions.


  • @allan_m will need a boot log as xorg log only give minimal output


    lspci > log.txt && lsusb >> log.txt && journalctl -b -0 >> log.txt && cat log.txt | curl -F 'f:1=<-' ix.io

    also would be good as it is more short for you to type maybe?

    journalctl -b -0 | curl -F 'f:1=<-' ix.io

    it will upload log and give a short URL you can post

  • Thanks for your reply @joekamprad. I did as you instructed (and I learned something else) and got the following output here: link text. If you (or anyone else) has time and inclination to look at it, perhaps it will mean more than it does to me (mostly gibberish). Thank you.

  • ant-19.4 …
    you where giving bootlog from starting LiveISO… will need to be the one from real system… you will need to arch-chroot into it or try typing the command from realboot after login without graphical environment.

  • Thanks for your replies and patience @joekamprad. I found a workaround to the problem without actually solving it, so I’m going to mark this solved. Here’s what I did in case anyone else might have been affected by something in an updated nvidia video driver:

    (1) At the grub menu, I pressed E to get into a screen to edit boot parameters. I went down to the line “linux” and entered “nomodeset” after “quiet”. CTRL-X to continue booting. This let me get to a login prompt.

    (2) I logged in, installed the antergos nvidia-installer package in pacman, and then installed the nouveau drivers instead of the nvidia proprietary driver.

    (3) Rebooted and was able to log into my system, and it’s functional, even though it doesn’t look as pretty as when I was using the nvidia driver. But something borked on the nvidia driver, and I don’t know how to fix that, so I will be content.

    Thanks for your help. This was at least a learning experience.

  • I had this exact same problem just a week or two ago. I tried arch-chroot too, but didn’t work. I tried messing with the boot options, but didn’t work, or I did it incorrectly. Reinstalled Antergos. Lost some files since my backup drive had an error, but now in a working system again and haven’t had the same issue since.

    Thanks or the workaround. I’ll try it next time if/when the same thing happens again.

nvidia165 blank screen12 Posts 6Views 187
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.