• nvidia 340xx drivers dropped from arch repositories


    You might remember there was a problem with nvidia 340xx drivers about three weeks ago. After that the developers decided to drop the 340xx drivers from the arch repositories:

    https://lists.archlinux.org/pipermail/arch-dev-public/2019-May/029568.html

    https://lists.archlinux.org/pipermail/arch-dev-public/2019-May/029577.html

    https://www.archlinux.org/packages/extra/x86_64/nvidia-340xx/

    https://www.archlinux.org/packages/extra/x86_64/nvidia-340xx-lts/

    I really do not understand this. My computer does not work with nouveau drivers (although the developers “hope” so) from the beginning of this year (linux versions above 4.10).

    So I decided at last to install linux-lts. But I cannot boot linux-lts, the booting gets stuck with a blinking cursor, which indicates that for my hardware the nouveau is causing problems. On the other hand, nvidia will drop support for 340xx at the end of the year, so a solution is clearly needed for me. My questions:

    • anybody knows from where I could get last nvidia 340xx-lts driver to make my linux-lts work?
    • any ideea about a replacement of the old video (GeForce 405) card with a newer one (if anybody has/had the same problem)?
  • OK, for those in the same situation like me, it seems I found a solution. GeForce GT 710 (for example from MSI) is available, has similar shape (it is even smaller, so it should fit in your old PC), consumes even less power (19W vs 25W), is more powerful (192 vs 16 CUDA cores), has passive cooling (no noise), uses same (old) interface (PCI Express 2.0), it supports two monitors as well, and the best is that it uses the latest drivers. Of course, this card is not for gaming, but it only costs around 50 Euros.

  • @new2antrgs do you try the nouveau modsetting driver included in the kernel already?

    remove nvidia driver and nouveau package if installed (xf86-video-nouveau)
    then:

    sudo nano /etc/mkinitcpio.conf
    

    Add nouveau to the modules:

    # vim:set ft=sh
    # MODULES
    # The following modules are loaded before any boot hooks are
    # run.  Advanced users may wish to specify all system modules
    # in this array.  For instance:
    #     MODULES=(piix ide_disk reiserfs)
    MODULES="nouveau"
    

    save with [Ctrl+X]
    Rebuild images:

    sudo mkinitcpio -p linux
    
  • @joekamprad
    Thank you for this, my “mkinitcpio.conf” does not contain MODULES=“nouveau”!

    As I understand, “mkinitcpio -p linux” is run after every linux update, so I’ll try it next time when I update linux kernel. I do not have “xf86-video-nouveau” installed, and I’ll try to keep the nvidia drivers installed but remove the blacklisting of nouveau as explained in https://wiki.archlinux.org/index.php/Nouveau#Tips_and_tricks.

  • @new2antrgs next kernel update will break your nvidia drivers… as the modules needs to be generated against running kernel…

  • @joekamprad

    I tried “sudo mkinitcpio -p linux” after modifying “mkinitcpio.conf” with the new 5.1.7 kernel but it is still not working. Of course, I could not boot properly because I did not have proper nvidia drivers, but I gave “sudo mkinitcpio -p linux” after booting the new kernel from the Ctrl-Alt-F2 command line and rebooted. I also checked that nouveau was loaded and nvidia was not (with rmmod). From the same command line I downgraded then back to 5.1.6 kernel.

nvidia166 drivers56 dropped2 340xx2 Posts 6Views 249
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.