• Use Xfce.


    Hi,
    I recently installed Antergos, all went well, no problems at all. I chose the gnome desktop upon installation which seems fine however I want to try Xfce as I’m running an old dell inspiron and it is a bit slow.

    So, can someone tell me how to change from gnome to Xfce please. I’ve done a lot of google research on this topic but most of the answers are from arch and as I am unskilled with computers I couldn’t understand them. I can use the command line reasonably well but is there a fairly straightforward way to achieve my goal.

    thanks,
    ralph.

  • Hi,
    I recently installed Antergos, all went well, no problems at all. I chose the gnome desktop upon installation which seems fine however I want to try Xfce as I’m running an old dell inspiron and it is a bit slow.

    So, can someone tell me how to change from gnome to Xfce please. I’ve done a lot of google research on this topic but most of the answers are from arch and as I am unskilled with computers I couldn’t understand them. I can use the command line reasonably well but is there a fairly straightforward way to achieve my goal.

    thanks,
    ralph.

  • #pacman -S xfce4 xfce4-goodies
    [url:1p1jn6sq]https://wiki.archlinux.org/index.php/xfce[/url:1p1jn6sq]
    now log out and then log back in using xfce

    [img:1pt1tebw]http://i59.tinypic.com/33e3r08.png[/img:1pt1tebw]
    [b:1pt1tebw]Don't forget to mark your thread as [SOLVED] [/b:1pt1tebw]

  • Thanks for the quick response Max. I followed your instructions, and I saw the package get downloaded via the terminal. However when I logged back in I was only offered two choices,GNOME and GNOME Classic. No Xfce. Tried logging back in a few times, no Xfce.

  • Hi,

    Hmm…a package may have been missed. Try this:

    sudo pacman -Syy xfce4 xfce4-goodies --needed --noconfirm
    

    Best Regards,

  • Hi, thanks for the added suggestions. I tried the new sudo command (twice) but no luck. Still only the gnome and gnome classic options when I log back in. I’ve added the screen result below, it does say something about an error.

    It’s not a major worry for me, gnome is going very well. In addition to a bit more speed, I thought a more basic DE such as xfce would help me understand antergos better as I would have to learn how to add feature to xfce.

    Let me take this opportunity to say I’m very impressed by antergos, no major issues so far and it’s running well on my machine.

    Thanks,

    ralph.

    warning: ristretto-0.6.3-4 is up to date – skipping
    resolving dependencies…
    looking for inter-conflicts…

    Packages (20): libkeybinder2-0.3.0-2 lsof-4.87-2 parted-3.2-1
    sg3_utils-1.39-1 udisks-1.0.5-1 vte-0.28.2-4
    xorg-xinit-1.3.3-4 gtk2-xfce-engine-3.0.1-2
    gtk3-xfce-engine-3.0.1-2 thunar-volman-0.8.0-2

    tumbler-0.1.30-1 xfce4-appfinder-4.10.1-1 xfce4-mixer-4.11.0-1
    xfce4-power-manager-1.2.0.212.g75107db-1 xfce4-session-4.10.1-3
    xfce4-settings-4.10.1-1 xfce4-terminal-0.6.3-1
    xfdesktop-4.10.2-2 xfwm4-4.10.1-1 xfwm4-themes-4.10.0-2

    Total Installed Size: 23.33 MiB

    :: Proceed with installation? [Y/n]
    (20/20) checking keys in keyring [######################] 100%
    (20/20) checking package integrity [######################] 100%
    (20/20) loading package files [######################] 100%
    (20/20) checking for file conflicts [######################] 100%
    error: failed to commit transaction (conflicting files)
    xfce4-session: /etc/xdg/autostart/xscreensaver.desktop exists in filesystem
    Errors occurred, no packages were upgraded.
    [[email protected] ~]$

  • Ah okay, I see the problem now. This should fix it:

    sudo pacman -S xfce4 xfce4-goodies --noconfirm --needed --force
    

    Cheers!

  • Excellent, worked perfectly, thanks Dustin!

Posts 8Views 5849
Log in to reply