• Wifi doesn't work after upgrade


    Hi, I installed Antergos on a 2013 Thinkpad some months ago. Generally kept it up to date but had a big upgrade today, trying to get the upgrade that rolls it over to the Arch servers.

    After upgrading and rebooting, wifi no longer works. My wireless device’s name has been changed to wlan0, whereas before it was wlp3s0. It can scan and try to connect to networks but doesn’t seem to ever connect, tried pinging 8.8.8.8 and even the router address and it says network unreachable.

    Not sure what outputs to paste here to get some help on this. Anyone else’s wifi broken after a recent upgrade? I tried installing and booting the LTS kernel and the problem persists.

  • Here’s the output of iwconfig and iw dev. It acts like it’s connected but nothing works. (network name changed for privacy)

    ag ~ $ iwconfig
    wlan0     IEEE 802.11  ESSID:"MyNetwork"
              Mode:Managed  Frequency:2.462 GHz  Access Point: 54:A0:50:DA:9C:30
              Bit Rate=2 Mb/s   Tx-Power=15 dBm
              Retry short limit:7   RTS thr:off   Fragment thr:off
              Power Management:off
              Link Quality=56/70  Signal level=-54 dBm
              Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
              Tx excessive retries:0  Invalid misc:18   Missed beacon:0
    
    enp0s25   no wireless extensions.
    
    lo        no wireless extensions.
    
    ag ~ $ iw dev
    phy#0
            Interface wlan0
                    ifindex 4
                    wdev 0x2
                    addr a4:4e:31:33:63:24
                    ssid MyNetwork
                    type managed
                    channel 11 (2462 MHz), width: 20 MHz, center1: 2462 MHz
                    txpower 15.00 dBm
    
    
    
  • @vrav Did you try it with the lts kernel? What wireless card is it?

    lspci

  • @vrav said in Wifi doesn't work after upgrade:

    trying to get the upgrade that rolls it over to the Arch servers.

    What upgrade are you talking about to roll it over to Arch? Did they just put one out in the last 6-7 hours? I updated then and it was a couple things.

  • Maybe I was wrong about the upgrade being out yet. I just read that Antergos was shutting down and the post from a week ago said “soon” so I figured it was underway.

    lspci:
    Intel Corporation Centrino Advanced-N 6205 [Taylor Peak] (rev 34)

  • @vrav Do you know if there was an update for this. Did you happen to check the pacman log and see what updates you did get? I know there have been kernels. It might be firmware driver related. Saw this problem a while back with intel iwlwifi and it took a lot to sort it out.

  • @vrav said in Wifi doesn't work after upgrade:

    Intel Corporation Centrino Advanced-N 6205 [Taylor Peak] (rev 34)

    Also did you check that the WIFI button is on?

  • I fixed it. Had to:

    1. Enable IPv6 on my router.
    2. Add the line “IP6=stateless” to my netctl profile in /etc/netctl/.
  • @vrav That’s interesting because some wifi don’t work with ipv6 enabled. Where did you find that info?

  • @ricklinux “journalctl -f” told me “No IPv6 routers available” so I searched around for solutions to that. Eventually I found out about SLAAC. More info here: https://wiki.archlinux.org/index.php/IPv6#Stateless_autoconfiguration_(SLAAC)

  • @vrav Did you also have to change any configuration in the ufw (Firewall)? I have that installed an Antergos during set up.

  • @ricklinux sorry I don’t know. I don’t think I have that installed. But for the record I have not tested this fix on Antergos because I am in the process of wiping the laptop to install Arch and was noticing the same problem with wifi on the live USB boot. And on my desktop running Arch. So I’m not sure if this fix works for Antergos, sorry.

  • @vrav Why are you going install Arch? Antergos is really Arch if you take out Antergos stuff which isn’t that much. They are supposed to be putting out a script to do this shortly anyway. Are you doing it to punish yourself? It’s too much work.

  • @ricklinux haha, yeah, I don’t know, I enjoy it. I just want a clean install. Even if it takes all day and the rest of the weekend to configure, it feels good once it’s done, and I usually learn a few new things along the way.

  • @vrav See if the kernel loaded a driver for the card.

    What desktop are you going to install? This is the part that i find most problematic as i can’t get it to look the way i want it to. I like Cinnamon desktop but most Cinnamon installs are the old looking ugly icons and themes. I’ve never really taken to KDE as i find it just too much work trying to figure out how to make it look how i want it. I don’t like it’s menu etc. This is kind of the problem as some of the out of the box desktops are not what i want either. But you are right it feels great when you get it done and you usually learn something new along the way.

  • @ricklinux just an update, I tried this fix on my Antergos install and it still couldn’t access the internet. Also seemingly it’s not required on the live USB anymore (maybe my router finally reset fully or something). So, that’s why I am installing Arch, because wifi works on it and not on Antergos anymore.

    I don’t actually use a DE. I use i3 as a WM with dmenu to launch apps. I do use some graphical apps like Thunar (file manager) and of course a web browser, graphical text editor, etc. But a simple tiling window manager like i3 keeps me productive. If you try it out, be sure to install i3blocks. It also has system-tray-like support for apps in the bar.

  • @vrav I would like to try i3 but it seems daunting. I wouldn’t know where to start. I’m so used to desktop icons and taskbar but I have seen some and they are using sway. It looks really nice but also a big learning curve.

  • @fernandomaroto So i can install i3 even though i have Cinnamon desktop and start using it?

  • @vrav That’s probably because Antergos isn’t giving any updates anymore? It’s like one of my wifi cards. MX has it load automatically and is the correct driver. Antergos or any other distro doesn’t have it so i have to load another one that makes it work.

wifi151 upgrade81 Posts 23Views 206
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.