• Mate-sensors not working (SOLVED)


    I m getting a no sensors found error on my dell d610 lptop. acpi -t shows correct cpu temp
    here is terminal output
    [[email protected] ~]$ dmesg | grep acpi
    [ 0.000000] ACPI: LAPIC (acpi_id[0x00] lapic_id[0x00] enabled)
    [ 0.000000] ACPI: LAPIC (acpi_id[0x01] lapic_id[0x01] disabled)
    [ 0.000000] ACPI: LAPIC_NMI (acpi_id[0x00] high edge lint[0x1])
    [ 0.000000] ACPI: LAPIC_NMI (acpi_id[0x01] high edge lint[0x1])
    [ 0.080642] acpiphp: ACPI Hot Plug PCI Controller Driver version: 0.5
    [ 0.133190] acpi LNXIOBAY:00: ACPI dock station (docks/bays count: 1)
    [ 0.138123] acpi PNP0C15:00: ACPI dock station (docks/bays count: 2)
    [ 0.146397] acpi PNP0A03:00: _OSC: OS supports [ExtendedConfig ASPM ClockPM Segments MSI]
    [ 0.146405] acpi PNP0A03:00: _OSC failed (AE_NOT_FOUND); disabling ASPM
    [ 0.161589] acpi PNP0A03:00: host bridge window [io 0x0000-0x0cf7] (ignored)
    [ 0.161593] acpi PNP0A03:00: host bridge window [io 0x0d00-0xffff] (ignored)
    [ 0.161597] acpi PNP0A03:00: host bridge window [mem 0x000a0000-0x000bffff] (ignored)
    [ 0.161600] acpi PNP0A03:00: host bridge window [mem 0x000d0000-0x000dffff] (ignored)
    [ 0.161604] acpi PNP0A03:00: host bridge window [mem 0x40000000-0xdfffffff] (ignored)
    [ 0.161607] acpi PNP0A03:00: host bridge window [mem 0xf0007000-0xf0007fff] (ignored)
    [ 0.161611] acpi PNP0A03:00: host bridge window [mem 0xf000c000-0xfebfffff] (ignored)
    [ 0.161614] acpi PNP0A03:00: host bridge window [mem 0xfec10000-0xfed1ffff] (ignored)
    [ 0.161618] acpi PNP0A03:00: host bridge window [mem 0xfee10000-0xffafffff] (ignored)
    [ 10.981208] ACPI: acpi_idle registered with cpuidle
    [ 14.510140] Modules linked in: ptp pps_core ssb hid_generic snd_intel8x0(+) mmc_core snd_ac97_codec pcmcia libphy i915(+) ac97_bus snd_pcm hwmon drm_kms_helper yenta_socket drm pcmcia_rsrc snd_timer lpc_ich snd pcmcia_core soundcore rng_core i2c_algo_bit i2c_core button parport_pc parport irda intel_agp crc_ccitt intel_gtt battery agpgart thermal shpchp tpm_tis tpm video ac acpi_cpufreq processor acpi_call(O) ext4 crc16 mbcache jbd2 usbhid hid sd_mod sr_mod cdrom crc_t10dif crct10dif_common ata_generic pata_acpi ata_piix atkbd libps2 ahci libahci libata scsi_mod ehci_pci uhci_hcd ehci_hcd usbcore usb_common i8042 serio
    [[email protected] ~]$

    [img:1pt1tebw]http://i59.tinypic.com/33e3r08.png[/img:1pt1tebw]
    [b:1pt1tebw]Don't forget to mark your thread as [SOLVED] [/b:1pt1tebw]

  • I m getting a no sensors found error on my dell d610 lptop. acpi -t shows correct cpu temp
    here is terminal output
    [[email protected] ~]$ dmesg | grep acpi
    [ 0.000000] ACPI: LAPIC (acpi_id[0x00] lapic_id[0x00] enabled)
    [ 0.000000] ACPI: LAPIC (acpi_id[0x01] lapic_id[0x01] disabled)
    [ 0.000000] ACPI: LAPIC_NMI (acpi_id[0x00] high edge lint[0x1])
    [ 0.000000] ACPI: LAPIC_NMI (acpi_id[0x01] high edge lint[0x1])
    [ 0.080642] acpiphp: ACPI Hot Plug PCI Controller Driver version: 0.5
    [ 0.133190] acpi LNXIOBAY:00: ACPI dock station (docks/bays count: 1)
    [ 0.138123] acpi PNP0C15:00: ACPI dock station (docks/bays count: 2)
    [ 0.146397] acpi PNP0A03:00: _OSC: OS supports [ExtendedConfig ASPM ClockPM Segments MSI]
    [ 0.146405] acpi PNP0A03:00: _OSC failed (AE_NOT_FOUND); disabling ASPM
    [ 0.161589] acpi PNP0A03:00: host bridge window [io 0x0000-0x0cf7] (ignored)
    [ 0.161593] acpi PNP0A03:00: host bridge window [io 0x0d00-0xffff] (ignored)
    [ 0.161597] acpi PNP0A03:00: host bridge window [mem 0x000a0000-0x000bffff] (ignored)
    [ 0.161600] acpi PNP0A03:00: host bridge window [mem 0x000d0000-0x000dffff] (ignored)
    [ 0.161604] acpi PNP0A03:00: host bridge window [mem 0x40000000-0xdfffffff] (ignored)
    [ 0.161607] acpi PNP0A03:00: host bridge window [mem 0xf0007000-0xf0007fff] (ignored)
    [ 0.161611] acpi PNP0A03:00: host bridge window [mem 0xf000c000-0xfebfffff] (ignored)
    [ 0.161614] acpi PNP0A03:00: host bridge window [mem 0xfec10000-0xfed1ffff] (ignored)
    [ 0.161618] acpi PNP0A03:00: host bridge window [mem 0xfee10000-0xffafffff] (ignored)
    [ 10.981208] ACPI: acpi_idle registered with cpuidle
    [ 14.510140] Modules linked in: ptp pps_core ssb hid_generic snd_intel8x0(+) mmc_core snd_ac97_codec pcmcia libphy i915(+) ac97_bus snd_pcm hwmon drm_kms_helper yenta_socket drm pcmcia_rsrc snd_timer lpc_ich snd pcmcia_core soundcore rng_core i2c_algo_bit i2c_core button parport_pc parport irda intel_agp crc_ccitt intel_gtt battery agpgart thermal shpchp tpm_tis tpm video ac acpi_cpufreq processor acpi_call(O) ext4 crc16 mbcache jbd2 usbhid hid sd_mod sr_mod cdrom crc_t10dif crct10dif_common ata_generic pata_acpi ata_piix atkbd libps2 ahci libahci libata scsi_mod ehci_pci uhci_hcd ehci_hcd usbcore usb_common i8042 serio
    [[email protected] ~]$

    [img:1pt1tebw]http://i59.tinypic.com/33e3r08.png[/img:1pt1tebw]
    [b:1pt1tebw]Don't forget to mark your thread as [SOLVED] [/b:1pt1tebw]

  • Depending on the age of your system, you may need the i8kutils package. It doesnt work well with newer Dell systems. You’ll know if it works by listening to your fan (trust me you’ll know lol). Don’t forget to modprobe -a to enable it.

    Cheers!

  • thanks dustin! it is working now

    [img:1pt1tebw]http://i59.tinypic.com/33e3r08.png[/img:1pt1tebw]
    [b:1pt1tebw]Don't forget to mark your thread as [SOLVED] [/b:1pt1tebw]

  • so hoe do I make the modprobe persistent?

    [img:1pt1tebw]http://i59.tinypic.com/33e3r08.png[/img:1pt1tebw]
    [b:1pt1tebw]Don't forget to mark your thread as [SOLVED] [/b:1pt1tebw]

  • Creat a *.conf file in /etc/modules-load.d with one module per line.

    Cheers!

  • so is the syntax for the config
    modprobe i8k -a

    [img:1pt1tebw]http://i59.tinypic.com/33e3r08.png[/img:1pt1tebw]
    [b:1pt1tebw]Don't forget to mark your thread as [SOLVED] [/b:1pt1tebw]

  • No, only the module name:[code:316xgnm8]i8k[/code:316xgnm8]

  • thank you!! works perfectly now

    [img:1pt1tebw]http://i59.tinypic.com/33e3r08.png[/img:1pt1tebw]
    [b:1pt1tebw]Don't forget to mark your thread as [SOLVED] [/b:1pt1tebw]

Posts 9Views 2108
Log in to reply