• \[SOLVED\] wireless keyboard not working


    i updated today and keyboard works at grub screen. at login it does not and afterlogin it does not. stuck using onscreenboard atm. please help

  • i updated today and keyboard works at grub screen. at login it does not and afterlogin it does not. stuck using onscreenboard atm. please help

  • Are you using GNOME? If so, open up system settings and make sure the correct layout is selected in the keyboard module. If that doesnt work, post the output of:

    setxkbmap -print -verbose 10
    

    You can reference this link for a little more info: [https://wiki.archlinux.org/index.php/Xorg#Keyboard_settings][0]">[https://wiki.archlinux.org/index.php/Xo][1] … d_settings

    [0]: <a href=
    [1]: https://wiki.archlinux.org/index.php/Xo

  • [[email protected] ~]$ setxkbmap -print -verbose 10
    Setting verbose level to 10
    locale is C
    Trying to load rules file ./rules/evdev…
    Trying to load rules file /usr/share/X11/xkb/rules/evdev…
    Success.
    Applied rules from evdev:
    rules: evdev
    model: evdev
    layout: en
    Trying to build keymap using the following components:
    keycodes: evdev+aliases(qwerty)
    types: complete
    compat: complete
    symbols: pc+en+inet(evdev)
    geometry: pc(pc104)
    xkb_keymap {
    xkb_keycodes { include “evdev+aliases(qwerty)” };
    xkb_types { include “complete” };
    xkb_compat { include “complete” };
    xkb_symbols { include “pc+en+inet(evdev)” };
    xkb_geometry { include “pc(pc104)” };
    };

    i could be wrong but it might be bluetooth related ? when i open bluetooth it says disabeled and when i enable it and try to pair keyboard i get nothing. still works at grub and works fine in windows

  • I think you may be right because your actual keyboard mapping looks correct. Bluetooth has always been one of the things that I can never get “just right” but since I rarely use Bluetooth, its not a problem for me. Have you enabled bluetooth through systemd? You should only have to run this command once:

    sudo systemctl enable bluetooth.service
    

    Check this article. It is written for a mouse but the process should be the same.
    [https://wiki.archlinux.org/index.php/Bluetooth_mouse_configuration][0]">[https://wiki.archlinux.org/index.php/Bl][1] … figuration

    [0]: <a href=
    [1]: https://wiki.archlinux.org/index.php/Bl

  • Well i got it working … Visibility had been turned off on my bluetooth. AFter another system update and turning the visibility on it has now discovered the keyboard. It seems when i go to type though there is latency upon initial typing. Is it normal to have to hit a key wait a few seconds then i can start typing or is there some way i can make it initialize during boot that might remove this latency ?

  • Are you using a usb Bluetooth adapter? If so it could be the usb-autosuspend that is causing the delay.

    Try putting this line:
    CONTROL_USB_AUTOSUSPEND=0
    in /etc/laptop-mode/conf.d/usb-autosuspend.conf

    if you don’t have laptop-mode daemon installed then put this line:
    options usbcore autosuspend=1
    in one of these:
    /etc/modprobe.conf
    /etc/modprobe.d/modprobe.conf
    /etc/modprobe.d/options

  • Unfortunately this did not resolve the issue. I used the option to create a /etc/modprobe.conf file and add the line options usbcore autosuspend=1 which is the only line in the file.

    Upon reboot there is still an initial keyboard latency. I also noticed an error when booting. bluetooth timeout error. I can get the exact error if needed. Please continue to assist if you can

  • Okay, I think the first place to start is getting your bluetooth to run normally at boot without errors. What is the make/model of the adapter? Can you post the output of “journalctl -bm” as root and then “journalctl -b” as your personal usr acct?

  • Here it is from the root … apparently this is a mess and I am having several issues
    [url:pmrm7etq]http://pastebin.com/KpVmyQtv[/url:pmrm7etq]

    And here it is from user account
    [url:pmrm7etq]http://pastebin.com/fA7DGr1D[/url:pmrm7etq]

  • It seems the driver for your wireless card is not interacting properly with the kernel. This may be related, but unless your wifi adapter and bluetooth are one and the same I don’t think it is. What is the make/model of your BT adapter? Also have you installed the latest package updates by running:

    sudo pacman -Syu
    

    If you haven’t, go ahead and install all available updates and then restart your system. If that does not fix it send me a copy of your log again but this time maximize the terminal window before running the command.

    sudo journalctl -b
    

    PS> Is your printer working? Try completely removing and then reinstalling it.

    sudo pacman -R hplip-plugin hplip  
    sudo yaourt -S hplip-plugin
    
  • The BT is logitech. The wireless network is USB Tenda (ralink)
    The printer is not currently working but after removing the hplip and cups and reinstalling the hplip from the AUR I cant find my printers usb cable so I’ll have to wait to get that working.
    I did another full update and I am still noticing the typing issue
    also the wireless seems to lag up quite regularly for about 10 - 15 seconds then goes back to normal. So heres a fresh log after the update and reboot without the hplip installed for now.

    [url:d7ur7y0z]http://pastebin.com/xF7huemD[/url:d7ur7y0z]

    Thanx for all the help so far also

  • Yes I expected you would be having some intermittent wifi issues. There is a a bug with the current drivers, I can’t seem to find the link at the moment. Which version of bluez do you have installed? Some people having problems with the latest. Try uninstalling bluez completely. You should not have to connect your keyboard and mouse through gnome at all because the adapter they came with identifies itself as a USB keyboard/Mouse and not BT (or at least it is supposed to). I have a script that will display the current usb related settings. Just download, extract, make it executable, and run it as root. Post the output here…

  • Hello,

    I also faced this type of problem sometime ago. Then i prefer raspberry pi wireless keyboard tutorials and i got proper solution. I think you also prefer this.

    ![raspberry pi wireless keyboard](image url)

    http://www.bestoninternet.com/compute/electronics/wireless-keyboard-raspberry-pi/

Posts 14Views 3150
Log in to reply