• Problems installing yay. Is Antergos repo still functional?


    I tried installing yay this morning and got the following result:

    Installing selected packages...
    
    resolving dependencies...
    looking for conflicting packages...
    Packages (1) yay-9.1.0-1
    Total Download Size: 1.92 MiB
    Total Installed Size: 6.31 MiB
    
    :: Retrieving packages...
    
    error: failed retrieving file 'yay-9.1.0-1-x86_64.pkg.tar.xz' from mirrors.antergos.com : The requested URL returned error: 404 
    (1/1) yay-9.1.0-1-x86_64 
    checking keys in keyring
    checking package integrity
    error: yay: signature from "Antergos Build Server (Automated Package Build System) " is unknown trust 
    
    :: File /var/cache/pacman/pkg/yay-9.1.0-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
    
    error: failed to commit transaction (invalid or corrupted package (PGP signature)) 
    Errors occurred, no packages were upgraded.
    
    Command finished with errors!
    

    However if i go checking mirrors.antergos.com it’s still live, moreover I was able to locate yay in there but apparently the available version is newer than what pacman is offering:

    alt text

    Any idea what’s going on?

  • @nate_x
    Antergos repo is becoming unstable. I guess you could use AUR instead. And either move the [antergos] repo definition in file /etc/pacman.conf to end of that file, or just remove it.

    Note that yay can be installed using pamac-manager, but you need to enable AUR support (in pamac-manager) since it is not enabled by default.

  • Thanks. I had some issues using pamac-manager some while ago and switched to octopi. If i disable antergos repository in octopi, I can indeed find and install yay as an aur package.

    I think I’ll leave antergos repository enabled for now just to help out debugging for those who will start facing issues in the following days/weeks and to help the people working on a solution to phase-out antergos repos.

  • @nate_x
    BTW, I just added yay into my repo: https://github.com/manuel-192/antergos-mup

    If you want to use this repo, add it before [antergos] definition in /etc/pacman.conf.
    There are all instructions behind the link above.

  • Not to hijack this thread at all, but I have almost all of the Antergos’ repo uploaded to my own repository for Reborn OS if you want to just use that for a bit until you find something better. If this interests you, simply add the following lines to your pacman.conf file:

    [Reborn-OS]
    Include = /etc/pacman.d/reborn-mirrorlist
    

    And then download our mirrorlist using the below command, placing it in the /etc/pacman/ directory.

    wget https://gitlab.com/RebornOS/RebornOS/raw/reverted/airootfs/etc/reborn-mirrorlist
    
  • @manuel My yay also failed to commit transaction and invalid or corrupted package thing.

    What is this yogurt program good for?

  • @archie7
    You could try refreshing pacman keys:

    su
    pacman -Sc
    pacman-key --init
    pacman-key --populate archlinux antergos
    pacman-key --refresh-keys
    

    This gives more info about AUR helpers: https://wiki.archlinux.org/index.php/AUR_helpers

  • @manuel I tried this and then sudo pacman -Syu, but the same error came up about the corrupted or broken yay thing.

    Maybe this will be fixed later in a update by Antergos.

    I cannot install AbiWord or 0 A.D while this yay thing doesn’t work.

  • Hey @archie7 did you try my solution in the third post in this thread? simply disable antergos repository until you install yay. It will be installed from AUR.

  • Yeah, that will work. The pamac-manager can also install AUR packages after enabling it.

  • @nate_x I am using the package manager that came with Antergos, I don’t know what it is called.

    I can see the Antergos yay that’s giving the problem. Can I remove that one and install the yay-bin or yay-git from the AUR?

    I need that yay thing to install AbiWord and 0 A.D.

  • @archie7

    You don’t necessarily need yay at all. And those packages are not from AUR but official Arch packages.
    So you should be able to install them with pamac-manager (the GUI package manager).
    Also pacman works, see man pacman.

    If you need to install AUR packages, pamac-manager needs just to be configured to support that.

installing130 live59 repo18 yay4 Posts 12Views 637
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.