• How can I prevent bluetooth from turning on at boot?


    Hello,

    I am trying to prevent the bluetooth radio from turning on (being enabled) at boot time (if I just log into my machine for the first time). I do not want to disable the bluetooth service. I would just like to have bluetooth radio turned off and be able to turn it back on when I need it.

    According to the Arch wiki, this should be the default behavior, but for whatever reason, it turns on whenever I log in. I’ve tried setting AutoEnable to false in /etc/bluetooth/main.conf, but no luck there either.

    Any help would be greatly appreciated! TIA!

    Thanks,
    Asif

  • @brownkid84 You could try masking the service. This will stop it from starting on boot. You can enable it at any time using unmask command. You can try and see if it works for you.

    systemctl mask bluetooth.service

    systemctl unmask bluetooth.service

boot320 bluetooth55 turning8 prevent7 Posts 2Views 47
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.