• Nvidia-dkms, Conky & nvidia-settings/control panel


    @joekamprad
    I’m sry for calling at you specifically, but have a few questions, and you may or may not recall recent issues I’ve suffered.

    I just got done installing my new gt740 4gb, an upgrade from gt730 4gb
    the main difference being triple simultaneous monitor support.

    Nvidia GT740 4GB

    Since I started using the dkms for nvidia, I’ve come to realize the control panel gui is gone from the kde menu, I’ve typed it in a console, it doesn’t say it’s not there but doesn’t show.

    1st question-
    Would a bad video card cause issues in other parts of the computer as a whole?
    ie, the usb issue you saw in one of my journal logs?
    I ask bc things seem to run alot faster atm!!! but have not plugged my bay device back in yet, I also but in a 400w power supply per minimum of gt740, my last power supply was 380w

    2nd question-
    My conky for nvidia info stopped working long ago using dkms & gt730 which used to work.
    ie

     nVidia GeForce GT 740 4GB
     | + Driver Version                 ${texeci 1200 nvidia-settings -tq NVIDIADriverVersion | awk 'NR==1{print $1}'}
     | + GPU Freq                       ${nvidia gpufreq}-Mhz
     | + Mem Freq                      ${nvidia memfreq}-Mhz
     | + GPU                                ${nvidia temp}ºC
     | + Threshhold                    ${nvidia threshold}ºC
     | + OpenGL image quality        ${nvidia imagequality}
    

    It would seem conky-nvidia will not install through pamac…
    gives

    conflicting files:
    libxnvctrl: /usr/include/NVCtrl/NVCtrl.h already exists in filesystem
    libxnvctrl: /usr/include/NVCtrl/NVCtrlLib.h already exists in filesystem
    libxnvctrl: /usr/include/NVCtrl/nv_control.h already exists in filesystem
    libxnvctrl: /usr/lib/libXNVCtrl.a already exists in filesystem
    libxnvctrl: /usr/lib/libXNVCtrl.so already exists in filesystem
    libxnvctrl: /usr/lib/libXNVCtrl.so.0 already exists in filesystem
    libxnvctrl: /usr/lib/libXNVCtrl.so.0.0.0 already exists in filesystem
    

    This not sure why it won’t remove and replace, but can’t figure out why gui settings for nvidia won’t show so I thought they might be related?
    I didn’t want to try through console yet as might be an issue.

    OH…LMAO sort of…
    nvidia-390xx-settings 390.116-1 through pamac says…
    build date: 12/31/1969
    install date: 12/31/1969
    ??? - yet system time & date are correct

    I better stop there, as that might be a flag lol

  • @Firespray said in Nvidia-dkms, Conky & nvidia-settings/control panel:

    nvidia-390xx-settings

    This is only for nvidia-390xx packages, you will need nvidia-settings installed as You are using latest drivers.

    For showing info about GPU under KDE i would search for a plasma-widget.

  • my apologies, I misspoke about the nvidia-390xx-settings.

    I did actually mean nvidia-settings, but was having issues with it.
    I couldn’t re-install because it said the files were there, but couldn’t uninstall because installer could not find it…

    Yesterday, I uninstalled all the drivers, got back to the nvidia-settings part, same thing, so I force installed.

    sudo pacman -S nvidia-settings --force
    

    After doing this I got the nVidia control panel back but I noticed all this to start with, because of conky not working, specifically these.

    ${nvidia membwutil}
    ${nvidia gpufreq}
    ${nvidia memfreq}
    ${nvidia temp}
    ${nvidia threshold}
    ${nvidia imagequality}
    

    After alot of searching I found

    nvidia-settings -q all
    

    and a conky example

    ${texeci 10 nvidia-settings -q [gpu:0]/TotalDedicatedGPUMemory -t}
    ${texeci 10 nvidia-settings -q [gpu:0]/UsedDedicatedGPUMemory -t}
    

    From here I found
    a new way to write conky, but today I came home had updates…reboot and come back and the original stuff started working again…

    So here is one question…
    How to find out what just was updated in Antergos after running pamac gui?

    It all works now…so if anyone looking for one stop nVidia Conky,
    Here is the info with multiple ways to get it ☺ .
    conky image

    # nvidia-settings -q all     nvidia-settings -q all  > nvidia-settings.txt
     ${alignc}${color orange}nVidia GeForce GT 740 4GB${color 46a4ff}
     | + Bus Type              ${goto 180}${color orange}PCI Express x16 Gen3${color 46a4ff}
     | + Driver Version        ${goto 180}${color orange}${texeci 1200 nvidia-settings -tq NVIDIADriverVersion | awk 'NR==1{print $1}'}${color 46a4ff}
     | + GPU Total Memory      ${goto 180}${color orange}${texeci 10 nvidia-settings -q [gpu:0]/TotalDedicatedGPUMemory -t}${color white}MB${color 46a4ff}
     | + Vram MB Total Usage   ${goto 180}${color orange}${texeci 10 nvidia-settings -q [gpu:0]/UsedDedicatedGPUMemory -t}${color white}MB${color 46a4ff}
     | + Vram % Total Usage    ${goto 180}${color orange}${nvidia membwutil}${color white}%${color 46a4ff}
     | + GPU Frequency         ${goto 180}${color orange}${texeci 1200 nvidia-settings -q [gpu:0]/GPUCurrentClockFreqs -t}${color white}Mhz${color 46a4ff}
     | + GPU Freq              ${goto 180}${color orange}${nvidia gpufreq}${color white}Mhz${color 46a4ff}
     | + Mem Freq              ${goto 180}${color orange}${nvidia memfreq}${color white}Mhz${color 46a4ff}
     | + GPU Temp              ${goto 180}${color orange}${nvidia temp}${color white}ºC${color 46a4ff}
     | + GPU Temp              ${goto 180}${color orange}${execi 10 nvidia-settings -q gpucoretemp -t | awk 'NR==1{print $1}'}${color white}°C${color 46a4ff}
    #This awk does the same    ${goto 180}${color orange}${execi 10 nvidia-settings -q gpucoretemp -t | awk 'NR>1{exit}{print $1}'}${color white}°C${color 46a4ff}
     | + Threshhold            ${goto 180}${color orange}${nvidia threshold}${color white}ºC${color 46a4ff}
     | + OpenGL image quality  ${goto 180}${color orange}${nvidia imagequality}${color 46a4ff}
     | + GPU Fan Speed         ${goto 180}${color orange}${execi 10 nvidia-settings -q [fan:0]/GPUCurrentFanSpeed -t}${color white}%${color 46a4ff}
    

    All Conkys
    alt text

panel37 conky14 nvidia-dkms4 Posts 3Views 119
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.