• Cannot boot into new linux 5.1.2.arch1-1


    Anyone not being able to boot after updating to the new linux 5.1.2.arch1-1? All I see is a blanking cursor.

  • Are you running NVIDIA 340xx drivers by any chance? If so, then that’s the culprite and not the updated Linux 5.1.2 kernel. I’ve tried with both NVIDIA-340xx and the dkms version, but both show the same error, with Nouveau the updated kernel boots. (Though for my machine that isn’t an option, because visuals are laggy. LTS kernel boots fine with the Nvidia-340xx(-dkms or lts version) driver.

  • @Bryanpwo

    Yes, I use NVIDIA-340xx!

    Unfortunately I did not have time in the morning to investigate thoroughly the issue, I just downgraded the newly updated linux, nvidia, and intel-ucode (as I understood, the linux 5.1.2 incorporates the new Intel microcodes to fix the new Zombieload/MDS vulnerability). However, somebody posted this last night:

    https://bugs.archlinux.org/task/62644?project=1&order=lastedit&sort=desc

    At least two people already reported having this issue. From what I understand, the issue is indeed with the linux 5.1.2 but related to NVIDIA-340xx and lightdm. Somebody even posted a patch for the linux kernel but I do not know how to apply it. I hope the issue will be resolved in the next linux kernel.

  • nvidia-340xx-dkms may will be able to build working modules for all installed kernels…

  • @joekamprad
    I’m using the dkms version and it doesn’t work either.

    @new2antrgs
    I didn’t research the problem, just assumed the nvidia driver was the problem after my findings, so thanks for the info.

  • @joekamprad, @Bryanpwo

    Does anyone know how to apply the “kernel-5.1.patch” from the link I have given before? I think you would have to compile your own kernel from git, but this is a too advanced topic for me at the moment. I think it makes sense to wait for a new kernel.

  • I do support one device with a legacy nvidia gpu, but i do configure ut to make use of nouveau shipped inside kernel itself not nvidia prop and xf86-video packages

  • Also, as @Bryanpwo already mentioned, you could use the LTS kernel until they fix the default kernel.

  • I have seen this morning that new nvidia drivers are available (nvidia-340xx-340.107-83, the problems occured yesterday with the -82 version), I tried, and it now works!

    @manuel : thank you for the suggestion, but I thought to better wait a few days before installing the LTS-version, and now it’s solved.

    @joekamprad : I had problems a few months ago with nouveau, that’s why I had to use the nvidia drivers.

    @Bryanpwo : how did you switch between nvidia and nouveau? I installed nvidia drivers with “nvidia-installer”, which has an option to restore nouveau. But after restoring nouveau, how do you switch again to nvidia?

  • @new2antrgs
    I think nvidia-installer uses blacklisting to enable or disable nouveau. Not sure where but /etc/modprobe.d may contain a file for it.

  • @new2antrgs
    ith the antergos nvidia-installer it’s easy to switch, just just type in the terminal sudo nvidia-installer -n, then reboot and you’re on nouveau.

boot321 5.1.2.arch1-11 Posts 11Views 327
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.