• Wireless adaptor no longer detected after update and reboot

    I updated my computer and rebooted and now my computer doesn’t detect my wireless adapter.

    I last updated my computer last night so I’m thinking it was one of the new packages that got updated this morning that caused the problem. There was a big KDE update so it may have been one of those.

    The wireless adapter that I use is the Alfa AWUS036ACH and it connects via USB. I’m not sure how to further diagnose and/or fix it.

    I have tried the following;
    My other USB devices still work and I’ve tried plugging the adapter into USB ports other devices were using therefore I don’t think it’s a USB issue.
    The wireless adapter works when plugged into another computer (Windows 10) therefore I don’t think it’s the adapter’s issue.

    Is there a way to rollback to yesterday to see if one of the update packages did this? Is there another way to check if the computer is seeing the wireless adapter when it gets plugged in?

    All help is appreciated. Thank you

  • @TenThousand
    Today also the kernel changed, package linux. That may well cause the issue. So you may want to try the LTS kernel:

    sudo pacman -S --needed linux-lts linux-lts-headers

    and then reboot to the LTS kernel (it is in the submenu of the boot menu).

    There is also the package downgrade, but I wouldn’t recommend using it for the kernel because it may cause other even more serious issues. If you use it, note that it is only a very temporary workaround.

  • @manuel
    Oh I didn’t notice that the kernel changed. That makes more sense. Thank you very much for your help.
    If going to the lts kernel messes my computer up more than this wireless issue what is the way to go back to the latest kernel? There is a way to switch between kernels right?

  • @TenThousand
    Yes, the boot menu gets you back to either kernel.
    Installing the LTS kernel simply installs those new packages without disturbing other packages.

  • @manuel Thank you for your help. I installed the L:TS kernel and initially it didn’t give me the boot choice but I found out that the grub file needed to be regenerated. And now I can boot with the LTS Kernel and keep my wireless.

    Regenerate Grub file command for anyone else with this issue.
    sudo grub-mkconfig -o /boot/grub/grub.cfg

  • @TenThousand
    Great! And sorry about the grub regeneration, I often seem to forget to mention that…

  • @manuel said in Wireless adaptor no longer detected after update and reboot:

    the grub regeneration, I often seem to forget to mention that…

    that’s an Arch thing and in my opinion, could be automatic … and yes may one not using grub, but this can be handled easily…

  • @joekamprad
    There could be a pacman hook to regenerate grub when kernel is installed or updated. But this is a subject for a new thread…

  • I created a new thread for automatically updating grub:

wireless38 longer20 detected17 adaptor2 Posts 9Views 80
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.