• Brother DCP-7030 Printer Scanner

    Hello all. My Brother DCP-7030 Printer / Scanner is “seen” by the system, at least in name only as a text printer, but even then doesn’t respond in any way. I’m running an AMD FX6300, 24GB Ram, GeForce GTX 960, Gigabyte board, if any of that matters. My Linux skills are very rusty and my Antergos (anything Arch) is nil. I installed, via Yay, brother-dcp7030-2.0.2-4 and all appeared to go well (no flags, optional dependencies installed) but nothing has changed. System says the same thing (text only, ready) but nothing. Printer sleeping soundly. I’ve always had problems with printers in linux. Once, I got it to work in a past version of Mint, but that was just a one-off it seems! I’m probably just being stupid, but can someone please help??! Thanks ahead of time. Cheers!

  • You will need to configure cups to use the installed driver. Use cups browser interface via url: http://localhost:631
    Or system-config-printer tool.

    Check if printer service is running feom terminal:

    systemctl status org.cups.cupsd.service
  • @joekamprad Thanks for the assistance, this is weird. When I did your check the msg “Unit org.cups.cuspsd.service could not be found.” When I look in localhost like you said (thanks, never knew!!) I see:

    Showing 1 of 1 printer.

    Queue Name Description Location Make and Model Status
    DCP-7030 DCP-7030 Generic Text-Only Printer Idle

    I don’t know what to do. Feels like the old days when you had to have specific printers only to use with linux. (My past goes back to COBOL on punch, IBM300 series main to turbo pascal with inline asm.)

  • may you where having a typo ?

    systemctl status org.cups.cupsd.service
    ● org.cups.cupsd.service - CUPS Scheduler
       Loaded: loaded (/usr/lib/systemd/system/org.cups.cupsd.service; enabled; vendor preset: dis>
       Active: active (running) since Sat 2019-05-11 10:42:01 CEST; 37min ago
         Docs: man:cupsd(8)
     Main PID: 558 (cupsd)
       Status: "Scheduler is running..."
        Tasks: 8 (limit: 4915)
       Memory: 218.3M
       CGroup: /system.slice/org.cups.cupsd.service

    cups must be running to use printer…

    if cups is really not installed i would first uninstall the brother-dcp7030-2.0.2-4 AUR package, install cups and then reinstall the driver package:

    sudo pacman -R brother-dcp7030
    sudo pacman -S cups system-config-printer
    sudo systemctl start org.cups.cupsd.service
    sudo systemctl enable org.cups.cupsd.service
    sudo pacman -S brother-dcp7030

    if it is a network printer (connected over Lan or Wireless) you will need avahi also:

    sudo pacman -S avahi
    sudo systemctl start avahi-daemon.service
    sudo systemctl enable avahi-daemon.service
  • Thank you again. The uninstall of brother went ok, but:

    checking dependencies…

    Packages (1) brother-dcp7030-2.0.2-4

    Total Removed Size: 0.21 MiB

    :: Do you want to remove these packages? [Y/n] y
    :: Processing package changes…
    (1/1) removing brother-dcp7030 [######################] 100%
    :: Running post-transaction hooks…
    (1/1) Arming ConditionNeedsUpdate…
    [[email protected] ~]$ sudo pacman -S cups system-config-printers
    warning: cups-2.2.11-2 is up to date – reinstalling
    error: target not found: system-config-printers

    Now I didn’t expect that!! However, I have no clue what to do about it! I’ve hated printers since I was a field tech!

  • sudo pacman -S cups system-config-printer

    not system-config-printers 😬

  • oh, no problem! I really appreciate the help. All went well with the installs as you outlined, but still no go. No errors this time like above, but the printer comes up in settings, just as a generic text only printer. Even this would suckingly be ok, but no go. Send something, and the printer still sleeps.

    After a status check:

    [[email protected] ~]$ sudo systemctl status org.cups.cupsd.service
    ● org.cups.cupsd.service - CUPS Scheduler
    Loaded: loaded (/usr/lib/systemd/system/org.cups.cupsd.service; enabled; ven>
    Active: active (running) since Fri 2019-05-10 12:39:12 EDT; 1 day 5h ago
    Docs: man:cupsd(8)
    Main PID: 1152 (cupsd)
    Status: “Scheduler is running…”
    Tasks: 2 (limit: 4915)
    Memory: 37.0M
    CGroup: /system.slice/org.cups.cupsd.service
    ├─ 1152 /usr/bin/cupsd -l
    └─22729 /usr/lib/cups/notifier/dbus dbus://

    May 10 12:39:09 jdf908ws systemd[1]: Starting CUPS Scheduler…
    May 10 12:39:12 jdf908ws systemd[1]: Started CUPS Scheduler.

    Oh well. Thanks for all your help anyways, I have kept the data in my google keep for the future. I’ll just have to do without printer and scanner as *nix normal (with me) and maybe VM a copy of windblows for printing.


  • as i mention before… you need to change the driver in settings to use the installed driver from brother-dcp7030… you can use the webinterface or the now installed tool to do so…(system-config-printer) what looks like this:
    Bildschirmfoto vom 2019-05-12 00-15-03.png
    it will search for the driver and will find the one installed, you may unlock and +Add a new printer to do so.

  • Yes, thank you, finally the printer part works! For some reason nothing happened until I decided to reboot (even though no updates were pending). Now magically it does. Your god-like powers are bowed to! :]

    One final question: Do you know how I can access the scanner?

  • @lk-stone

    One final question: Do you know how I can access the scanner?

    According to the Brother web site, your DCP-7030 uses the brscan3 scanner driver. So you need to go to the Arch Linux AUR and download the PKGBUILD and do a makepkg command to install it. Or if you have the AUR enabled in paman, you can install it from there. Notice in the AUR there are the following, brscan2 brscan3 brscan4 and brscan5. The older the printer, the lower the suffix number will be. You might want to double check on the brother web site that brscan3 is the correct one for your printer/scanner.

    When the scanner driver is installed, it should instruct you to as root enter a line similar to the following:
    brsaneconfig3 -a name=“Brother” model=“DCP7030” ip=“193.168.0.xxx
    When you install the scanner driver, it SHOULD give you the command format so look for it. If your printer is USB connected, I THINK but cannot guarantee that you just omit the IP portion.

    EDIT: Oops, according to this Brother Web page, you only need to enter the brsaneconfigX command for network printers.

    For Gnome, download “Simple Scan” from the Antergos repositories and it should work a treat. For other DE’s you might have to find an alternative to “Simple Scan”. Xsane will work but is not as user friendly as Simple Scan.

  • @pudge said in Brother DCP-7030 Printer Scanner:

    For Gnome, download “Simple Scan” from the Antergos repositories

    simple-scan is on Archlinux/Community

  • No device detected as far as the scanner goes, but printer still works!! <grin>

  • isnt the sane brother scanner driver brscan(x) in the aur?

  • @ringo32
    Yes, brscanX (X=2…5) exist in AUR.

  • Hey thanks! I don’t know how you people find some of this stuff. First I only knew how to lookup by cmd yay and then try to choose the best. Now i’ve found the actual website for the AUR which is nice, but anything I looked at in no way pointed to brscan! Since my unit is a DCP-7030, which version would be best to use? And is there an easier way to find and install from AUR? I tried converting a .deb to arch with debtap once. Once. I just always hope I find the right one in cmd line yay and if not oh well.

  • I installed, via yay, brscan3. At the end it asked for sudo pw, so cool. Finished install, but no other instructions. ( by the way, how do you activate AUR in pacman? And is there a gui for pacman? )

    Simplescan saw the scanner this time, but on click said it couldn’t connect to scanner.

    I really appreciate your help, all of you!

  • @lk-stone
    To install a package from AUR there are lots of options.
    But the easiest probably are pamac-manager and yay.
    The pamac-manager has a GUI, and it has support for AUR apps, but AUR support is not enabled by default.

    With yay you can install with command

    yay -S appname

    Web search is a good way to get info. Great places are e.g. Antergos and Arch wikis.

  • @lk-stone said in Brother DCP-7030 Printer Scanner:

    by the way, how do you activate AUR in pacman? And is there a gui for pacman? )

    pacman itself can not handle building packages from AUR, it handles only packages itself.

    But there is pamac GUI already installed default at Antergos.

    If you are using GNOME Desktop you may only do not see it.

    You can enable pamac notification over gnome-tweak-tool
    Bildschirmfoto vom 2019-05-13 19-20-33.png
    pamac can handle both packages and AUR builds, also searching and updating for AUR builds, you will need to enable this (if you do not already enable AUR support on initial install)
    Bildschirmfoto vom 2019-05-13 19-21-46.png

  • You all are being so helpful. Half my problem is not knowing what I’m looking for, or what specifically to google. I now have pacman enabled in the package manager. For some reason, the front end looked different before and hard to see what was happening, so now I can manage packages better without bothering anyone! (you should see the size of my search history for my system not recognizing dvd’s!}

    Package manager shows both brscan3 and driver installed, but I still can’t connect to the scanner, and when I try to configure printer via the webpage, even when I put in my admin pw, it says forbidden. I’m obviously missing a way to initialize the brscan, but google searches have put me way down so many rabbit holes!

  • yay -S brscan-skey 
    brscan-skey  -l
printer55 brother22 scanner6 dcp-70301 Posts 21Views 133
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.