• Touchpad clicks (both left and right) not working...

    Hey Guys

    I just noticed today that both the left and right clicks on my touchpad are not working. I can “tap to click”, but physically clicking the touchpad like a mouse is not working.

    I normally use a mouse with my laptop and only resort to using the actual touchpad when I forced to (I find it annoying and cumbersome).

    However it’s kind of bugging me that the physical clicks aren’t working, especially since I they worked the last time I used the touchpad. This was maybe several months ago, and I haven’t changed anything. In fact today was the first time I ever even looked at the touchpad setttings when I discovered clicking wasn’t working.

    I’m using an Acer Swift 3, with KDE.

    Anyone have any ideas?


  • @mattb66 Have you checked the KDE settings turn on mouse emulation?


  • @ricklinux Yeah I have tried turning those both off and and on and it doesn’t seem to matter…Although my settings look slightly different:


  • @mattb66 That is just a generic picture from a KDE site. Corners say no action? That’s where the right and left clicks are. What settings does it have there? Or did you try them? Also what is under enable disable touch pad? I don’t use KDE so im just asking. Do you know if the hardware is a synaptics touch pad? See what the hardware is as there are so many different touch pads.

    lspci -vv

  • Hi @ricklinux

    Thanks for replying.

    Yeah in the “corners” drop-down menus it says “left button”, “middle button”, and “right button”, but those are just for the “simulated” clicks (i.e. tapping the touchpad in the corners simulates a click). The ACTUAL clicking of the touchpad (in the bottom left and right corners) still doesn’t work no matter what I set them to…

    edit: The “corners” menus. Setting these just enables taps (i.e. simulated clicks) for each of the touchpad corner areas.


    Here is what is under the Enable/Disable touchpad tab:


    Typing lspci -vv didn’t bring up anything of interest (I think), but typing:
    cat /proc/bus/input/devices

    gives this:

    I: Bus=0018 Vendor=06cb Product=7db7 Version=0100
    N: Name=“SYNA7DB5:00 06CB:7DB7 Touchpad”
    P: Phys=i2c-SYNA7DB5:00
    S: Sysfs=/devices/pci0000:00/0000:00:15.1/i2c_designware.1/i2c-2/i2c-SYNA7DB5:00/0018:06CB:7DB7.0005/input/input18
    U: Uniq=
    H: Handlers=event4 mouse1
    B: PROP=5
    B: EV=1b
    B: KEY=e520 10000 0 0 0 0
    B: ABS=2e0800000000003
    B: MSC=20

    What do you think?


  • @mattb66 It must be a Synaptics touch pad. I can only suggest reading up on libinput as supposedly synaptics drivers aren’t used anymore on Arch. Libinput page: https://wiki.archlinux.org/index.php/Libinput


    You could also try libinput-gestures from AUR

touchpad55 working10 left8 clicks4 Posts 6Views 80
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.