• Stuttering with multiple screens


    I’ve had this problem for a long time and I couldn’t find a solution. Games and videos will stutter whenever I use multiple screens. This problem happens on all DEs, on other distros, regardless of compositor, regardless of the game being fullscreen or windowed, regardless of resolutions or refresh rates. I use the nvidia proprietary drivers on my gtx 1070. On particularly bad example is Dark Souls 2: SotfS, with proton and steam. It will stutter at regular intervals, even the mouse cursor will stutter anywhere on screens. The problem only goes away when I go back to only one screen. Is it the drivers? Or X? Of course I can’t simply switch from one screen to multiple or vice versa easily as XFCE gets confused and buggy. I also tried multiple separate X screens.

    So I have some questions: Would it work better with an AMD card? Am I a rare breed that like multiple screens? Has anybody else delved into this problem?

  • @patlefort
    Note that I don’t have many monitors so can’t confirm any of the stuff of this posting will help.

    Did you already try using the nvidia-dkms package? For some problems it helps.
    To install nvidia-dkms, uninstall nvidia-lts first if you have it. Then:

    sudo pacman -S --needed nvidia-dkms linux-lts-headers linux-headers
    

    To give us more info, have you already tried anything (like kernel parameters, blacklisting, nvidia settings etc.) to solve the issue?
    Could you also show the output of the following command (inxi is an AUR package):

    inxi -F
    

    This might also help: https://wiki.archlinux.org/index.php/NVIDIA/Troubleshooting#Multi-monitor

  • @manuel

    inxi output:

    System:    Host: ordi-pat Kernel: 5.0.10-arch1-1-ARCH x86_64 bits: 64 Desktop: Xfce 4.13.3 Distro: Antergos Linux 
    Machine:   Type: Desktop Mobo: ASUSTeK model: ROG ZENITH EXTREME v: Rev 1.xx serial: <root required> UEFI: American Megatrends 
               v: 1701 date: 01/09/2019 
    CPU:       Topology: 16-Core (2-Die) model: AMD Ryzen Threadripper 1950X bits: 64 type: MT MCP MCM L2 cache: 8192 KiB 
               Speed: 3720 MHz min/max: 2200/3400 MHz Core speeds (MHz): 1: 3720 2: 2076 3: 2348 4: 2059 5: 2088 6: 2071 7: 2154 
               8: 2189 9: 2694 10: 2078 11: 2312 12: 3148 13: 2292 14: 2101 15: 2448 16: 2283 17: 2216 18: 2763 19: 2132 20: 2327 
               21: 2060 22: 1980 23: 2022 24: 3036 25: 2091 26: 2167 27: 2043 28: 2742 29: 2381 30: 2126 31: 2677 32: 1966 
    Graphics:  Device-1: NVIDIA GP104 [GeForce GTX 1070] driver: nvidia v: 418.56 
               Display: x11 server: X.Org 1.20.4 driver: nvidia resolution: 2560x1440~144Hz 
               OpenGL: renderer: GeForce GTX 1070/PCIe/SSE2 v: 4.6.0 NVIDIA 418.56 
    Audio:     Device-1: Advanced Micro Devices [AMD] Family 17h HD Audio driver: snd_hda_intel 
               Device-2: NVIDIA GP104 High Definition Audio driver: snd_hda_intel 
               Sound Server: ALSA v: k5.0.10-arch1-1-ARCH 
    Network:   Device-1: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter driver: ath10k_pci 
               IF: wlp3s0 state: down mac: 6a:e9:b6:91:67:df 
               Device-2: Wilocity Wil6200 802.11ad Wireless Network Adapter driver: wil6210 
               IF: wlp4s0 state: down mac: e6:81:1b:81:7d:91 
               Device-3: Intel I211 Gigabit Network driver: igb 
               IF: enp5s0 state: up speed: 1000 Mbps duplex: full mac: 10:7b:44:91:34:28 
               Device-4: Aquantia AQC107 NBase-T/IEEE 802.3bz Ethernet [AQtion] driver: atlantic 
               IF: enp7s0 state: down mac: 10:7b:44:90:bc:ed 
    Drives:    Local Storage: total: 19.21 TiB used: 10.84 TiB (56.4%) 
               ID-1: /dev/nvme0n1 vendor: Crucial model: CT1000P1SSD8 size: 931.51 GiB 
               ID-2: /dev/nvme1n1 vendor: Western Digital model: WDS512G1X0C-00ENX0 size: 476.94 GiB 
               ID-3: /dev/sda vendor: Western Digital model: WD10EZEX-75WN4A0 size: 931.51 GiB 
               ID-4: /dev/sdb type: USB vendor: JMicron model: Tech size: 238.47 GiB 
               ID-5: /dev/sdc vendor: Seagate model: ST4000DM000-1F2168 size: 3.64 TiB 
               ID-6: /dev/sdd type: USB vendor: Western Digital model: WD40EZRZ-00GXCB0 size: 3.64 TiB 
               ID-7: /dev/sde type: USB vendor: Western Digital model: WD40EZRZ-75GXCB0 size: 3.64 TiB 
               ID-8: /dev/sdf vendor: Western Digital model: WD20EARS-00S8B1 size: 1.82 TiB 
               ID-9: /dev/sdg type: USB vendor: Western Digital model: WD40EZRX-00SPEB0 size: 3.64 TiB 
               ID-10: /dev/sdh vendor: Western Digital model: WD5002ABYS-01B1B0 size: 465.76 GiB 
               ID-11: /dev/sdk vendor: OCZ model: AGILITY3 size: 335.35 GiB 
    Partition: ID-1: / size: 127.05 GiB used: 99.18 GiB (78.1%) fs: ext4 dev: /dev/nvme1n1p6 
               ID-2: /boot size: 945.2 MiB used: 56.9 MiB (6.0%) fs: ext4 dev: /dev/nvme1n1p5 
    Sensors:   System Temperatures: cpu: 38.8 C mobo: N/A gpu: nvidia temp: 47 C 
               Fan Speeds (RPM): cpu: 0 gpu: nvidia fan: 0% 
    Info:      Processes: 556 Uptime: 8m Memory: 62.83 GiB used: 3.41 GiB (5.4%) Shell: bash inxi: 3.0.34
    

    I am using the “nvidia” package, which is supposed to be what to use with non-lts kernels. nvidia-dkms is for custom kernels, according to the wiki.
    I tried:

    • Adding nomodeset as kernel parameter.
    • Blacklisting nouveau.
    • Changing my main monitor refresh rate to 60hz to match other 2 screens.
    • Forcing full composition pipeline.
    • Turn on and off vsync.
    • Turning on and off composition in XFCE.
    • Changing primary monitor.
    • Using multiple separate X screens.
    • Other DEs, even other distros like Ubuntu, Fedora. I retested KDE and interestingly the insane constant stuttering I get in DS2 is gone, something must have changed very recently. But it’s still not as smooth as with only one screen for any game.

    AFAIK g-sync simply does not work with multiple screens. To be clear I’m getting stuttering, not tearing. I’m not sure what’s the status of wayland for nvidia, would that make any difference?

  • @patlefort
    Thanks for the info. You have an interesting system with AMD CPU and Nvidia GPU.

    The nvidia-dkms has already helped some people on their systems. Seems that nvidia-dkms is either newer than nvidia, or provides a more compatible result because it is compiled on site. And I’m using nvidia-dkms myself because of some problems a had earlier with nvidia.

    But of course that doesn’t guarantee nvidia-dkms will work in your system. I’d try it anyway. And to be on the safe side, the installer USB drive is good to have available in case of any booting issues.

    A long shot (if you didn’t already) is to try the linux-lts kernel.

    I have no experience about wayland, but there have been several issues reported about it.

    For now I’m out of more ideas, hopefully someone with more experience can help.

  • @patlefort https://wiki.archlinux.org/index.php/NVIDIA/Troubleshooting#Avoid_screen_tearing

    I do not have any problems with nvidia and multimonitors… but i do use xrandr script for lightdm and the “full composition” hack

multiple9 screens5 stuttering2 Posts 5Views 85
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.