• warning: plymouth: local is newer than antergos


    Hello, I am getting this warning on system update. If I try to downgrade plymouth system cant find a dependency.

    Is there any problem with the repos?

    sudo pacman -Su
    :: Starting full system upgrade...
    warning: plymouth: local (0.9.4-4) is newer than antergos (0.9.2.r2031-1)
     there is nothing to do
    
    sudo pacman -Suu
    :: Starting full system upgrade...
    warning: plymouth: downgrading from version 0.9.4-4 to version 0.9.2.r2031-1
    resolving dependencies...
    warning: cannot resolve "plymouth-theme-antergos", a dependency of "plymouth"
    :: The following package cannot be upgraded due to unresolvable dependencies:
          plymouth
    
    :: Do you want to skip the above package for this upgrade? [y/N] n
    error: failed to prepare transaction (could not satisfy dependencies)
    :: unable to satisfy dependency 'plymouth-theme-antergos' required by plymouth
    
    
  • did you ever updated plymouth from aur ?

    you can try just sudo pacman -S plymouth ?

  • @tupingbr do you use plymouth?
    It is not used by default on installed Antergos, we use it for the ISO only.

  • @joekamprad Yes I use plymouth.
    @ringo32 “sudo pacman -S plymouth” have the same problem as “sudo pacman -Suu”:

    $ sudo pacman -S plymouth
    warning: downgrading package plymouth (0.9.4-4 => 0.9.2.r2031-1)
    resolving dependencies...
    warning: cannot resolve "plymouth-theme-antergos", a dependency of "plymouth"
    :: The following package cannot be upgraded due to unresolvable dependencies:
          plymouth
    
    :: Do you want to skip the above package for this upgrade? [y/N] n
    error: failed to prepare transaction (could not satisfy dependencies)
    :: unable to satisfy dependency 'plymouth-theme-antergos' required by plymouth
    
    
  • if you really want to downgrade to the antergos repo plymouth,
    i guess

    sudo pacman -Rdd plymouth && sudo pacman -S plymouth
    

    is the only way to do… it removed plymouth without depency test, after install another plymouth package.
    Your plymouth local basicly newer then the antergos repo.

    sudo pacman -Syu first normal complains about local is newer, is not necesary bad if plymouth works.

  • @tupingbr said in warning: plymouth: local is newer than antergos:

    plymouth-theme-antergos

    is the problem here:

    warning: cannot resolve "plymouth-theme-antergos", a dependency of "plymouth"
    

    It is not on the mirrors anymore.

    pikaur -Ss plymouth
    Searching... [###]
    antergos/plymouth 0.9.2.r2031-1 
        A graphical boot splash screen with kernel mode-setting support    
    aur/plymouth 0.9.4-4 (468, 6.23)
        A graphical boot splash screen with kernel mode-setting support
    

    and Antergos plymouth is outdated (builded 2016)

  • @joekamprad yes, I agree that is the root cause of the problem. But how can it be fixed?
    Package “plymouth-theme-antergos” shouldn’t be on the mirrors?

  • as i say Antergos is using plymouth for the Live ISO and for that there was also plymouth-theme-antergos.
    There was not there to install them on real installed systems… so uninstall it and install version from AUR if you want to run plymouth on installed system.

    sudo pacman -R plymouth-theme-antergos plymouth
    pikaur -S aur/plymouth

  • @joekamprad tried exactly this before. The warning remains, but I have just figured out what is happening.

    I think that every package that I have installed from AUR that has the same name on antergos repo is giving this warning.

    Today there are 2 more packages with same warning (total 3):

     sudo pacman -Su
    :: Starting full system upgrade...
    warning: lightdm-webkit2-greeter: local (2.2.5-2) is newer than antergos (2.2.5-1)
    warning: plymouth: local (0.9.4-4) is newer than antergos (0.9.2.r2031-1)
    warning: qt5-styleplugins: local (5.0.0.20170311-13) is newer than antergos (5.0.0.20170311-11)
     there is nothing to do
    
    

    I have another computer that I installed Arch. I have never got this kind of messages upon updating.

    Thank you for your time. Antergos is easier to install but comparing to pure Arch it is more likely to have some package conflicts due to the fact that comunity aims on pure Arch on the AUR repos… I think it is a fair trade off.

  • Antergos have some latency on development lately, usually, packages should be up to date and usually Antergos repo should only hold packages not available on Arch repositories (what is the issue here for 2 packages, they are available on archrepo and also [outdated] at antergos repo)

warning12 plymouth5 newer3 Posts 10Views 167
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.