• Desktop fails to stay on after updates!


    I can’t get pass login half the time, when the desktop opens then it flashes and become black screen and no command possible, only rebooting with the switch of the computer.
    Same problem with kernel 5.0.9 and 4.19.37 LTS.
    I can open a terminal with ctl-alt-F2 command.

  • @philipc
    Can you login with a TTY? Press Ctrl-Alt-F2 and you should get a TTY terminal.

  • @manuel
    Ok, i will try that, i need to change SSD because now i am on my backup Ubuntu system.

  • @manuel
    I could login normaly into the system on the lts kernel, but there is still this weird flashing of the desktop when it opens, but this time it did’nt go black screen.
    This has been happening since last friday update of X11, i never had this issue before.

  • @philipc Didn’t notice any updates to x11 but there were updates to systemd and also lts kernel since Friday.

  • I get a desktop blackout every second time i reboot, the other time it stays normal.
    That is once i login into the desktop, in my case KDE.

  • @manuel
    Yes i can open a terminal with ctl-alt-F2 command.
    But how i could use this to fix the issue?

  • @philipc
    There are many potential reasons for that strange behavior, e.g. updates to

    • display manager
    • graphics driver
    • kernel
    • etc.

    So, if it is the display manager, you could change it to another: lightdm, sddm or gdm. For example:

    su
    pacman -S --needed sddm
    systemctl disable lightdm
    systemctl enable sddm
    reboot
    

    If it is the graphics driver, we need more info about your graphics and machine. So please install inxi from AUR and show the output of command:

    inxi -Fc0
    
  • I filmed the issue and put it on my Youtube channel.
    Here is the link :
    https://www.youtube.com/watch?v=eF-WYeJAmQ8&feature=youtu.be

  • @philipc
    Interesting video!

    If changing lightdm to sddm doesn’t help, then you could check the /var/log/pacman.log file and see what are the latest updates.
    Then you could try downgrading the latest updated packages one by one to see if any of them is the culprit.
    For downgrading you can use e.g. the downgrade package and program.

  • @manuel
    Ok, i will try SDDM and then i’l come back for an update, thanks!

  • I tried with sddm enabled and the same issue occurs.

    I’m seriously thinking about leaving this distro, i can’t spend whole evenings fixing bugs, i want to enjoy my system.
    I find it very unpleasant and insecure to have updates that breaks the system, not to mention having updates with conflicting packages that we have to find out what package to remove in order to successfully achieve the updates, that also happened a couple times in only about 3 months. ☹

  • @philipc I am using Cinnamon desktop and rarely had any issue in more than 2 years. Just works …that’s why I’m using it. I know you just had issues with the Nvidia drivers last week. I’m not sure if something was not right all along as I have Nvidia too but is a GTX 1060 desktop card. You are using different drivers than mine. I find Cinnamon to have little issues.

  • As i said in FB, hopefully it is :) but i thought something as Composition / backend of Kwin… change it or install openbox to use kde/openbox session to see if different… on my system 1 out 3 reboots i think it hangs if its past fsck dont get it. hopefully @philipc find the issue.

  • I installed new updates this morning and now the issue seems to be resolved using sddm service, but not with lightdm. Before lightdm(default) used to work fine. Now i still have this weird desktop flash when opening and a lag when hitting reboot button, but no screen blackouts.
    Here’s the updates i installed today :
    2019-04-30_08-17.png
    2019-04-30_08-18.png

  • @philipc 👍

    sddm is also better integraded on Kde

    as example having kcm-sddm, easily change wallpaper and theme and discover easliy change themes minor is if you remove discover it removes the sddm-themes from it also so keep that in mind :)

    anything done on checking the GL backend op composition also, to look ?

  • @philipc
    One thing with Nvidia drivers is that it seems to be better to use the dkms version(s). That is:

    sudo pacman -S --needed nvidia-dkms linux-headers linux-lts-headers
    

    instead of nvidia or nvidia-lts.

  • @manuel read back in the initcpio messages he uses nvidia-dkms
    ?

  • @ringo32
    I’m still quite a newbie, so checking the GL backend op composition i did’nt not do yet, i still have to figure out what this is and how to do it, loll!

  • @philipc at configuration at the monitor setting you find option of composition also there is backend is from from xrender to opengl 2.0 to opengl 3.1 on some system has some quirky behaviour general depend which system i think

system143 broken38 x113 completly2 Posts 47Views 139
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.