• A lot of services don't want to start randomly - systemd 242.0-3


    Hello!

    I would like to ask you for help / suggestion what is going on.
    I observed that some services can’t be started at OS boot sequence.
    Problem is very similar like topic here:
    https://forum.antergos.com/topic/11667/systemd-timesyncd-service-broken-since-systemd-242-0-1-update

    But… appears randomly and it’s applicable for more services <and unfortunately not timesyncd>.

    Here is a log from journalctl:

    kwi 28 01:45:49 odziom-pc systemd[1]: systemd-fsck-root.service: Start request repeated too quickly.
    kwi 28 01:45:49 odziom-pc systemd[1]: Failed to start File System Check on Root Device.
    kwi 28 01:45:49 odziom-pc systemd[1]: systemd-firstboot.service: Start request repeated too quickly.
    kwi 28 01:45:49 odziom-pc systemd[1]: Failed to start First Boot Wizard.
    kwi 28 01:45:49 odziom-pc systemd[1]: systemd-sysusers.service: Start request repeated too quickly.
    kwi 28 01:45:49 odziom-pc systemd[1]: Failed to start Create System Users.
    kwi 28 01:45:49 odziom-pc systemd[1]: systemd-hwdb-update.service: Start request repeated too quickly.
    kwi 28 01:45:49 odziom-pc systemd[1]: Failed to start Rebuild Hardware Database.
    kwi 28 01:45:49 odziom-pc systemd[1]: sys-fs-fuse-connections.mount: Start request repeated too quickly.
    kwi 28 01:45:49 odziom-pc systemd[1]: sys-fs-fuse-connections.mount: Failed with result 'start-limit-hit'.
    kwi 28 01:45:49 odziom-pc systemd[1]: Failed to mount FUSE Control File System.
    kwi 28 01:45:49 odziom-pc systemd-udevd[417]: Process '/usr/bin/alsactl restore 2' failed with exit code 99.
    

    I tried also install a fresh install of Antergos OS and I’ve got the same errors. Is it a problem with systemd package or something was changed and not works properly?

    Thanks in advance! :)

  • @odziom91 There is a new updated version of systemd so update and see if anything is different.

  • @ricklinux thanks for reply
    Unfortunately after upgrading to version 242.16-1 problem was not resolved…

  • @odziom91 What is strange is the fact that you said it’s the same after you said you reinstalled. Did you do stuff after a fresh install or did you try it right away? I find that odd because if it was okay prior to the 242.03 update it doesn’t make sense. What desktop is it you’re using?

  • Yep. I just downloaded a fresh Antergos ISO file and re-install system with full format. I thought that maybe something is wrong, but when I just reinstalled OS an error just come up on the first boot…
    I’m using MATE desktop environment.

    There is one more problem with OS - of course after reinstall too. “pluma” package is also broken (maybe?). Since few weeks I don’t have any text in this app - just only icons.

    pluma

    When I go to package manager and search for pluma package I see a description with unknown Chinese characters. :)

    pluma-pamac

  • @odziom91 I think this explains a lot. There have been a lot of issues with the Mate desktop as of late with missing packages or something from upstream? Were there any errors on the install from cinchi? I installed it last time with instructions and was able to get it working except for the Mate menu or something which you had to install the Brisk menu i think. So i did have it installed and working but i only did it to test that it could be done. I use Cinnamon and i don’t have any issues hardly ever. @manuel or @joekamprad would be able to give more info on this if you’re stuck on using Mate.

  • When I installed Antergos I observed a problem with Brisk menu. It’s installed but don’t show on MATE panel - I must add it manually, which is not a problem. Second problem - Numix default theme isn’t load as it should. Third problem is with “pluma” package as I mentioned in previous post. ;)

    Were there any errors on the install from cinchi?
    

    Nope. Installer download fresh packages from Internet and install without problems.

    Btw. Regarding to issue with systemd problems - I tried also to install Antergos with the same ISO file on VirtualBox. I’m shocked that works without errors… ☹
    I don’t know what is going on…

  • @odziom91 Did you look at any logs? before and or after reinstalling?

  • @odziom91 Have you made any hardware changes?

  • Did you look at any logs? before and or after reinstalling?
    

    I tried to find something in logs <dmesg, journalctl, systemctl> but nothing more was appear. <I guess. ;)>

    Have you made any hardware changes?
    

    No. Hardware is still the same.

    I checked right now status of systemctl.
    When I boot OS I receive problems with few services.
    After system is booted up and check systemctl --all I see that only one service is failed: sys-fs-fuse-connections.mount

    [[email protected] ~]$ systemctl status sys-fs-fuse-connections.mount
    ● sys-fs-fuse-connections.mount - FUSE Control File System
       Loaded: loaded (/usr/lib/systemd/system/sys-fs-fuse-connections.mount; static; vendor preset: disabled)
       Active: failed (Result: start-limit-hit)
        Where: /sys/fs/fuse/connections
         What: fusectl
         Docs: https://www.kernel.org/doc/Documentation/filesystems/fuse.txt
               https://www.freedesktop.org/wiki/Software/systemd/APIFileSystems
    
    kwi 28 23:09:39 odziom-pc systemd[1]: Condition check resulted in FUSE Control File System being skipped.
    kwi 28 23:09:39 odziom-pc systemd[1]: Condition check resulted in FUSE Control File System being skipped.
    kwi 28 23:09:39 odziom-pc systemd[1]: Condition check resulted in FUSE Control File System being skipped.
    kwi 28 23:09:39 odziom-pc systemd[1]: Condition check resulted in FUSE Control File System being skipped.
    kwi 28 23:09:40 odziom-pc systemd[1]: sys-fs-fuse-connections.mount: Start request repeated too quickly.
    kwi 28 23:09:40 odziom-pc systemd[1]: sys-fs-fuse-connections.mount: Failed with result 'start-limit-hit'.
    kwi 28 23:09:40 odziom-pc systemd[1]: Failed to mount FUSE Control File System.
    kwi 28 23:09:40 odziom-pc systemd[1]: sys-fs-fuse-connections.mount: Start request repeated too quickly.
    kwi 28 23:09:40 odziom-pc systemd[1]: sys-fs-fuse-connections.mount: Failed with result 'start-limit-hit'.
    kwi 28 23:09:40 odziom-pc systemd[1]: Failed to mount FUSE Control File System.
    
  • @odziom91 said in A lot of services don't want to start randomly - systemd 242.0-3:

    systemctl status sys-fs-fuse-connections.mount

    Maybe it’s not enabled or started. I get this on mine.

    [[email protected] ~]$ systemctl status sys-fs-fuse-connections.mount
    [sudo] password for rick: 
    ● sys-fs-fuse-connections.mount - FUSE Control File System
       Loaded: loaded (/usr/lib/systemd/system/sys-fs-fuse-connections.mount; static; vendor preset: disabled)
       Active: active (mounted) since Sun 2019-04-28 15:58:55 EDT; 2h 43min ago
        Where: /sys/fs/fuse/connections
         What: fusectl
         Docs: https://www.kernel.org/doc/Documentation/filesystems/fuse.txt
               https://www.freedesktop.org/wiki/Software/systemd/APIFileSystems
        Tasks: 0 (limit: 4915)
       Memory: 44.0K
       CGroup: /system.slice/sys-fs-fuse-connections.mount
    
    Apr 28 15:58:55 antergos-linux systemd[1]: Mounting FUSE Control File System...
    Apr 28 15:58:55 antergos-linux systemd[1]: Mounted FUSE Control File System.
    [[email protected] ~]$ 
     
    
    

    It say’s loaded, active, & mounted.

  • So. I think that this is a problem with… mounting NTFS partitions.
    When I disable all entries to ntfs-3g problem is gone and boot up without errors. 😐

    So where is a problem? Is it a problem with fstab configuration? I don’t think so, but maybe just look at my current config <which are always working fine, also before fresh install>.

    # /etc/fstab: static file system information.
    #
    # Use 'blkid' to print the universally unique identifier for a
    # device; this may be used with UUID= as a more robust way to name devices
    # that works even if disks are added and removed. See fstab(5).
    #
    # <file system> <mount point>   <type>  <options>       <dump>  <pass>
    #
    UUID=6EEB-E081 /boot/efi vfat defaults,noatime 0 0
    UUID=f94282e7-61b7-4fb0-8474-4cf1001fa176 /boot ext4 defaults,noatime,discard 0 0
    UUID=244e1878-b599-4fae-b373-ad054dc58bcc / ext4 defaults,noatime,discard 0 1
    UUID=abc70067-5eb0-484f-976c-c2f913046141 swap swap defaults 0 0
    
    # dodatkowe dyski
    UUID=c128dd6e-7d35-44d3-b5db-3d8554ffae51 /mnt/odziom/adata1 ext4 defaults 0 0
    UUID=9e403dea-5799-4693-942f-e633fb1dbb3e /mnt/odziom/crucial1 ext4 defaults 0 0
    UUID=2a0a3f57-d24d-40c3-a2f8-e3086531a613 /mnt/odziom/samsung1 ext4 defaults 0 0
    UUID=4071DF64329C45AC /mnt/odziom/toshiba1 ntfs-3g defaults,users 0 0
    UUID=4C0A9D4D0A9D3544 /mnt/odziom/toshiba2 ntfs-3g defaults,users 0 0
    UUID=5D9FBE5D4F105B01 /mnt/odziom/toshiba3 ntfs-3g defaults,users 0 0
    

    I have also surprised with other thing. I have a dual-boot option - Antergos together with Windows 10 <so stupid OS ;)>. And… I saw that Windows 10 checked an option “Fast startup” AGAIN… Unfortunately isn’t fix a problem with this service, but I don’t know why Micro$oft change OS options without my acceptance. 😓

  • @odziom91 Windows 10 is awful. When fast start up is enabled it creates Hiberfile. So may have something to do with it? I turn hibernation off in Windows with command prompt as admin.
    (powercfg.exe /h off)

  • I switched off but still with the same result. 😅
    So it looks like I should don’t use NTFS at all. 😄

    Temporary solution for me: disable all NTFS drives from fstab file.

  • @odziom91 So do you have ntfs-3g installed? That’s to be able to read ntfs. So you took out the entries in fstab for ntfs drives and it works now? Maybe you just don’t want to mount them on boot.

  • @odziom91 So…maybe it’s trying to mount the ntfs partitions on boot?

  • @odziom91 Okay i just checked my other system that is dual boot Windows 10 and i have no entries in fstab for windows only Antergos. So did you put them there? This is my output.

    # /etc/fstab: static file system information.
    #
    # Use 'blkid' to print the universally unique identifier for a
    # device; this may be used with UUID= as a more robust way to name devices
    # that works even if disks are added and removed. See fstab(5).
    #
    # <file system> <mount point>   <type>  <options>       <dump>  <pass>
    #
    UUID=6E8C-AA46 /boot/efi vfat defaults,noatime 0 0
    UUID=b027d051-8841-4ef8-b83d-c17b424b2b30 /boot ext4 defaults,noatime,discard 0 0
    UUID=91eed3d4-6964-47b4-b0ea-43464aa9aa44 / ext4 defaults,noatime,discard 0 1
    UUID=1d8a1b4a-caf5-4223-94db-d7c8a0b10608 swap swap defaults 0 0
    
    
  • @odziom91 said in A lot of services don't want to start randomly - systemd 242.0-3:

    So. I think that this is a problem with… mounting NTFS partitions.
    When I disable all entries to ntfs-3g problem is gone and boot up without errors. 😐

    So where is a problem? Is it a problem with fstab configuration? I don’t think so, but maybe just look at my current config <which are always working fine, also before fresh install>.

    # /etc/fstab: static file system information.
    #
    # Use 'blkid' to print the universally unique identifier for a
    # device; this may be used with UUID= as a more robust way to name devices
    # that works even if disks are added and removed. See fstab(5).
    #
    # <file system> <mount point>   <type>  <options>       <dump>  <pass>
    #
    UUID=6EEB-E081 /boot/efi vfat defaults,noatime 0 0
    UUID=f94282e7-61b7-4fb0-8474-4cf1001fa176 /boot ext4 defaults,noatime,discard 0 0
    UUID=244e1878-b599-4fae-b373-ad054dc58bcc / ext4 defaults,noatime,discard 0 1
    UUID=abc70067-5eb0-484f-976c-c2f913046141 swap swap defaults 0 0
    
    # dodatkowe dyski
    UUID=c128dd6e-7d35-44d3-b5db-3d8554ffae51 /mnt/odziom/adata1 ext4 defaults 0 0
    UUID=9e403dea-5799-4693-942f-e633fb1dbb3e /mnt/odziom/crucial1 ext4 defaults 0 0
    UUID=2a0a3f57-d24d-40c3-a2f8-e3086531a613 /mnt/odziom/samsung1 ext4 defaults 0 0
    UUID=4071DF64329C45AC /mnt/odziom/toshiba1 ntfs-3g defaults,users 0 0
    UUID=4C0A9D4D0A9D3544 /mnt/odziom/toshiba2 ntfs-3g defaults,users 0 0
    UUID=5D9FBE5D4F105B01 /mnt/odziom/toshiba3 ntfs-3g defaults,users 0 0
    

    I have also surprised with other thing. I have a dual-boot option - Antergos together with Windows 10 <so stupid OS ;)>. And… I saw that Windows 10 checked an option “Fast startup” AGAIN… Unfortunately isn’t fix a problem with this service, but I don’t know why Micro$oft change OS options without my acceptance. 😓

    I think it is a problem with fstab as those entries shouldn’t be there or they aren’t configured correctly? So everything working now?

  • Also systemd got some updates yesterday.

  • @odziom91
    You may want to check the option for the ntfs drives at /etc/fstab.
    Here’s the documentation: https://www.tuxera.com/community/open-source-ntfs-3g/

    I usually have these simple options for ntfs drives in /etc/fstab:

    UUID=<long-uuid-string> /mnt/drive1 ntfs defaults
    
systemd36 randomly13 services4 242.0-31 Posts 24Views 264
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.