• Flickering Boot Screen & Boot Failure


    Hi, after the GPU driver crashed during a game session, I was unable to get it back up and working because it returned ”Could not load GPU driver" or “cannot insert nvidia, device doesn’t exist”. So I decided to remove bumblebee and nvidia and reinstall them again. After a reboot, everything was fine till the OK from CUPS schedulers after which point I usually enter the DE but instead the screen starts flashing like its trying to connect and disconnect the monitor and it goes on forever. I booted using “nomodeset” and the flickering is gone but doesn’t go past the CUPS Scheduler with a blinking cursor. I couldn’t access tty2 during the flickering because it was very frequent and would throw me back to the original screen, but I managed to get logs with the “nomodeset”. It seems like an NVIDIA problem. I noticed that Start Kernel Module service seemed to fail and lightdm wasn’t started among other issues. Any help would be appreciated thanks.

    Logs: http://transfer.sh/Yb3tj/logs.tar

  • to boot with intel only use:

    modprobe.blacklist=nouveau
    

    at boot grub kernel line to boot with intel only, after uninstalled nvidia drivers is a workaround to get X started if something is failing…

    May also working with nvidia? modprobe.blacklist=nouveau modprobe.blacklist=nvidia so that you do not need to uninstall nvidia drivers to boot with intel only —

    Do you install (reinstall) bumblebee with nvidia-installer -b ?

  • @joekamprad yep, I installed(reinstalled) bumblebee with nvidia-installer -b idk why its so confused. I’ll try blacklisting the gpu drivers as soon as i can and report back.

  • @joekamprad Unfortunately blacklisting the GPU drivers does not help and I’m still getting a flickering screen with boot failure. I am also getting this error infinitely.

    Error Image

  • @HunterKiller
    I blacklisting doesn’t help, then you may also need to check files at /etc/X11/xorg.conf.d. If there are files, maybe some of them are not needed?

  • Also, reinstalling kernel, or using another kernel might help?

    sudo pacman -S linux linux-lts
    

    and reboot to the other kernel.

  • @manuel there are 4 files there. 1) 00-keyboard.conf 2) 10-optimus-manager.conf 3) 50-synaptics.conf 4) 99-killx.conf

    I tried reinstalling the kernel before, I’ll try again.

  • You may need to install more nvidia support if using the other kernel.
    I’d recommend installing nvidia-dkms instead of nvidia and nvidia-lts. Then you need also packages linux-headers and linux-lts-headers.

  • @manuel Reinstalled kernel and I’m still flickering at the CUPS scheduler. I’ll swap the nvidia driver and see if anything happens.

  • @HunterKiller
    Did you try blacklisting like

    modprobe.blacklist=nouveau,nvidia
    

    ?
    Also, some more info about your machine would help:

    yay -S inxi
    inxi -F
    

    Ah, and do you have anything special graphics related stuff in /etc/mkinitcpio.conf?

  • @manuel Blacklisting still doesn’t help.
    The output to inxi -F

    1

    I haven’t manually edited mkinitpcio.conf
    It has a bunch of comments and these.
    MODULES=""
    BINARIES=""
    FILES=""
    HOOKS=“base udev autodetect modconf block keyboard keymap resume filesystems fsck”

  • @HunterKiller
    The inxi tells you don’t have any graphics driver in use. Probably you had blacklisted all nvidia drivers, but there should be an Intel driver, probably i915.

    Which graphics drivers you have installed?

    pacman -Qs xf86-video
    pacman -Qs nvidia
    lsmod | grep i915
    

    And do you have something at /etc/modprobe.d?

  • It has Intel HD Graphics 4000

  • @manuel

    pacman -Qs xf86-video
    local/xf-86-video-fbdev 0 .5 .0-1 (xorg-drivers) 
    X.org framebuffer video driver 
    
    local/xf86-video-intel 1:2.99.917+863+g6afed33b-1 (xorg-drivers) 
    X.org Intel i810/i830/i915/945G/G965+ video drivers 
    
    local/xf86-video-vesa 2.4.0-2 (xorg-drivers xorg)
    X.org vesa video driver
    
    
    
    
    lsmod | grep i915
    
    i915 2166784 0
    i2c_algo_bit 16384 1 i915
    drm_kms_helper 208896 1 i915
    drm 499712 2 drm_kms_helper, i915
    intel_gtt 24576 1 i915
    

    pacman -Qs nvidia
    output

    I have dell-sum-hwmon.conf at /etc/modprobe.d

  • @HunterKiller
    You seem to have bumblebee and primus stuff for nvidia. Are those primus things there for a reason?

    I’ve personally noticed that having too many graphics drivers installed may cause weird issues.

  • @manuel Yes, they are there because my laptop is Optimus enabled. Intel HD 4000 & Nvidia GT640M. I have been using these same packages without issue for many months so I dont think the combination is the problem.

  • @HunterKiller
    I know, but why do you both primus and bumblebee? AFAIK they are alternative ways to handle hybrid graphics like yours. And which one of them are you using?

  • @manuel I use primus and bumblebee depending on the application.

  • @HunterKiller
    From all this info I guess this problem may come from two sources: graphics drivers, or graphics card(s).
    If the cause is the drivers, then take note of the setup, remove all but the Intel driver and blacklist nouveau, then reboot. Basically that should work.
    And if it doesn’t work, then one of the graphics cards may be broken.

  • @manuel I have windows installed and both cards are working. So it has to be a software problem

boot321 failure16 flickering8 Posts 30Views 117
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.