• locale set wrong


    Hi,

    I just discovered that my locale was set to en_AU.UTF-8 rather than en_GB.UTF-8. So I updated /etc/locale.gen to uncomment the GB locale and recomment the AU locale. I then updated /etc/locale.conf with:

    LANG="en_GB.UTF-8"
    LANGUAGE="en_GB"
    LC_CTYPE="en_GB.UTF-8"
    LC_MESSAGES="en_GB.UTF-8"
    LC_COLLATE="en_GB.UTF-8"
    LC_ALL="en_GB.UTF-8"
    

    I then ran locale-gen. Rebooted and nearly everything is correct now bar LANG which is still showing AU. Here’s the output of locale:

    LANG=en_AU.UTF-8
    LC_CTYPE="en_GB.UTF-8"
    LC_NUMERIC="en_GB.UTF-8"
    LC_TIME="en_GB.UTF-8"
    LC_COLLATE="en_GB.UTF-8"
    LC_MONETARY="en_GB.UTF-8"
    LC_MESSAGES="en_GB.UTF-8"
    LC_PAPER="en_GB.UTF-8"
    LC_NAME="en_GB.UTF-8"
    LC_ADDRESS="en_GB.UTF-8"
    LC_TELEPHONE="en_GB.UTF-8"
    LC_MEASUREMENT="en_GB.UTF-8"
    LC_IDENTIFICATION="en_GB.UTF-8"
    LC_ALL=en_GB.UTF-8
    

    And just for good measure locale -a:

    C
    en_GB.utf8
    POSIX
    

    How do I get the LANG to update?

  • @doyler78
    sudo localectl set-locale LANG=en_GB.UTF-8

  • @joekamprad Unfortunately that hasn’t worked. It’s still showing AU. I have rebooted after it.

    Working now. Another reboot seems to have sorted it.

  • @doyler78 Yes…reboot was necessary.

  • @ricklinux I did reboot after running the set-locale but when I logged in again and ran locale it was still showing AU. I decided to reboot again and check again and this time it changed. Very odd but glad it worked.

  • @doyler78 Ya…that’s seems typical …couple reboots from what i have seen and read.

  • @doyler78 How’s the wi-fi been working anyway? Antergos is really great isn’t it!

  • @ricklinux Wifi going strong. No problems since. I’ve been using Antergos for a couple of years now. I was initially worried about moving from Ubuntu given that Antergos is more bleeding edge but in that time I’ve had very few breakages and usually they are sorted fairly swiftly. I always have another partition with another linux distro and windows as well installed just in case of anything more major such as when I tried to clean up my pacman cache and completely broke it. Pacman thought nothing was installed. That was a reinstall job and lesson learned but that was on my desktop computer. I’ve about 5 linux partitions on that one but Antergos is the main on there also though all my server stuff runs in an Ubuntu Server VM.

  • @doyler78 Yes i have found the same. I like the fact that Antergos is rolling release and more bleeding edge so it updates more frequently than anything i have tried and it’s Arch. I use the Cinnamon desktop and i really haven’t found too many problems in all the time i have been using Antergos. It’s been a little bit of a learning curve but i learn something new everyday. It just works. I have been a distro hopper for a long time but once i found Antergos that was it for me. I do like some other versions but i have gotten away from the multi-boot set ups and currently i have only one desktop running Windows 10 dual boot with Antergos. It is a brand new desktop i just built this year so it has the latest hardware. Only keeping Windows around for other purposes but the goal is to be Linux only and Windows free! I have also used vm quite a bit but i prefer the OS installed. It does have it’s purpose and can work well with the right configurations and hardware. I’m glad you like Antergos and i think it is awesome.

  • This is a tip if something with Antergos goes really south:

    menuentry 'Boot Antergos ISO' {
        set isofile=/ISO/antergos-19.4-x86_64.iso    # change this line when new ISO is published
        search --no-floppy --set=root --file $isofile
        probe -u $root --set=uuid
        loopback loop $isofile
        linux (loop)/arch/boot/vmlinuz img_dev=/dev/disk/by-uuid/$uuid img_loop=$isofile
        initrd (loop)/arch/boot/intel_ucode.img (loop)/arch/boot/archiso.img
    }
    

    It is a new grub boot menu entry that boots from the Antergos ISO file! In case of an emergency, with this definition you can still boot, and fix problems in the real installation.

    Notes

    The above definition assumes that the Antergos ISO file antergos-19.4-x86_64.iso already exists in directory /ISO on some drive. Note that the drive should be formatted as ext4.

    Simply write the above definition to file /boot/grub/custom.cfg and reboot.

    Then you have a new menu entry as the last entry. Select that, and you boot the Antergos ISO directly.

locale9 Posts 10Views 46
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.