• systemd-timesyncd.service broken since systemd 242.0-1 update


    Since yesterdays systemd update, the synching of the system time to the network time via systemd-timesyncd.service is broken.

    systemctl status systemd-timesyncd.service
    ● systemd-timesyncd.service - Network Time Synchronization
       Loaded: loaded (/usr/lib/systemd/system/systemd-timesyncd.service; enabled; vendor preset: enabled)
       Active: failed (Result: exit-code) since Wed 2019-04-24 08:24:53 CEST; 8s ago
         Docs: man:systemd-timesyncd.service(8)
      Process: 5463 ExecStart=/usr/lib/systemd/systemd-timesyncd (code=exited, status=238/STATE_DIRECTORY)
     Main PID: 5463 (code=exited, status=238/STATE_DIRECTORY)
    
    Apr 24 08:24:53 p707 systemd[1]: systemd-timesyncd.service: Service has no hold-off time (RestartSec=0), sche>
    Apr 24 08:24:53 p707 systemd[1]: systemd-timesyncd.service: Scheduled restart job, restart counter is at 5.
    Apr 24 08:24:53 p707 systemd[1]: Stopped Network Time Synchronization.
    Apr 24 08:24:53 p707 systemd[1]: systemd-timesyncd.service: Start request repeated too quickly.
    Apr 24 08:24:53 p707 systemd[1]: systemd-timesyncd.service: Failed with result 'exit-code'.
    Apr 24 08:24:53 p707 systemd[1]: Failed to start Network Time Synchronization.
    
    

    Any suggestions?
    J.

  • @Jeannie____
    I just upgraded (after reading your post), and the systemd-timesyncd.service is working as expected. I know that doesn’t help you, and I’m sorry about that, but I thought it might be helpful to know that it does work for someone. 🤷‍♂️

  • @Jeannie____ Here is my output right now.

    [[email protected] ~]$ systemctl status systemd-timesyncd.service
    [sudo] password for rick:
    ● systemd-timesyncd.service - Network Time Synchronization
    Loaded: loaded (/usr/lib/systemd/system/systemd-timesyncd.service; enabled; vendor preset: enabled)
    Active: active (running) since Wed 2019-04-24 08:57:34 EDT; 4min 16s ago
    Docs: man:systemd-timesyncd.service(8)
    Main PID: 632 (systemd-timesyn)
    Status: “Synchronized to time server for the first time 206.108.0.132:123 (2.arch.pool.ntp.org).”
    Tasks: 2 (limit: 4915)
    Memory: 3.6M
    CGroup: /system.slice/systemd-timesyncd.service
    └─632 /usr/lib/systemd/systemd-timesyncd

    Apr 24 08:57:34 antergos-linux systemd[1]: Starting Network Time Synchronization…
    Apr 24 08:57:34 antergos-linux systemd-timesyncd[632]: The system is configured to read the RTC time in the local time zone. This mode cannot be fully supported. All system time to RTC updates are disabled.
    Apr 24 08:57:34 antergos-linux systemd[1]: Started Network Time Synchronization.
    Apr 24 08:58:06 antergos-linux systemd-timesyncd[632]: Synchronized to time server for the first time 206.108.0.132:123 (2.arch.pool.ntp.org).
    [[email protected] ~]$

  • @Jeannie____ Looks like it’s exiting as soon as it loads but don’t know why. Did you try starting the service? Is it enabled? I have mine set to RTC time local for dual boot with Windows.

  • @Jeannie____ sudo systemctl status systemd-timesyncd

    Try:

    sudo /usr/lib/systemd/systemd-timesyncd

  • @Jeannie____ said in systemd-timesyncd.service broken since systemd 242.0-1 update:
    what is :

    timedatectl show-timesync --all
    

    is one time server blocked?

  • @ringo32 Mine seems to have all ntp servers working.

  • @ringo32
    It times out after a couple of seconds.
    J.

  • @Jeannie____ here is the issue: https://github.com/systemd/systemd/issues/7605

    in short you have to delete ‘/var/lib/systemd/timesync’ manually

    $ sudo rm -rf '/var/lib/systemd/timesync'
    
  • @shizeeg said in systemd-timesyncd.service broken since systemd 242.0-1 update:

    https://github.com/systemd/systemd/issues/7605

    this is from 2017… (poettering closed this on 11 Dec 2017)

    But it looks like working:

    [email protected]>> sudo rm -rf '/var/lib/systemd/timesync'
    [sudo] Passwort für joekamprad: 
     [email protected]>> systemctl status systemd-timesyncd     
    ● systemd-timesyncd.service - Network Time Synchronization
       Loaded: loaded (/usr/lib/systemd/system/systemd-timesyncd.service; enabled; vendor preset: enabled)
       Active: failed (Result: exit-code) since Thu 2019-04-25 09:26:37 CEST; 14min ago
         Docs: man:systemd-timesyncd.service(8)
      Process: 560 ExecStart=/usr/lib/systemd/systemd-timesyncd (code=exited, status=238/STATE_DIRECTORY)
     Main PID: 560 (code=exited, status=238/STATE_DIRECTORY)
    
    Apr 25 09:26:37 antergos-system systemd[1]: Failed to start Network Time Synchronization.
    Apr 25 09:26:37 antergos-system systemd[1]: systemd-timesyncd.service: Service has no hold-off time (RestartSec=0), scheduling restart.
    Apr 25 09:26:37 antergos-system systemd[1]: systemd-timesyncd.service: Scheduled restart job, restart counter is at 5.
    Apr 25 09:26:37 antergos-system systemd[1]: Stopped Network Time Synchronization.
    Apr 25 09:26:37 antergos-system systemd[1]: systemd-timesyncd.service: Start request repeated too quickly.
    Apr 25 09:26:37 antergos-system systemd[1]: systemd-timesyncd.service: Failed with result 'exit-code'.
    Apr 25 09:26:37 antergos-system systemd[1]: Failed to start Network Time Synchronization.
     ✘ [email protected]>> systemctl restart systemd-timesyncd
     [email protected]>> systemctl status systemd-timesyncd 
    ● systemd-timesyncd.service - Network Time Synchronization
       Loaded: loaded (/usr/lib/systemd/system/systemd-timesyncd.service; enabled; vendor preset: enabled)
       Active: active (running) since Thu 2019-04-25 09:41:13 CEST; 1s ago
         Docs: man:systemd-timesyncd.service(8)
     Main PID: 23241 (systemd-timesyn)
       Status: "Synchronized to time server for the first time 176.9.100.86:123 (0.arch.pool.ntp.org)."
        Tasks: 2 (limit: 4915)
       Memory: 1.7M
       CGroup: /system.slice/systemd-timesyncd.service
               └─23241 /usr/lib/systemd/systemd-timesyncd
    
    Apr 25 09:41:12 antergos-system systemd[1]: Starting Network Time Synchronization...
    Apr 25 09:41:13 antergos-system systemd[1]: Started Network Time Synchronization.
    Apr 25 09:41:11 antergos-system systemd-timesyncd[23241]: Synchronized to time server for the first time 176.9.100.86:123 (0.arch.pool.ntp.org).
    
  • @ricklinux
    The process is still running, here’s what happened in the last 3 hours:

    [[email protected] ~]$ sudo /usr/lib/systemd/systemd-timesyncd
    [sudo] Passwort für jeannie: 
    Synchronized to time server for the first time 144.76.102.204:123 (0.arch.pool.ntp.org).
    Timed out waiting for reply from 144.76.102.204:123 (0.arch.pool.ntp.org).
    Synchronized to time server for the first time 178.63.9.212:123 (0.arch.pool.ntp.org).
  • @joekamprad
    I deleted /var/lib/systemd/timesync. Then I ran systemctl status systemd-timesyncd.
    Here’s the output:

    $ systemctl status systemd-timesyncd
    ● systemd-timesyncd.service - Network Time Synchronization
       Loaded: loaded (/usr/lib/systemd/system/systemd-timesyncd.service; enabled; vendor preset: enabled)
       Active: failed (Result: exit-code) since Thu 2019-04-25 09:53:11 CEST; 2h 12min ago
         Docs: man:systemd-timesyncd.service(8)
      Process: 661 ExecStart=/usr/lib/systemd/systemd-timesyncd (code=exited, status=238/STATE_DIRECTORY)
     Main PID: 661 (code=exited, status=238/STATE_DIRECTORY)
    
    Apr 25 09:53:11 p707 systemd[1]: systemd-timesyncd.service: Service has no hold-off time (RestartSec=0), sche>
    Apr 25 09:53:11 p707 systemd[1]: systemd-timesyncd.service: Scheduled restart job, restart counter is at 5.
    Apr 25 09:53:11 p707 systemd[1]: Stopped Network Time Synchronization.
    Apr 25 09:53:11 p707 systemd[1]: systemd-timesyncd.service: Start request repeated too quickly.
    Apr 25 09:53:11 p707 systemd[1]: systemd-timesyncd.service: Failed with result 'exit-code'.
    Apr 25 09:53:11 p707 systemd[1]: Failed to start Network Time Synchronization.
    ...skipping...
    ● systemd-timesyncd.service - Network Time Synchronization
       Loaded: loaded (/usr/lib/systemd/system/systemd-timesyncd.service; enabled; vendor preset: enabled)
       Active: failed (Result: exit-code) since Thu 2019-04-25 09:53:11 CEST; 2h 12min ago
         Docs: man:systemd-timesyncd.service(8)
      Process: 661 ExecStart=/usr/lib/systemd/systemd-timesyncd (code=exited, status=238/STATE_DIRECTORY)
     Main PID: 661 (code=exited, status=238/STATE_DIRECTORY)
    
    Apr 25 09:53:11 p707 systemd[1]: systemd-timesyncd.service: Service has no hold-off time (RestartSec=0), sche>
    Apr 25 09:53:11 p707 systemd[1]: systemd-timesyncd.service: Scheduled restart job, restart counter is at 5.
    Apr 25 09:53:11 p707 systemd[1]: Stopped Network Time Synchronization.
    Apr 25 09:53:11 p707 systemd[1]: systemd-timesyncd.service: Start request repeated too quickly.
    Apr 25 09:53:11 p707 systemd[1]: systemd-timesyncd.service: Failed with result 'exit-code'.
    Apr 25 09:53:11 p707 systemd[1]: Failed to start Network Time Synchronization.
    
    
  • @Jeannie____ needs to restart the service to take action:
    sudo systemctl restart systemd-timesyncd

  • @Jeannie____ Hi Jeannie,

    I had exactly the same issue you describe, in 13 independent Arch installations here. The sequence of commands below fixed the issue everywhere. Essentially, it repeats what was already suggested by @joekamprad.

    systemd-timesyncd fix

    systemctl status systemd-timesyncd
    systemctl stop systemd-timesyncd
    systemctl disable systemd-timesyncd
    sudo rm -rf '/var/lib/systemd/timesync'
    systemctl enable systemd-timesyncd
    systemctl start systemd-timesyncd
    systemctl status systemd-timesyncd
    
  • timedatectl timesync-status
    
  • @joekamprad
    Thanks, that did the trick. Issue solved.
    J.

  • @Jeannie____ said in systemd-timesyncd.service broken since systemd 242.0-1 update:

    systemctl status systemd-timesyncd

    I haven’t had that issue since the update.

       Loaded: loaded (/usr/lib/systemd/system/systemd-timesyncd.service; enabled; vendor preset: enabled)
       Active: active (running) since Thu 2019-04-25 07:46:55 EDT; 16min ago
         Docs: man:systemd-timesyncd.service(8)
     Main PID: 453 (systemd-timesyn)
       Status: "Synchronized to time server for the first time 154.11.146.39:123 (2.arch.pool.ntp.org)."
        Tasks: 2 (limit: 4915)
       Memory: 2.2M
       CGroup: /system.slice/systemd-timesyncd.service
               └─453 /usr/lib/systemd/systemd-timesyncd
    
    Apr 25 07:46:54 antergos-linux systemd[1]: Starting Network Time Synchronization...
    Apr 25 07:46:55 antergos-linux systemd[1]: Started Network Time Synchronization.
    Apr 25 07:47:24 antergos-linux systemd-timesyncd[453]: Synchronized to time server for the first time 154.11.146.39:123 (2.arch.pool.ntp.org).
    
broken38 systemd36 242.0-11 Posts 17Views 256
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.